From 4ee0fc1f25235a62940d839e82c2499a54c19ceb Mon Sep 17 00:00:00 2001
From: Jens Petersen <petersen@redhat.com>
Date: Sun, 29 Jul 2018 00:53:28 +0900
Subject: [PATCH] revise .cabal

---
 ghc-vector-algorithms.spec      |  10 ++-
 vector-algorithms-0.7.0.1.cabal | 118 ++++++++++++++++++++++++++++++++
 2 files changed, 125 insertions(+), 3 deletions(-)
 create mode 100644 vector-algorithms-0.7.0.1.cabal

diff --git a/ghc-vector-algorithms.spec b/ghc-vector-algorithms.spec
index 7ad29c4..48bd5fb 100644
--- a/ghc-vector-algorithms.spec
+++ b/ghc-vector-algorithms.spec
@@ -1,4 +1,4 @@
-# generated by cabal-rpm-0.12.1
+# generated by cabal-rpm-0.12.5
 # https://fedoraproject.org/wiki/Packaging:Haskell
 
 %global pkg_name vector-algorithms
@@ -8,12 +8,13 @@
 
 Name:           ghc-%{pkg_name}
 Version:        0.7.0.1
-Release:        4%{?dist}
+Release:        5%{?dist}
 Summary:        Efficient algorithms for vector arrays
 
 License:        BSD
 Url:            https://hackage.haskell.org/package/%{pkg_name}
 Source0:        https://hackage.haskell.org/package/%{pkgver}/%{pkgver}.tar.gz
+Source1:        https://hackage.haskell.org/package/%{pkgver}/%{pkg_name}.cabal#/%{pkgver}.cabal
 
 BuildRequires:  ghc-Cabal-devel
 BuildRequires:  ghc-rpm-macros
@@ -49,7 +50,7 @@ files.
 
 %prep
 %setup -q -n %{pkgver}
-cabal-tweak-dep-ver vector '< 0.12' '< 0.13'
+cp -p %{SOURCE1} %{pkg_name}.cabal
 
 
 %build
@@ -80,6 +81,9 @@ cabal-tweak-dep-ver vector '< 0.12' '< 0.13'
 
 
 %changelog
+* Sat Jul 28 2018 Jens Petersen <petersen@redhat.com> - 0.7.0.1-5
+- revise .cabal
+
 * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.0.1-4
 - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
 
diff --git a/vector-algorithms-0.7.0.1.cabal b/vector-algorithms-0.7.0.1.cabal
new file mode 100644
index 0000000..db4a504
--- /dev/null
+++ b/vector-algorithms-0.7.0.1.cabal
@@ -0,0 +1,118 @@
+name:              vector-algorithms
+version:           0.7.0.1
+x-revision: 1
+license:           BSD3
+license-file:      LICENSE
+author:            Dan Doel
+maintainer:        Dan Doel <dan.doel@gmail.com>
+copyright:         (c) 2008,2009,2010,2011,2012,2013,2014,2015 Dan Doel
+                   (c) 2015 Tim Baumann
+homepage:          http://code.haskell.org/~dolio/
+category:          Data
+synopsis:          Efficient algorithms for vector arrays
+description:       Efficient algorithms for vector arrays
+build-type:        Simple
+cabal-version:     >= 1.9.2
+
+flag BoundsChecks
+  description: Enable bounds checking
+  default: True
+
+flag UnsafeChecks
+  description: Enable bounds checking in unsafe operations at the cost of a
+               significant performance penalty.
+  default: False
+
+flag InternalChecks
+  description: Enable internal consistency checks at the cost of a
+               significant performance penalty.
+  default: False
+
+flag bench
+  description: Build a benchmarking program to test vector-algorithms
+               performance
+  default: False
+
+flag properties
+  description: Enable the quickcheck tests
+  default: True
+
+source-repository head
+  type:     darcs
+  location: http://hub.darcs.net/dolio/vector-algorithms
+
+library
+  hs-source-dirs: src
+
+  build-depends: base >= 4.5 && < 5,
+                 vector >= 0.6 && < 0.13,
+                 primitive >=0.3 && <0.7,
+                 bytestring >= 0.9 && < 1.0
+
+  exposed-modules:
+    Data.Vector.Algorithms.Optimal
+    Data.Vector.Algorithms.Insertion
+    Data.Vector.Algorithms.Intro
+    Data.Vector.Algorithms.Merge
+    Data.Vector.Algorithms.Radix
+    Data.Vector.Algorithms.Search
+    Data.Vector.Algorithms.Heap
+    Data.Vector.Algorithms.AmericanFlag
+    Data.Vector.Algorithms.Tim
+
+  other-modules:
+    Data.Vector.Algorithms.Common
+
+  ghc-options:
+    -Odph
+    -funbox-strict-fields
+
+  include-dirs:
+    include
+
+  install-includes:
+    vector.h
+
+  if flag(BoundsChecks)
+    cpp-options: -DVECTOR_BOUNDS_CHECKS
+
+  if flag(UnsafeChecks)
+    cpp-options: -DVECTOR_UNSAFE_CHECKS
+
+  if flag(InternalChecks)
+    cpp-options: -DVECTOR_INTERNAL_CHECKS
+
+executable vector-algorithms-bench
+  hs-source-dirs: bench
+
+  if !flag(bench)
+    buildable: False
+
+  main-is: Main.hs
+
+  other-modules:
+    Blocks
+
+  build-depends: base, mwc-random, vector, vector-algorithms, mtl
+  ghc-options: -Wall -Odph
+
+test-suite properties
+  hs-source-dirs: tests/properties
+  type: exitcode-stdio-1.0
+  main-is: Tests.hs
+
+  other-modules:
+    Optimal
+    Properties
+    Util
+
+  if !flag(properties)
+    buildable: False
+  else
+    build-depends:
+      base,
+      bytestring,
+      containers,
+      QuickCheck >= 2,
+      vector,
+      vector-algorithms