diff --git a/.gitignore b/.gitignore
index 93d7307..78d4a54 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
 /vector-algorithms-0.7.0.1.tar.gz
 /vector-algorithms-0.7.0.4.tar.gz
 /vector-algorithms-0.8.0.1.tar.gz
+/vector-algorithms-0.8.0.3.tar.gz
diff --git a/ghc-vector-algorithms.spec b/ghc-vector-algorithms.spec
index a4c5305..dda676c 100644
--- a/ghc-vector-algorithms.spec
+++ b/ghc-vector-algorithms.spec
@@ -7,15 +7,14 @@
 %bcond_with tests
 
 Name:           ghc-%{pkg_name}
-Version:        0.8.0.1
-Release:        2%{?dist}
+Version:        0.8.0.3
+Release:        1%{?dist}
 Summary:        Efficient algorithms for vector arrays
 
 License:        BSD
 Url:            https://hackage.haskell.org/package/%{pkg_name}
 # Begin cabal-rpm sources:
 Source0:        https://hackage.haskell.org/package/%{pkgver}/%{pkgver}.tar.gz
-Source1:        https://hackage.haskell.org/package/%{pkgver}/%{pkg_name}.cabal#/%{pkgver}.cabal
 # End cabal-rpm sources
 
 # Begin cabal-rpm deps:
@@ -74,7 +73,6 @@ This package provides the Haskell %{pkg_name} profiling library.
 %prep
 # Begin cabal-rpm setup:
 %setup -q -n %{pkgver}
-cp -bp %{SOURCE1} %{pkg_name}.cabal
 # End cabal-rpm setup
 
 
@@ -111,6 +109,7 @@ cp -bp %{SOURCE1} %{pkg_name}.cabal
 
 
 %files devel -f %{name}-devel.files
+%doc CHANGELOG.md
 
 
 %if %{with haddock}
@@ -125,6 +124,9 @@ cp -bp %{SOURCE1} %{pkg_name}.cabal
 
 
 %changelog
+* Fri Feb 14 2020 Jens Petersen <petersen@redhat.com> - 0.8.0.3-1
+- update to 0.8.0.3
+
 * Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.0.1-2
 - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
 
diff --git a/sources b/sources
index aed6b31..bf0a2ef 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-SHA512 (vector-algorithms-0.8.0.1.tar.gz) = 22ee41d20a502bb7ec209f1d0882b1a02c37ac563740c6174c7c09181d958ab37ec6bf64d67675edeb9f3659e03f48109122d17921d054c835c9e79a21c52643
+SHA512 (vector-algorithms-0.8.0.3.tar.gz) = 45311e19a1e5c9994e7d666b73445d11946f60915df3d2f385a435538d1b6b0929b56a960f83c5df1b2df883566e7f8e6fdd5be4e075364d7daecd6dbec780e5
diff --git a/vector-algorithms-0.8.0.1.cabal b/vector-algorithms-0.8.0.1.cabal
deleted file mode 100644
index 7951cee..0000000
--- a/vector-algorithms-0.8.0.1.cabal
+++ /dev/null
@@ -1,148 +0,0 @@
-name:              vector-algorithms
-version:           0.8.0.1
-x-revision: 2
-license:           BSD3
-license-file:      LICENSE
-author:            Dan Doel
-maintainer:        Dan Doel <dan.doel@gmail.com>
-                   Erik de Castro Lopo <erikd@mega-nerd.com>
-copyright:         (c) 2008,2009,2010,2011,2012,2013,2014,2015 Dan Doel
-                   (c) 2015 Tim Baumann
-homepage:          https://github.com/erikd/vector-algorithms/
-category:          Data
-synopsis:          Efficient algorithms for vector arrays
-description:       Efficient algorithms for sorting vector arrays. At some stage
-                   other vector algorithms may be added.
-build-type:        Simple
-cabal-version:     >= 1.9.2
-
-flag BoundsChecks
-  description: Enable bounds checking
-  default: True
-
-flag UnsafeChecks
-  description: Enable bounds checking in unsafe operations at the cost of a
-               significant performance penalty.
-  default: False
-
-flag InternalChecks
-  description: Enable internal consistency checks at the cost of a
-               significant performance penalty.
-  default: False
-
-flag bench
-  description: Build a benchmarking program to test vector-algorithms
-               performance
-  default: True
-
-flag properties
-  description: Enable the quickcheck tests
-  default: True
-
--- flag dump-simpl
---   description: Dumps the simplified core during compilation
---   default: False
-
-flag llvm
-  description: Build using llvm
-  default: False
-
-source-repository head
-  type:     git
-  location: https://github.com/erikd/vector-algorithms/
-
-library
-  hs-source-dirs: src
-
-  build-depends: base >= 4.5 && < 5,
-                 vector >= 0.6 && < 0.13,
-                 primitive >=0.3 && <0.8,
-                 bytestring >= 0.9 && < 1.0
-
-  if ! impl (ghc >= 7.8)
-    build-depends: tagged >= 0.4 && < 0.9
-
-  exposed-modules:
-    Data.Vector.Algorithms.Optimal
-    Data.Vector.Algorithms.Insertion
-    Data.Vector.Algorithms.Intro
-    Data.Vector.Algorithms.Merge
-    Data.Vector.Algorithms.Radix
-    Data.Vector.Algorithms.Search
-    Data.Vector.Algorithms.Heap
-    Data.Vector.Algorithms.AmericanFlag
-    Data.Vector.Algorithms.Tim
-
-  other-modules:
-    Data.Vector.Algorithms.Common
-
-  ghc-options:
-    -funbox-strict-fields
-
-  -- Cabal/Hackage complains about these
-  -- if flag(dump-simpl)
-  --   ghc-options: -ddump-simpl -ddump-to-file
-
-  if flag(llvm)
-    ghc-options: -fllvm
-
-  include-dirs:
-    include
-
-  install-includes:
-    vector.h
-
-  if flag(BoundsChecks)
-    cpp-options: -DVECTOR_BOUNDS_CHECKS
-
-  if flag(UnsafeChecks)
-    cpp-options: -DVECTOR_UNSAFE_CHECKS
-
-  if flag(InternalChecks)
-    cpp-options: -DVECTOR_INTERNAL_CHECKS
-
-benchmark simple-bench
-  hs-source-dirs: bench/simple
-  type: exitcode-stdio-1.0
-
-  if !flag(bench)
-    buildable: False
-
-  main-is: Main.hs
-
-  other-modules:
-    Blocks
-
-  build-depends: base, mwc-random, vector, vector-algorithms
-  ghc-options: -Wall
-
-  -- Cabal/Hackage complains about these
-  -- if flag(dump-simpl)
-  --   ghc-options: -ddump-simpl -ddump-to-file
-
-  if flag(llvm)
-    ghc-options: -fllvm
-
-test-suite properties
-  hs-source-dirs: tests/properties
-  type: exitcode-stdio-1.0
-  main-is: Tests.hs
-
-  other-modules:
-    Optimal
-    Properties
-    Util
-
-  if !flag(properties)
-    buildable: False
-  else
-    build-depends:
-      base,
-      bytestring,
-      containers,
-      QuickCheck > 2.9 && < 2.14,
-      vector,
-      vector-algorithms
-
-  if flag(llvm)
-    ghc-options: -fllvm