From f6739b3a7f4e4a7df9e84580d3e24355232174d6 Mon Sep 17 00:00:00 2001
From: Jens Petersen <petersen@redhat.com>
Date: Sun, 17 Feb 2019 22:47:43 +0800
Subject: [PATCH] refresh to cabal-rpm-0.13

---
 ghc-uuid-types.spec    |  21 ++++--
 uuid-types-1.0.3.cabal | 156 ++++++++++++++++++++---------------------
 2 files changed, 95 insertions(+), 82 deletions(-)

diff --git a/ghc-uuid-types.spec b/ghc-uuid-types.spec
index 73ede45..fb593a8 100644
--- a/ghc-uuid-types.spec
+++ b/ghc-uuid-types.spec
@@ -1,4 +1,4 @@
-# generated by cabal-rpm-0.12.5
+# generated by cabal-rpm-0.13
 # https://fedoraproject.org/wiki/Packaging:Haskell
 
 %global pkg_name uuid-types
@@ -8,17 +8,19 @@
 
 Name:           ghc-%{pkg_name}
 Version:        1.0.3
-Release:        9%{?dist}
+Release:        10%{?dist}
 Summary:        Type definitions for Universally Unique Identifiers
 
 License:        BSD
 Url:            https://hackage.haskell.org/package/%{pkg_name}
+# Begin cabal-rpm sources:
 Source0:        https://hackage.haskell.org/package/%{pkgver}/%{pkgver}.tar.gz
 Source1:        https://hackage.haskell.org/package/%{pkgver}/%{pkg_name}.cabal#/%{pkgver}.cabal
+# End cabal-rpm sources
 
+# Begin cabal-rpm deps:
 BuildRequires:  ghc-Cabal-devel
 BuildRequires:  ghc-rpm-macros
-# Begin cabal-rpm deps:
 BuildRequires:  ghc-binary-devel
 BuildRequires:  ghc-bytestring-devel
 BuildRequires:  ghc-deepseq-devel
@@ -56,16 +58,22 @@ This package provides the Haskell %{pkg_name} library development files.
 
 
 %prep
+# Begin cabal-rpm setup:
 %setup -q -n %{pkgver}
-cp -p %{SOURCE1} %{pkg_name}.cabal
+cp -bp %{SOURCE1} %{pkg_name}.cabal
+# End cabal-rpm setup
 
 
 %build
+# Begin cabal-rpm build:
 %ghc_lib_build
+# End cabal-rpm build
 
 
 %install
+# Begin cabal-rpm install
 %ghc_lib_install
+# End cabal-rpm install
 
 
 %check
@@ -81,7 +89,9 @@ cp -p %{SOURCE1} %{pkg_name}.cabal
 
 
 %files -f %{name}.files
+# Begin cabal-rpm files:
 %license LICENSE
+# End cabal-rpm files
 
 
 %files devel -f %{name}-devel.files
@@ -89,6 +99,9 @@ cp -p %{SOURCE1} %{pkg_name}.cabal
 
 
 %changelog
+* Sun Feb 17 2019 Jens Petersen <petersen@redhat.com> - 1.0.3-10
+- refresh to cabal-rpm-0.13
+
 * Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.3-9
 - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
 
diff --git a/uuid-types-1.0.3.cabal b/uuid-types-1.0.3.cabal
index 1bd6d21..3fecbb6 100644
--- a/uuid-types-1.0.3.cabal
+++ b/uuid-types-1.0.3.cabal
@@ -1,78 +1,78 @@
-Name: uuid-types
-Version: 1.0.3
-x-revision: 1
-Copyright: (c) 2008-2014 Antoine Latter
-Author: Antoine Latter
-Maintainer: aslatter@gmail.com
-License: BSD3
-License-file: LICENSE
-
-Category: Data
-Build-Type: Simple
-Cabal-Version: >= 1.8
-
-Description:
- This library contains type definitions for Universally Unique Identifiers
- and basic conversion functions.
-
- See <http://en.wikipedia.org/wiki/UUID> for the general idea.
-
-Synopsis: Type definitions for Universally Unique Identifiers
-
-Homepage: https://github.com/aslatter/uuid
-Bug-Reports: https://github.com/aslatter/uuid/issues
-
-Extra-Source-Files:
-     CHANGES
-
-
-Library
- Build-Depends: base >=3 && < 5,
-                binary >= 0.4 && < 0.9,
-                bytestring >= 0.9 && < 0.11,
-                deepseq >= 1.3 && < 1.5,
-                hashable (>= 1.1.1.0 && < 1.2.0) || (>= 1.2.1 && < 1.3),
-                random >= 1.0.1 && < 1.2,
-                text >= 1 && < 1.3
-
- Exposed-Modules:
-   Data.UUID.Types
-   -- Exposed for companion projects; *NOT* part of the official API:
-   Data.UUID.Types.Internal.Builder
-   Data.UUID.Types.Internal
-
- Extensions: DeriveDataTypeable
- Ghc-Options:        -Wall
-
-source-repository   head
-  type:             git
-  location:         https://github.com/aslatter/uuid.git
-
-Test-Suite testuuid
-    Type:              exitcode-stdio-1.0
-    Main-is:           TestUUID.hs
-    Hs-source-dirs:    tests
-    Extensions:        DeriveDataTypeable
-    Ghc-Options:       -Wall -fno-warn-orphans
-    Build-Depends:     base >= 3 && < 5,
-                       uuid-types,
-                       bytestring >= 0.9 && < 0.11,
-                       HUnit >=1.2 && < 1.4,
-                       QuickCheck >=2.4 && < 2.10,
-                       tasty >= 0.10 && < 0.12,
-                       tasty-hunit == 0.9.*,
-                       tasty-quickcheck == 0.8.*
-
-benchmark benchmark
-    Type:              exitcode-stdio-1.0
-    Main-is:           BenchUUID.hs
-    Hs-source-dirs:    tests
-    Extensions:        DeriveDataTypeable, CPP
-    Ghc-Options:       -Wall -fno-warn-orphans
-    Build-depends:     base == 4.*,
-                       uuid-types,
-                       bytestring >= 0.9 && < 0.11,
-                       containers >= 0.4 && < 0.6,
-                       criterion >= 0.4 && < 1.2,
-                       deepseq >= 1.1 && < 1.5,
-                       random >= 1.0.1 && < 1.2
+Name: uuid-types
+Version: 1.0.3
+x-revision: 1
+Copyright: (c) 2008-2014 Antoine Latter
+Author: Antoine Latter
+Maintainer: aslatter@gmail.com
+License: BSD3
+License-file: LICENSE
+
+Category: Data
+Build-Type: Simple
+Cabal-Version: >= 1.8
+
+Description:
+ This library contains type definitions for Universally Unique Identifiers
+ and basic conversion functions.
+
+ See <http://en.wikipedia.org/wiki/UUID> for the general idea.
+
+Synopsis: Type definitions for Universally Unique Identifiers
+
+Homepage: https://github.com/aslatter/uuid
+Bug-Reports: https://github.com/aslatter/uuid/issues
+
+Extra-Source-Files:
+     CHANGES
+
+
+Library
+ Build-Depends: base >=3 && < 5,
+                binary >= 0.4 && < 0.9,
+                bytestring >= 0.9 && < 0.11,
+                deepseq >= 1.3 && < 1.5,
+                hashable (>= 1.1.1.0 && < 1.2.0) || (>= 1.2.1 && < 1.3),
+                random >= 1.0.1 && < 1.2,
+                text >= 1 && < 1.3
+
+ Exposed-Modules:
+   Data.UUID.Types
+   -- Exposed for companion projects; *NOT* part of the official API:
+   Data.UUID.Types.Internal.Builder
+   Data.UUID.Types.Internal
+
+ Extensions: DeriveDataTypeable
+ Ghc-Options:        -Wall
+
+source-repository   head
+  type:             git
+  location:         https://github.com/aslatter/uuid.git
+
+Test-Suite testuuid
+    Type:              exitcode-stdio-1.0
+    Main-is:           TestUUID.hs
+    Hs-source-dirs:    tests
+    Extensions:        DeriveDataTypeable
+    Ghc-Options:       -Wall -fno-warn-orphans
+    Build-Depends:     base >= 3 && < 5,
+                       uuid-types,
+                       bytestring >= 0.9 && < 0.11,
+                       HUnit >=1.2 && < 1.4,
+                       QuickCheck >=2.4 && < 2.10,
+                       tasty >= 0.10 && < 0.12,
+                       tasty-hunit == 0.9.*,
+                       tasty-quickcheck == 0.8.*
+
+benchmark benchmark
+    Type:              exitcode-stdio-1.0
+    Main-is:           BenchUUID.hs
+    Hs-source-dirs:    tests
+    Extensions:        DeriveDataTypeable, CPP
+    Ghc-Options:       -Wall -fno-warn-orphans
+    Build-depends:     base == 4.*,
+                       uuid-types,
+                       bytestring >= 0.9 && < 0.11,
+                       containers >= 0.4 && < 0.6,
+                       criterion >= 0.4 && < 1.2,
+                       deepseq >= 1.1 && < 1.5,
+                       random >= 1.0.1 && < 1.2