diff --git a/ghc-unliftio-core.spec b/ghc-unliftio-core.spec
index 5d568d5..93f4218 100644
--- a/ghc-unliftio-core.spec
+++ b/ghc-unliftio-core.spec
@@ -1,4 +1,4 @@
-# generated by cabal-rpm-0.12
+# generated by cabal-rpm-0.13
 # https://fedoraproject.org/wiki/Packaging:Haskell
 
 %global pkg_name unliftio-core
@@ -6,16 +6,19 @@
 
 Name:           ghc-%{pkg_name}
 Version:        0.1.1.0
-Release:        5%{?dist}
+Release:        6%{?dist}
 Summary:        The MonadUnliftIO typeclass for unlifting monads to IO
 
 License:        MIT
 Url:            https://hackage.haskell.org/package/%{pkg_name}
+# Begin cabal-rpm sources:
 Source0:        https://hackage.haskell.org/package/%{pkgver}/%{pkgver}.tar.gz
+Source1:        https://hackage.haskell.org/package/%{pkgver}/%{pkg_name}.cabal#/%{pkgver}.cabal
+# End cabal-rpm sources
 
+# Begin cabal-rpm deps:
 BuildRequires:  ghc-Cabal-devel
 BuildRequires:  ghc-rpm-macros
-# Begin cabal-rpm deps:
 BuildRequires:  ghc-transformers-devel
 # End cabal-rpm deps
 
@@ -40,15 +43,22 @@ This package provides the Haskell %{pkg_name} library development files.
 
 
 %prep
+# Begin cabal-rpm setup:
 %setup -q -n %{pkgver}
+cp -bp %{SOURCE1} %{pkg_name}.cabal
+# End cabal-rpm setup
 
 
 %build
+# Begin cabal-rpm build:
 %ghc_lib_build
+# End cabal-rpm build
 
 
 %install
+# Begin cabal-rpm install
 %ghc_lib_install
+# End cabal-rpm install
 
 
 %post devel
@@ -60,7 +70,9 @@ This package provides the Haskell %{pkg_name} library development files.
 
 
 %files -f %{name}.files
+# Begin cabal-rpm files:
 %license LICENSE
+# End cabal-rpm files
 
 
 %files devel -f %{name}-devel.files
@@ -68,6 +80,9 @@ This package provides the Haskell %{pkg_name} library development files.
 
 
 %changelog
+* Sun Feb 17 2019 Jens Petersen <petersen@redhat.com> - 0.1.1.0-6
+- refresh to cabal-rpm-0.13
+
 * Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.1.0-5
 - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
 
diff --git a/unliftio-core-0.1.1.0.cabal b/unliftio-core-0.1.1.0.cabal
new file mode 100644
index 0000000..fc3a42b
--- /dev/null
+++ b/unliftio-core-0.1.1.0.cabal
@@ -0,0 +1,36 @@
+-- This file has been generated from package.yaml by hpack version 0.21.2.
+--
+-- see: https://github.com/sol/hpack
+--
+-- hash: 30994f07a9010e7816784501ed5ff3165c34026fa5dc555ebf1a70f6d6c0f1af
+
+name:           unliftio-core
+version:        0.1.1.0
+x-revision: 1
+synopsis:       The MonadUnliftIO typeclass for unlifting monads to IO
+description:    Please see the documentation and README at <https://www.stackage.org/package/unliftio-core>
+category:       Control
+homepage:       https://github.com/fpco/unliftio/tree/master/unliftio-core#readme
+author:         Michael Snoyman, Francesco Mazzoli
+maintainer:     michael@snoyman.com
+copyright:      2017 FP Complete
+license:        MIT
+license-file:   LICENSE
+build-type:     Simple
+cabal-version:  >= 1.10
+
+extra-source-files:
+    ChangeLog.md
+    README.md
+
+library
+  hs-source-dirs:
+      src
+  build-depends:
+      base >=4.5 && <4.12
+    , transformers >=0.2 && <0.6
+  exposed-modules:
+      Control.Monad.IO.Unlift
+  other-modules:
+      Paths_unliftio_core
+  default-language: Haskell2010