diff --git a/.gitignore b/.gitignore
index 420a1f1..cf0d5f1 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,2 +1,3 @@
/tls-1.4.0.tar.gz
/tls-1.4.1.tar.gz
+/tls-1.5.4.tar.gz
diff --git a/ghc-tls.spec b/ghc-tls.spec
index 329d872..72d2de4 100644
--- a/ghc-tls.spec
+++ b/ghc-tls.spec
@@ -7,15 +7,14 @@
%bcond_with tests
Name: ghc-%{pkg_name}
-Version: 1.4.1
-Release: 10%{?dist}
+Version: 1.5.4
+Release: 1%{?dist}
Summary: TLS/SSL protocol native implementation (Server and Client)
License: BSD
Url: https://hackage.haskell.org/package/%{pkg_name}
# Begin cabal-rpm sources:
Source0: https://hackage.haskell.org/package/%{pkgver}/%{pkgver}.tar.gz
-Source1: https://hackage.haskell.org/package/%{pkgver}/%{pkg_name}.cabal#/%{pkgver}.cabal
# End cabal-rpm sources
# Begin cabal-rpm deps:
@@ -29,6 +28,7 @@ BuildRequires: ghc-bytestring-prof
BuildRequires: ghc-cereal-prof
BuildRequires: ghc-cryptonite-prof
BuildRequires: ghc-data-default-class-prof
+BuildRequires: ghc-hourglass-prof
BuildRequires: ghc-memory-prof
BuildRequires: ghc-mtl-prof
BuildRequires: ghc-network-prof
@@ -38,7 +38,6 @@ BuildRequires: ghc-x509-store-prof
BuildRequires: ghc-x509-validation-prof
%if %{with tests}
BuildRequires: ghc-QuickCheck-devel
-BuildRequires: ghc-hourglass-devel
BuildRequires: ghc-tasty-devel
BuildRequires: ghc-tasty-quickcheck-devel
%endif
@@ -51,9 +50,9 @@ This provides a high-level implementation of a sensitive security protocol,
eliminating a common set of security issues through the use of the advanced
type system, high level constructions and common Haskell features.
-Currently implement the SSL3.0, TLS1.0, TLS1.1 and TLS1.2 protocol, and support
-RSA and Ephemeral (Elliptic curve and regular) Diffie Hellman key exchanges,
-and many extensions.
+Currently implement the SSL3.0, TLS1.0, TLS1.1, TLS1.2 and TLS 1.3 protocol,
+and support RSA and Ephemeral (Elliptic curve and regular) Diffie Hellman key
+exchanges, and many extensions.
Some debug tools linked with tls, are available through the
.
@@ -96,7 +95,6 @@ This package provides the Haskell %{pkg_name} profiling library.
%prep
# Begin cabal-rpm setup:
%setup -q -n %{pkgver}
-cp -bp %{SOURCE1} %{pkg_name}.cabal
# End cabal-rpm setup
@@ -148,6 +146,9 @@ cp -bp %{SOURCE1} %{pkg_name}.cabal
%changelog
+* Wed Jun 10 2020 Jens Petersen - 1.5.4-1
+- update to 1.5.4
+
* Wed Feb 19 2020 Jens Petersen - 1.4.1-10
- refresh to cabal-rpm-2.0.2
diff --git a/sources b/sources
index e2d80d8..d31b890 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-SHA512 (tls-1.4.1.tar.gz) = a72435af9d3188fb19d6367089bc598ec17e845eccfbeb3457da89c3a3eb3f47b6041b4d2be6bff63e0c40e110b1eb8b176380e5acb82641869df4dfb871d9fd
+SHA512 (tls-1.5.4.tar.gz) = fb95ab6012ed95d82a41810b83e6f779645fa56d46c57f34a954a6885c295737808edcdcdca9e88e5b3c663f5aee71f104fe1fdd9ab35fb6a8ade4a202376d4a
diff --git a/tls-1.4.1.cabal b/tls-1.4.1.cabal
deleted file mode 100644
index 24068a7..0000000
--- a/tls-1.4.1.cabal
+++ /dev/null
@@ -1,174 +0,0 @@
-Name: tls
-Version: 1.4.1
-x-revision: 1
-Description:
- Native Haskell TLS and SSL protocol implementation for server and client.
- .
- This provides a high-level implementation of a sensitive security protocol,
- eliminating a common set of security issues through the use of the advanced
- type system, high level constructions and common Haskell features.
- .
- Currently implement the SSL3.0, TLS1.0, TLS1.1 and TLS1.2 protocol,
- and support RSA and Ephemeral (Elliptic curve and regular) Diffie Hellman key exchanges,
- and many extensions.
- .
- Some debug tools linked with tls, are available through the
- .
-License: BSD3
-License-file: LICENSE
-Copyright: Vincent Hanquez
-Author: Vincent Hanquez
-Maintainer: Vincent Hanquez
-Synopsis: TLS/SSL protocol native implementation (Server and Client)
-Build-Type: Simple
-Category: Network
-stability: experimental
-Cabal-Version: >=1.8
-Homepage: http://github.com/vincenthz/hs-tls
-extra-source-files: Tests/*.hs
- CHANGELOG.md
-
-Flag compat
- Description: Accept SSLv2 client hello for beginning SSLv3 / TLS handshake
- Default: True
- Manual: True
-
-Flag network
- Description: Use the base network library
- Default: True
- Manual: True
-
-Flag hans
- Description: Use the Haskell Network Stack (HaNS)
- Default: False
- Manual: True
-
-Library
- Build-Depends: base >= 4.7 && < 5
- , mtl >= 2
- , transformers
- , cereal >= 0.4
- , bytestring
- , data-default-class
- -- crypto related
- , memory >= 0.14.6
- , cryptonite >= 0.24
- -- certificate related
- , asn1-types >= 0.2.0
- , asn1-encoding
- , x509 >= 1.7.1
- , x509-store >= 1.6
- , x509-validation >= 1.6.5
- , async >= 2.0
- if flag(network)
- Build-Depends: network >= 2.4.0.0
- cpp-options: -DINCLUDE_NETWORK
- if flag(hans)
- Build-Depends: hans
- cpp-options: -DINCLUDE_HANS
- Exposed-modules: Network.TLS
- Network.TLS.Cipher
- Network.TLS.Compression
- Network.TLS.Internal
- Network.TLS.Extra
- Network.TLS.Extra.Cipher
- Network.TLS.Extra.FFDHE
- other-modules: Network.TLS.Cap
- Network.TLS.Struct
- Network.TLS.Core
- Network.TLS.Context
- Network.TLS.Context.Internal
- Network.TLS.Credentials
- Network.TLS.Backend
- Network.TLS.Crypto
- Network.TLS.Crypto.DH
- Network.TLS.Crypto.IES
- Network.TLS.Crypto.Types
- Network.TLS.ErrT
- Network.TLS.Extension
- Network.TLS.Handshake
- Network.TLS.Handshake.Common
- Network.TLS.Handshake.Certificate
- Network.TLS.Handshake.Key
- Network.TLS.Handshake.Client
- Network.TLS.Handshake.Server
- Network.TLS.Handshake.Process
- Network.TLS.Handshake.Signature
- Network.TLS.Handshake.State
- Network.TLS.Hooks
- Network.TLS.IO
- Network.TLS.Imports
- Network.TLS.MAC
- Network.TLS.Measurement
- Network.TLS.Packet
- Network.TLS.Parameters
- Network.TLS.Record
- Network.TLS.Record.Types
- Network.TLS.Record.Engage
- Network.TLS.Record.Disengage
- Network.TLS.Record.State
- Network.TLS.RNG
- Network.TLS.State
- Network.TLS.Session
- Network.TLS.Sending
- Network.TLS.Receiving
- Network.TLS.Util
- Network.TLS.Util.ASN1
- Network.TLS.Util.Serialization
- Network.TLS.Types
- Network.TLS.Wire
- Network.TLS.X509
- ghc-options: -Wall
- if flag(compat)
- cpp-options: -DSSLV2_COMPATIBLE
-
-Test-Suite test-tls
- type: exitcode-stdio-1.0
- hs-source-dirs: Tests
- Main-is: Tests.hs
- other-modules: Certificate
- Ciphers
- Connection
- Marshalling
- PipeChan
- PubKey
- Build-Depends: base >= 3 && < 5
- , mtl
- , cereal >= 0.3
- , data-default-class
- , tasty
- , tasty-quickcheck
- , tls
- , QuickCheck
- , cryptonite
- , bytestring
- , asn1-types
- , x509
- , x509-validation
- , hourglass
- ghc-options: -Wall -fno-warn-unused-imports
-
-Benchmark bench-tls
- hs-source-dirs: Benchmarks Tests
- Main-Is: Benchmarks.hs
- type: exitcode-stdio-1.0
- Build-depends: base >= 4 && < 5
- , tls
- , x509
- , x509-validation
- , data-default-class
- , cryptonite
- , criterion >= 1.0
- , mtl
- , bytestring
- , asn1-types
- , hourglass
- , QuickCheck >= 2
- , tasty-quickcheck
- , tls
- ghc-options: -Wall -fno-warn-unused-imports
-
-source-repository head
- type: git
- location: https://github.com/vincenthz/hs-tls
- subdir: core