diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..f5c7f93
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+/tls-1.4.0.tar.gz
diff --git a/README.md b/README.md
deleted file mode 100644
index 3c1d3bc..0000000
--- a/README.md
+++ /dev/null
@@ -1,3 +0,0 @@
-# ghc-tls
-
-The ghc-tls package
\ No newline at end of file
diff --git a/ghc-tls.spec b/ghc-tls.spec
new file mode 100644
index 0000000..3a7d9a6
--- /dev/null
+++ b/ghc-tls.spec
@@ -0,0 +1,128 @@
+# generated by cabal-rpm-0.11.2
+# https://fedoraproject.org/wiki/Packaging:Haskell
+
+%global pkg_name tls
+%global pkgver %{pkg_name}-%{version}
+
+%bcond_with tests
+
+Name: ghc-%{pkg_name}
+Version: 1.4.0
+Release: 1.git.0.35b2e21%{?dist}
+Summary: TLS/SSL protocol native implementation (Server and Client)
+
+License: BSD
+Url: https://hackage.haskell.org/package/%{pkg_name}
+Source0: https://hackage.haskell.org/package/%{pkgver}/%{pkgver}.tar.gz
+
+BuildRequires: ghc-Cabal-devel
+BuildRequires: ghc-rpm-macros
+# Begin cabal-rpm deps:
+BuildRequires: ghc-asn1-encoding-devel
+BuildRequires: ghc-asn1-types-devel
+BuildRequires: ghc-async-devel
+BuildRequires: ghc-bytestring-devel
+BuildRequires: ghc-cereal-devel
+BuildRequires: ghc-cryptonite-devel
+BuildRequires: ghc-data-default-class-devel
+BuildRequires: ghc-memory-devel
+BuildRequires: ghc-mtl-devel
+BuildRequires: ghc-network-devel
+BuildRequires: ghc-transformers-devel
+BuildRequires: ghc-x509-devel
+BuildRequires: ghc-x509-store-devel
+BuildRequires: ghc-x509-validation-devel
+%if %{with tests}
+BuildRequires: ghc-QuickCheck-devel
+BuildRequires: ghc-hourglass-devel
+BuildRequires: ghc-tasty-devel
+BuildRequires: ghc-tasty-quickcheck-devel
+%endif
+# End cabal-rpm deps
+
+%description
+Native Haskell TLS and SSL protocol implementation for server and client.
+
+This provides a high-level implementation of a sensitive security protocol,
+eliminating a common set of security issues through the use of the advanced
+type system, high level constructions and common Haskell features.
+
+Currently implement the SSL3.0, TLS1.0, TLS1.1 and TLS1.2 protocol, and support
+RSA and Ephemeral (Elliptic curve and regular) Diffie Hellman key exchanges,
+and many extensions.
+
+Some debug tools linked with tls, are available through the
+.
+
+
+%package devel
+Summary: Haskell %{pkg_name} library development files
+Provides: %{name}-static = %{version}-%{release}
+Requires: ghc-compiler = %{ghc_version}
+Requires(post): ghc-compiler = %{ghc_version}
+Requires(postun): ghc-compiler = %{ghc_version}
+Requires: %{name}%{?_isa} = %{version}-%{release}
+
+%description devel
+This package provides the Haskell %{pkg_name} library development files.
+
+
+%prep
+%setup -q -n %{pkgver}
+
+
+%build
+%ghc_lib_build
+
+
+%install
+%ghc_lib_install
+
+
+%check
+%cabal_test
+
+
+%post devel
+%ghc_pkg_recache
+
+
+%postun devel
+%ghc_pkg_recache
+
+
+%files -f %{name}.files
+%license LICENSE
+
+
+%files devel -f %{name}-devel.files
+%doc CHANGELOG.md
+
+
+%changelog
+* Sun Sep 24 2017 Elliott Sales de Andrade 1.4.0-1
+- Update to latest version.
+- Update to latest spec template.
+
+* Sun Jul 23 2017 Elliott Sales de Andrade 1.3.10-2
+- Update to almost-latest version.
+- Add patch enabling newer ghc-x509.
+
+* Fri Jul 21 2017 Elliott Sales de Andrade 1.3.5-5
+- Bump for Fedora 26.
+
+* Fri Dec 16 2016 Elliott Sales de Andrade - 1.3.5-4
+- spec file generated by cabal-rpm-0.10.0
+- Update release to be newer than previous builds
+
+* Sun May 01 2016 Elliott Sales de Andrade - 1.3.5-3
+- Bump to rebuild against new dependencies
+
+* Fri Apr 29 2016 Elliott Sales de Andrade - 1.3.5-2
+- Bump to rebuild against dependencies
+
+* Sun Apr 24 2016 Elliott Sales de Andrade - 1.3.5-1
+- update to 1.3.5
+
+* Sun Aug 23 2015 Ben Boeckel - 1.3.1-1
+- initial package
diff --git a/sources b/sources
new file mode 100644
index 0000000..5802169
--- /dev/null
+++ b/sources
@@ -0,0 +1 @@
+SHA512 (tls-1.4.0.tar.gz) = f4130b19c764f3423481b23c0d8f09540baf6cbb066045796ac28f030a3c43ac0efd342fe1ceceb0aa4d33a9cfc3b2c9d5d216e758a43a31d32a1fbee022921a