From f7e7e654f69d5bc6e9d1c5c64352600a10958dae Mon Sep 17 00:00:00 2001
From: Jens Petersen <petersen@redhat.com>
Date: Wed, 4 Aug 2021 22:29:12 +0800
Subject: [PATCH] revise .cabal

---
 ghc-split.spec      |  3 +++
 split-0.2.3.4.cabal | 58 +++++++++++++++++++++++++++++++++++++++++++++
 2 files changed, 61 insertions(+)
 create mode 100644 split-0.2.3.4.cabal

diff --git a/ghc-split.spec b/ghc-split.spec
index bcbef9e..dca3610 100644
--- a/ghc-split.spec
+++ b/ghc-split.spec
@@ -16,9 +16,11 @@ License:        BSD
 Url:            https://hackage.haskell.org/package/%{pkg_name}
 # Begin cabal-rpm sources:
 Source0:        https://hackage.haskell.org/package/%{pkgver}/%{pkgver}.tar.gz
+Source1:        https://hackage.haskell.org/package/%{pkgver}/%{pkg_name}.cabal#/%{pkgver}.cabal
 # End cabal-rpm sources
 
 # Begin cabal-rpm deps:
+BuildRequires:  dos2unix
 BuildRequires:  ghc-Cabal-devel
 BuildRequires:  ghc-rpm-macros
 BuildRequires:  ghc-base-prof
@@ -84,6 +86,7 @@ This package provides the Haskell %{pkg_name} profiling library.
 %prep
 # Begin cabal-rpm setup:
 %setup -q -n %{pkgver}
+dos2unix -k -n %{SOURCE1} %{pkg_name}.cabal
 # End cabal-rpm setup
 
 
diff --git a/split-0.2.3.4.cabal b/split-0.2.3.4.cabal
new file mode 100644
index 0000000..ee5aa61
--- /dev/null
+++ b/split-0.2.3.4.cabal
@@ -0,0 +1,58 @@
+Name:                split
+Version:             0.2.3.4
+x-revision: 1
+Stability:           stable
+
+Description:         A collection of various methods for splitting
+                     lists into parts, akin to the \"split\" function
+                     found in several mainstream languages. Here is
+                     its tale:
+                     .
+                     Once upon a time the standard "Data.List" module
+                     held no function for splitting a list into parts
+                     according to a delimiter.  Many a brave
+                     lambda-knight strove to add such a function, but
+                     their striving was in vain, for Lo, the Supreme
+                     Council fell to bickering amongst themselves what
+                     was to be the essential nature of the One True
+                     Function which could cleave a list in twain (or
+                     thrain, or any required number of parts).
+                     .
+                     And thus came to pass the split package,
+                     comprising divers functions for splitting a list
+                     asunder, each according to its nature.  And the
+                     Supreme Council had no longer any grounds for
+                     argument, for the favored method of each was
+                     contained therein.
+                     .
+                     To get started, see the "Data.List.Split" module.
+Synopsis:            Combinator library for splitting lists.
+License:             BSD3
+License-file:        LICENSE
+Copyright:           (c) Brent Yorgey, Louis Wasserman 2008-2012
+Extra-source-files:  README, test/Properties.hs, CHANGES
+Author:              Brent Yorgey
+Maintainer:          byorgey@gmail.com
+Category:            List
+Build-type:          Simple
+Cabal-Version:       >= 1.10
+Tested-with:         GHC ==7.0.4 || ==7.2.2 || ==7.4.2 || ==7.6.3 || ==7.8.4 || ==7.10.3 || ==8.0.2 || ==8.2.2 || ==8.4.4 || ==8.6.5 || ==8.8.4 || ==8.10.4 || ==9.0.1
+Bug-reports:         https://github.com/byorgey/split/issues
+
+Test-suite split-tests
+  type:              exitcode-stdio-1.0
+  main-is:           Properties.hs
+  build-depends:     base, QuickCheck >= 2.4, split
+  default-language:  Haskell2010
+  Hs-source-dirs:    test
+
+Source-repository head
+  type:              git
+  location:          http://github.com/byorgey/split.git
+
+Library
+  ghc-options:       -Wall
+  build-depends:     base < 4.16
+  exposed-modules:   Data.List.Split, Data.List.Split.Internals
+  default-language:  Haskell2010
+  Hs-source-dirs:    src