diff --git a/ghc-rpm-macros.spec b/ghc-rpm-macros.spec
index 7c55e4f..b8ec7ab 100644
--- a/ghc-rpm-macros.spec
+++ b/ghc-rpm-macros.spec
@@ -11,7 +11,7 @@
 
 Name:           ghc-rpm-macros
 Version:        1.6.15
-Release:        1%{?dist}
+Release:        2%{?dist}
 Summary:        RPM macros for building Haskell packages for GHC
 
 License:        GPLv3+
@@ -147,6 +147,9 @@ EOF
 
 
 %changelog
+* Tue Feb 14 2017 Jens Petersen <petersen@redhat.com> - 1.6.15-2
+- do not set CFLAGS on ppc64 or ppc64le due to -Wunused-label noise
+
 * Mon Feb 13 2017 Jens Petersen <petersen@redhat.com> - 1.6.15-1
 - fix handling of ghc's .files with new ghc_lib_subpackage -d option
 
diff --git a/macros.ghc b/macros.ghc
index 433474e..736febf 100644
--- a/macros.ghc
+++ b/macros.ghc
@@ -27,7 +27,7 @@ fi
 %ghc_check_bootstrap\
 %global _hardened_ldflags %{nil}\
 # -Wunused-label is extremely noisy: remove for ghc-8.0\
-%ifnarch aarch64\
+%ifnarch aarch64 ppc64 ppc64le\
 CFLAGS="${CFLAGS:-%optflags}"; export CFLAGS\
 %endif\
 LDFLAGS="${LDFLAGS:-%{?__global_ldflags}}"; export LDFLAGS\