diff --git a/ghc-old-locale.spec b/ghc-old-locale.spec
index 7d15311..b58de14 100644
--- a/ghc-old-locale.spec
+++ b/ghc-old-locale.spec
@@ -1,4 +1,4 @@
-# generated by cabal-rpm-0.12.1
+# generated by cabal-rpm-0.12.5
 # https://fedoraproject.org/wiki/Packaging:Haskell
 
 %global pkg_name old-locale
@@ -6,12 +6,13 @@
 
 Name:           ghc-%{pkg_name}
 Version:        1.0.0.7
-Release:        9%{?dist}
+Release:        10%{?dist}
 Summary:        Locale library
 
 License:        BSD
 Url:            https://hackage.haskell.org/package/%{pkg_name}
 Source0:        https://hackage.haskell.org/package/%{pkgver}/%{pkgver}.tar.gz
+Source1:        https://hackage.haskell.org/package/%{pkgver}/%{pkg_name}.cabal#/%{pkgver}.cabal
 
 BuildRequires:  ghc-Cabal-devel
 BuildRequires:  ghc-rpm-macros
@@ -38,7 +39,7 @@ This package provides the Haskell %{pkg_name} library development files.
 
 %prep
 %setup -q -n %{pkgver}
-cabal-tweak-dep-ver base '< 4.9' '< 4.11'
+cp -p %{SOURCE1} %{pkg_name}.cabal
 
 
 %build
@@ -66,6 +67,9 @@ cabal-tweak-dep-ver base '< 4.9' '< 4.11'
 
 
 %changelog
+* Sat Feb 16 2019 Jens Petersen <petersen@redhat.com> - 1.0.0.7-10
+- use revised .cabal file
+
 * Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.0.7-9
 - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
 
diff --git a/old-locale-1.0.0.7.cabal b/old-locale-1.0.0.7.cabal
new file mode 100644
index 0000000..13dd2dd
--- /dev/null
+++ b/old-locale-1.0.0.7.cabal
@@ -0,0 +1,36 @@
+name:         old-locale
+version:      1.0.0.7
+x-revision: 2
+-- NOTE: Don't forget to update ./changelog.md
+license:      BSD3
+license-file: LICENSE
+maintainer:   libraries@haskell.org
+bug-reports:  https://github.com/haskell/old-locale/issues
+synopsis:     locale library
+category:     System
+build-type:   Simple
+Cabal-Version:>=1.10
+tested-with:  GHC==7.8.3, GHC==7.8.2, GHC==7.8.1, GHC==7.6.3, GHC==7.6.2, GHC==7.6.1, GHC==7.4.2, GHC==7.4.1, GHC==7.2.2, GHC==7.2.1, GHC==7.0.4, GHC==7.0.3, GHC==7.0.2, GHC==7.0.1, GHC==6.12.3
+description:
+    This package provides the ability to adapt to
+    locale conventions such as date and time formats.
+
+extra-source-files:
+    changelog.md
+
+source-repository head
+    type:     git
+    location: https://github.com/haskell/old-locale.git
+
+Library
+    default-language: Haskell98
+    other-extensions: CPP
+    if impl(ghc>=7.2)
+        -- && base>=4.4.1
+        other-extensions: Safe
+
+    exposed-modules:
+        System.Locale
+
+    build-depends: base >= 4.2 && < 5
+    ghc-options: -Wall