commit d8d8bcec9d30cc3153cf5347e60def145d58963c
Author: Alexey Lyubimov <a.lyubimov@softline.com>
Date:   Fri Aug 25 15:20:00 2023 +0300

    import ghc-indexed-traversable-0.1.2-1.el9

diff --git a/.ghc-indexed-traversable.metadata b/.ghc-indexed-traversable.metadata
new file mode 100644
index 0000000..bd0a03c
--- /dev/null
+++ b/.ghc-indexed-traversable.metadata
@@ -0,0 +1 @@
+f5d62dc076611bbf788f0931626dcc414d4534e0  SOURCES/indexed-traversable-0.1.2.tar.gz
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..0428877
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+SOURCES/indexed-traversable-0.1.2.tar.gz
diff --git a/SOURCES/indexed-traversable-0.1.2.cabal b/SOURCES/indexed-traversable-0.1.2.cabal
new file mode 100644
index 0000000..cdcd465
--- /dev/null
+++ b/SOURCES/indexed-traversable-0.1.2.cabal
@@ -0,0 +1,93 @@
+cabal-version:      1.12
+name:               indexed-traversable
+version:            0.1.2
+x-revision:         1
+build-type:         Simple
+license:            BSD2
+license-file:       LICENSE
+category:           Data
+maintainer:         Oleg Grenrus <oleg.grenrus@iki.fi>
+author:             Edward Kmett
+synopsis:           FunctorWithIndex, FoldableWithIndex, TraversableWithIndex
+description:
+  This package provides three useful generalizations:
+  .
+  @
+  class Functor f => FunctorWithIndex i f | f -> i where
+  \  imap :: (i -> a -> b) -> f a -> f b
+  @
+  .
+  @
+  class Foldable f => FoldableWithIndex i f | f -> i where
+  \  ifoldMap :: Monoid m => (i -> a -> m) -> f a -> m
+  @
+  .
+  @
+  class (FunctorWithIndex i t, FoldableWithIndex i t, Traversable t) => TraversableWithIndex i t | t -> i where
+  \  itraverse :: Applicative f => (i -> a -> f b) -> t a -> f (t b)
+  @
+  .
+  This package contains instances for types in GHC boot libraries.
+  For some additional instances see [indexed-traversable-instances](https://hackage.haskell.org/package/indexed-traversable-instances).
+  .
+  The [keys](https://hackage.haskell.org/package/keys) package provides similar functionality,
+  but uses (associated) @TypeFamilies@ instead of @FunctionalDependencies@.
+
+extra-source-files: Changelog.md
+tested-with:
+  GHC ==7.0.4
+   || ==7.2.2
+   || ==7.4.2
+   || ==7.6.3
+   || ==7.8.4
+   || ==7.10.3
+   || ==8.0.2
+   || ==8.2.2
+   || ==8.4.4
+   || ==8.6.5
+   || ==8.8.4
+   || ==8.10.7
+   || ==9.0.1
+   || ==9.2.1
+
+source-repository head
+  type:     git
+  location: https://github.com/haskellari/indexed-traversable
+  subdir:   indexed-traversable
+
+library
+  default-language: Haskell2010
+  ghc-options:      -Wall
+  hs-source-dirs:   src
+  other-modules:
+    GhcExts
+    WithIndex
+
+  exposed-modules:
+    Data.Foldable.WithIndex
+    Data.Functor.WithIndex
+    Data.Traversable.WithIndex
+
+  build-depends:
+      array         >=0.3.0.2 && <0.6
+    , base          >=4.3     && <4.17
+    , containers    >=0.4.0.0 && <0.7
+    , transformers  >=0.3.0.0 && <0.7
+
+  if !impl(ghc >=7.8)
+    build-depends: tagged >=0.8.5 && <0.9
+
+  if !impl(ghc >=7.10)
+    build-depends: void >=0.7.2 && <0.8
+
+  if !impl(ghc >=8.0)
+    build-depends:
+        base-orphans         >=0.8.3  && <0.9
+      , semigroups           >=0.18.4 && <0.21
+      , transformers-compat  >=0.6.6  && <0.8
+
+  if (impl(ghc >=7.0) && impl(ghc <7.6))
+    build-depends: ghc-prim
+
+  if (impl(ghc >=7.0) && impl(ghc <7.2))
+    build-depends: generic-deriving ==1.14.*
diff --git a/SPECS/ghc-indexed-traversable.spec b/SPECS/ghc-indexed-traversable.spec
new file mode 100644
index 0000000..bfd4750
--- /dev/null
+++ b/SPECS/ghc-indexed-traversable.spec
@@ -0,0 +1,139 @@
+# generated by cabal-rpm-2.0.9
+# https://docs.fedoraproject.org/en-US/packaging-guidelines/Haskell/
+
+%global pkg_name indexed-traversable
+%global pkgver %{pkg_name}-%{version}
+
+Name:           ghc-%{pkg_name}
+Version:        0.1.2
+Release:        1%{?dist}
+Summary:        FunctorWithIndex, FoldableWithIndex, TraversableWithIndex
+
+License:        BSD
+Url:            https://hackage.haskell.org/package/%{pkg_name}
+# Begin cabal-rpm sources:
+Source0:        https://hackage.haskell.org/package/%{pkgver}/%{pkgver}.tar.gz
+Source1:        https://hackage.haskell.org/package/%{pkgver}/%{pkg_name}.cabal#/%{pkgver}.cabal
+# End cabal-rpm sources
+
+# Begin cabal-rpm deps:
+BuildRequires:  ghc-Cabal-devel
+BuildRequires:  ghc-rpm-macros
+BuildRequires:  ghc-array-prof
+BuildRequires:  ghc-base-prof
+BuildRequires:  ghc-containers-prof
+BuildRequires:  ghc-transformers-prof
+# End cabal-rpm deps
+
+%description
+This package provides three useful generalizations:
+
+'class Functor f => FunctorWithIndex i f | f -> i' (imap)
+
+'class Foldable f => FoldableWithIndex i f | f -> i' (ifoldMap)
+
+'class (FunctorWithIndex i t, FoldableWithIndex i t, Traversable t) =>
+TraversableWithIndex i t | t -> i' (itraverse)
+
+This package contains instances for types in GHC boot libraries.
+For some additional instances see indexed-traversable-instances.
+
+The keys package provides similar functionality,
+but uses (associated) 'TypeFamilies' instead of 'FunctionalDependencies'.
+
+
+%package devel
+Summary:        Haskell %{pkg_name} library development files
+Provides:       %{name}-static = %{version}-%{release}
+Provides:       %{name}-static%{?_isa} = %{version}-%{release}
+%if %{defined ghc_version}
+Requires:       ghc-compiler = %{ghc_version}
+%endif
+Requires:       %{name}%{?_isa} = %{version}-%{release}
+
+%description devel
+This package provides the Haskell %{pkg_name} library development
+files.
+
+
+%if %{with haddock}
+%package doc
+Summary:        Haskell %{pkg_name} library documentation
+BuildArch:      noarch
+Requires:       ghc-filesystem
+
+%description doc
+This package provides the Haskell %{pkg_name} library
+documentation.
+%endif
+
+
+%if %{with ghc_prof}
+%package prof
+Summary:        Haskell %{pkg_name} profiling library
+Requires:       %{name}-devel%{?_isa} = %{version}-%{release}
+Supplements:    (%{name}-devel and ghc-prof)
+
+%description prof
+This package provides the Haskell %{pkg_name} profiling library.
+%endif
+
+
+%prep
+# Begin cabal-rpm setup:
+%setup -q -n %{pkgver}
+cp -bp %{SOURCE1} %{pkg_name}.cabal
+# End cabal-rpm setup
+
+
+%build
+# Begin cabal-rpm build:
+%ghc_lib_build
+# End cabal-rpm build
+
+
+%install
+# Begin cabal-rpm install
+%ghc_lib_install
+# End cabal-rpm install
+
+
+%files -f %{name}.files
+# Begin cabal-rpm files:
+%license LICENSE
+# End cabal-rpm files
+
+
+%files devel -f %{name}-devel.files
+%doc Changelog.md
+
+
+%if %{with haddock}
+%files doc -f %{name}-doc.files
+%license LICENSE
+%endif
+
+
+%if %{with ghc_prof}
+%files prof -f %{name}-prof.files
+%endif
+
+
+%changelog
+* Fri Aug 25 2023 Alexey Lyubimov <a.lyubimov@msvsphere.ru> - 0.1.2-1
+- Rebuilt for MSVSphere 9.2
+
+* Tue Jun 07 2022 Jens Petersen <petersen@redhat.com> - 0.1.2-1
+- https://hackage.haskell.org/package/indexed-traversable-0.1.2/changelog
+
+* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.1-4
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
+
+* Fri Aug 06 2021 Jens Petersen <petersen@redhat.com> - 0.1.1-3
+- rebuild
+
+* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.1-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
+
+* Tue Feb 16 2021 Jens Petersen <petersen@redhat.com> - 0.1.1-1
+- spec file generated by cabal-rpm-2.0.8