diff --git a/.gitignore b/.gitignore
index 0fabf28..02f6140 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,4 @@
 /conduit-extra-1.1.13.1.tar.gz
 /conduit-extra-1.1.15.tar.gz
 /conduit-extra-1.2.3.2.tar.gz
+/typed-process-0.2.1.0.tar.gz
diff --git a/ghc-conduit-extra.spec b/ghc-conduit-extra.spec
index a5110cb..a6acc0f 100644
--- a/ghc-conduit-extra.spec
+++ b/ghc-conduit-extra.spec
@@ -4,19 +4,24 @@
 %global pkg_name conduit-extra
 %global pkgver %{pkg_name}-%{version}
 
+%global typedprocess typed-process-0.2.1.0
+%global subpkgs %{typedprocess}
+
 %bcond_with tests
 
 Name:           ghc-%{pkg_name}
 Version:        1.2.3.2
+# can only be reset when all subpkgs bumped
 Release:        1%{?dist}
-Summary:        Conduit adapters for common libraries
+Summary:        Batteries included conduit: adapters for common libraries
 
 License:        MIT
 Url:            https://hackage.haskell.org/package/%{pkg_name}
 Source0:        https://hackage.haskell.org/package/%{pkgver}/%{pkgver}.tar.gz
+Source1:        https://hackage.haskell.org/package/%{typedprocess}/%{typedprocess}.tar.gz
 
 BuildRequires:  ghc-Cabal-devel
-BuildRequires:  ghc-rpm-macros
+BuildRequires:  ghc-rpm-macros-extra
 # Begin cabal-rpm deps:
 BuildRequires:  ghc-async-devel
 BuildRequires:  ghc-attoparsec-devel
@@ -36,7 +41,7 @@ BuildRequires:  ghc-streaming-commons-devel
 BuildRequires:  ghc-text-devel
 BuildRequires:  ghc-transformers-base-devel
 BuildRequires:  ghc-transformers-devel
-BuildRequires:  ghc-typed-process-devel
+#BuildRequires:  ghc-typed-process-devel
 BuildRequires:  ghc-unliftio-core-devel
 %if %{with tests}
 BuildRequires:  ghc-QuickCheck-devel
@@ -76,15 +81,26 @@ Obsoletes:      ghc-zlib-conduit-devel < 1.2
 This package provides the Haskell %{pkg_name} library development files.
 
 
+%global main_version %{version}
+
+%if %{defined ghclibdir}
+%ghc_lib_subpackage %{typedprocess}
+%endif
+
+%global version %{main_version}
+
+
 %prep
-%setup -q -n %{pkgver}
+%setup -q -n %{pkgver} -a1
 
 
 %build
+%ghc_libs_build %{subpkgs}
 %ghc_lib_build
 
 
 %install
+%ghc_libs_install %{subpkgs}
 %ghc_lib_install
 
 
@@ -117,6 +133,7 @@ This package provides the Haskell %{pkg_name} library development files.
 %changelog
 * Wed Jan 24 2018 Jens Petersen <petersen@redhat.com> - 1.2.3.2-1
 - update to 1.2.3.2
+- subpackage new typed-process dep
 
 * Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.15-3
 - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
diff --git a/sources b/sources
index 0ce5afd..9887252 100644
--- a/sources
+++ b/sources
@@ -1 +1,2 @@
 SHA512 (conduit-extra-1.2.3.2.tar.gz) = 758fe17c11be7eb82fe761be33cce68614bb148cec36486bb4903eed818f6a79b495788223447ec5fdff112d71a45f3b347db5c41fe6266c52021c7987839112
+SHA512 (typed-process-0.2.1.0.tar.gz) = d9a2f3a651a44c2887b165469a2d6409948cad3f1ebc90b55036ad8b0a186539064b09d35114225275d91b5f63e6c8e7e319c5816e79af69df47193877f1a867