Manually-specified variables were not used by the project:

GDCM_PDF_DOCUMENTATION
Patch for poppler breaks builds for previous releases.
Fix BTFS on unsigned-char arches
Add -fsigned-char to the build flags. The compiler complaints make sense if
  char is unsigned.
epel9
Sérgio M. Basto 6 years ago
parent 79d65bfc57
commit aa48f41db3

@ -0,0 +1,11 @@
--- ./Source/Common/gdcmString.h.orig 2019-02-25 17:28:26.424232122 +0000
+++ ./Source/Common/gdcmString.h 2019-02-25 17:28:57.986168143 +0000
@@ -27,7 +27,7 @@ namespace gdcm
* TMaxLength is only a hint. Noone actually respect the max length
* TPadChar is the string padding (0 or space)
*/
-template <char TDelimiter = '\\', unsigned int TMaxLength = 64, char TPadChar = ' '>
+template <signed char TDelimiter = '\\', unsigned int TMaxLength = 64, signed char TPadChar = ' '>
class /*GDCM_EXPORT*/ String : public std::string /* PLEASE do not export me */
{
// UI wants \0 for pad character, while ASCII ones wants space char... do not allow anything else

@ -3,7 +3,7 @@
Name: gdcm
Version: 2.8.8
Release: 2%{?dist}
Release: 3%{?dist}
Summary: Grassroots DiCoM is a C++ library to parse DICOM medical files
License: BSD
URL: http://gdcm.sourceforge.net/wiki/index.php/Main_Page
@ -28,6 +28,7 @@ Patch5: 0005-use-cpp-11-standard.patch
Patch6: 0006-Update-for-new-poppler.patch
# Use unversioned directory name
Patch7: 0007-Use-unversioned-dir.patch
Patch8: gdcm-2.8.8-fix-narrow.patch
BuildRequires: CharLS-devel >= 1.0
BuildRequires: cmake
@ -117,9 +118,13 @@ You should install the python3-gdcm package if you would like to
used this library with python
%prep
%autosetup -n GDCM-%{version} -S git
%autosetup -n GDCM-%{version} -S git -N
# Data source
%setup -n GDCM-%{version} -q -T -D -a 1
%patch -p1 -P 1 2 3 4 5 7 8
%if 0%{?fedora} > 29
%patch6 -p1 -b .poppler.0.73.0
%endif
# Fix cmake command
sed -i.backup 's/add_dependency/add_dependencies/' Utilities/doxygen/CMakeLists.txt
@ -160,7 +165,6 @@ pushd %{_target_platform}
-DGDCM_DATA_ROOT=../gdcmData/ \
-DGDCM_BUILD_EXAMPLES:BOOL=ON \
-DGDCM_DOCUMENTATION:BOOL=ON \
-DGDCM_PDF_DOCUMENTATION:BOOL=OFF \
-DGDCM_WRAP_PYTHON:BOOL=ON \
-DPYTHON_EXECUTABLE=%{__python3} \
-DGDCM_INSTALL_PYTHONMODULE_DIR=%{python3_sitearch} \
@ -280,6 +284,14 @@ make test -C %{_target_platform} || exit 0
%{python3_sitearch}/__pycache__/%{name}*
%changelog
* Mon Feb 25 2019 Sérgio Basto <sergio@serjux.com> - 2.8.8-3
- Manually-specified variables were not used by the project:
GDCM_PDF_DOCUMENTATION
- Patch for poppler breaks builds for previous releases.
- Fix BTFS on unsigned-char arches
- Add -fsigned-char to the build flags. The compiler complaints make sense if
char is unsigned.
* Mon Feb 18 2019 Ankur Sinha <ankursinha AT fedoraproject DOT org> - 2.8.8-2
- Enable tests

Loading…
Cancel
Save