Fix swig header import error

epel9
Mario Ceresa 14 years ago
parent b5ebc798c1
commit 2728aff0d3

@ -0,0 +1,12 @@
diff --git a/gdcm-2.0.16/Wrapping/Python/gdcmswig.i b/gdcm-2.0.16/Wrapping/Python/gdcmswig.i
index 6a5a5c7..26c8ba5 100644
--- a/gdcm-2.0.16/Wrapping/Python/gdcmswig.i
+++ b/gdcm-2.0.16/Wrapping/Python/gdcmswig.i
@@ -27,6 +27,7 @@
// "There is no option to suppress all SWIG warning messages."
#pragma SWIG nowarn=302,303,312,362,383,389,401,503,504,509,510,514,516
%{
+#include <cstddef> // ptrdiff_t
#include "gdcmTypes.h"
#include "gdcmASN1.h"
#include "gdcmSmartPointer.h"

@ -0,0 +1,11 @@
--- CMakeLists.txt.orig2 2010-11-22 11:43:24.258330997 +0100
+++ CMakeLists.txt 2010-11-22 11:43:54.402331000 +0100
@@ -191,7 +191,7 @@
# Install directories
STRING(TOLOWER ${PROJECT_NAME} projectname)
-SET(subdir "${projectname}-${GDCM_MAJOR_VERSION}.${GDCM_MINOR_VERSION}")
+SET(subdir "${projectname}")
IF(NOT GDCM_INSTALL_BIN_DIR)
SET(GDCM_INSTALL_BIN_DIR "bin")

@ -11,7 +11,7 @@
Name: gdcm
Version: 2.0.16
Release: 9%{?dist}
Release: 8%{?dist}
Summary: Grassroots DiCoM is a C++ library to parse DICOM medical files
Group: Development/Libraries
License: BSD
@ -27,6 +27,8 @@ Patch1: gdcm-2.0.14-inplacebuild.patch
Patch2: gdcm-2.0.14-usecopyright.patch
Patch3: gdcm-2.0.14-use_system_charls.patch
Patch4: gdcm-2.0.16-fix_dso_link.patch
Patch5: gdcm-2.0.16-remove_versioned_install_dir.patch
Patch6: gdcm-2.0.16-fix_ptrdiff.patch
BuildRequires: cmake >= 2.6.0
BuildRequires: openssl-devel
@ -82,6 +84,8 @@ used this library with python
%patch2
%patch3
%patch4 -p1
%patch5
%patch6 -p2
# Remove bundled utilities (we use Fedora's ones)
@ -141,10 +145,8 @@ mv $RPM_BUILD_ROOT%{_libdir}/_gdcmswig.so $RPM_BUILD_ROOT%{python_sitelib}/
mv $RPM_BUILD_ROOT%{_libdir}/vtkgdcm.py $RPM_BUILD_ROOT%{python_sitelib}/
## Rearranging directory layout and removing version from dir
mv $RPM_BUILD_ROOT%{_datadir}/gdcm-2.0 $RPM_BUILD_ROOT%{_datadir}/gdcm
mv $RPM_BUILD_ROOT%{_libdir}/gdcm-2.0/*.cmake $RPM_BUILD_ROOT%{_datadir}/gdcm/
rmdir $RPM_BUILD_ROOT%{_libdir}/gdcm-2.0/
mv $RPM_BUILD_ROOT%{_includedir}/gdcm-2.0 $RPM_BUILD_ROOT%{_includedir}/gdcm
mv $RPM_BUILD_ROOT%{_libdir}/gdcm/*.cmake $RPM_BUILD_ROOT%{_datadir}/gdcm/
rmdir $RPM_BUILD_ROOT%{_libdir}/gdcm/
## Cleaning Example dir from cmake cache files + remove 0-lenght files
find %{_builddir}/%{?buildsubdir}/Examples -depth -name CMakeFiles | xargs rm -rf
@ -183,14 +185,11 @@ ctest .
%{python_sitelib}/*
%changelog
* Wed Jan 12 2011 Rex Dieter <rdieter@fedoraproject.org> - 2.0.16-9
- rebuild (openjpeg)
* Mon Feb 2 2011 Mario Ceresa <mrceresa@gmail.com> 2.0.16-8
- Added patch to fix upstream bug #3169784
* Sun Jan 02 2011 Rex Dieter <rdieter@fedoraproject.org> - 2.0.16-8
- rebuild (poppler)
* Wed Dec 15 2010 Rex Dieter <rdieter@fedoraproject.org> - 2.0.16-7
- rebuild (poppler)
* Mon Nov 22 2010 Mario Ceresa <mrceresa@gmail.com> 2.0.16-7
- Fixed bug 655738
* Tue Nov 19 2010 Mario Ceresa <mrceresa@gmail.com> 2.0.16-6
- Enabled VTK support

Loading…
Cancel
Save