Initial commit for EPEL 9

epel9
Devrim Gündüz 3 years ago
parent ace4458d11
commit ef9848de52

@ -0,0 +1,38 @@
gdal-1.9.1.tar.gz re-pack for Fedora
All files with pending legal questions are stripped from the original tarball,
to form this tarball. Legal information is mainly from PROVENANCE.TXT
No files are manipulated.
Please see the cleaning script clean-gdal.sh!
This leaves GDAL short of a few formats, coordinate systems and the PHP bindings.
Volker Fröhlich <volker27@gmx.at>
* updated to 1.9.1 by Volker Fröhlich <volker27@gmx.at>
* updated to 1.9.0 by Volker Fröhlich <volker27@gmx.at>
* updated to 1.7.3 by Viji V Nair <viji@fedoraproject.org>
* updated to 1.7.2 by Sven Lankes <sven@lank.es>
* updated to 1.7.1 by Balint Crisitan <cristian.balint@gmail.com>
* updated to 1.6.1 by Dan Horak <dan@danny.cz>
Removed files:
========================================
# due to uncertain license issues
and derivative copy from ESRI (TM) and CubeWerx (TM):
data/cubewerx_extra.wkt
data/esri_extra.wkt
data/ecw_cs.wkt
Removed folders plus its contents:
========================================
# due to uncertain license issues these formats
are removed and not suported in fedora pack:
frmts/bsb <-- http://www.osgeo.org/pipermail/gdal-dev/2003-September/001097.html
swig/php <-- PHP license, incompatible mixture

@ -0,0 +1,30 @@
#!/bin/bash
if [ $# -lt 1 ]; then
echo "Usage: $0 version"
exit 1
fi
VERSION="$1"
wget https://github.com/OSGeo/gdal/releases/download/v$VERSION/gdal-$VERSION.tar.gz
tar xvf gdal-"${VERSION}".tar.gz
mv gdal-"${VERSION}"{,-fedora} && pushd gdal-"${VERSION}"-fedora
rm data/cubewerx_extra.wkt
rm data/esri_extra.wkt
rm data/esri_Wisconsin_extra.wkt
rm data/esri_StatePlane_extra.wkt
rm data/ecw_cs.wkt
#Really necessary?
rm -r swig/php
popd
#TODO: Insert Provenance file
tar cvfJ gdal-"${VERSION}"-fedora.tar.xz gdal-"${VERSION}"-fedora

@ -0,0 +1,33 @@
diff -rupN --no-dereference gdal-3.4.0-fedora/ogr/ogrsf_frmts/cad/libopencad/cadobjects.cpp gdal-3.4.0-fedora-new/ogr/ogrsf_frmts/cad/libopencad/cadobjects.cpp
--- gdal-3.4.0-fedora/ogr/ogrsf_frmts/cad/libopencad/cadobjects.cpp 2021-11-04 12:56:51.000000000 +0100
+++ gdal-3.4.0-fedora-new/ogr/ogrsf_frmts/cad/libopencad/cadobjects.cpp 2021-11-09 11:58:38.117291664 +0100
@@ -34,6 +34,7 @@
#include <limits>
#include <math.h>
#include <algorithm>
+#include <limits>
//------------------------------------------------------------------------------
// CADVector
diff -rupN --no-dereference gdal-3.4.0-fedora/ogr/ogrsf_frmts/cad/libopencad/dwg/r2000.cpp gdal-3.4.0-fedora-new/ogr/ogrsf_frmts/cad/libopencad/dwg/r2000.cpp
--- gdal-3.4.0-fedora/ogr/ogrsf_frmts/cad/libopencad/dwg/r2000.cpp 2021-11-04 12:56:50.000000000 +0100
+++ gdal-3.4.0-fedora-new/ogr/ogrsf_frmts/cad/libopencad/dwg/r2000.cpp 2021-11-09 11:58:38.117291664 +0100
@@ -39,6 +39,7 @@
#include <limits>
#include <memory>
#include <string>
+#include <limits>
#if ((defined(__sun__) || defined(__FreeBSD__)) && __GNUC__ == 4 && __GNUC_MINOR__ == 8) || defined(__ANDROID__)
// gcc 4.8 on Solaris 11.3 or FreeBSD 11 doesn't have std::string
diff -rupN --no-dereference gdal-3.4.0-fedora/third_party/LercLib/Lerc2.h gdal-3.4.0-fedora-new/third_party/LercLib/Lerc2.h
--- gdal-3.4.0-fedora/third_party/LercLib/Lerc2.h 2021-11-04 12:56:01.000000000 +0100
+++ gdal-3.4.0-fedora-new/third_party/LercLib/Lerc2.h 2021-11-09 11:58:38.118291684 +0100
@@ -30,6 +30,7 @@ Contributors: Thomas Maurer
#include <limits>
#include <string>
#include <typeinfo>
+#include <limits>
#include "Defines.h"
#include "BitMask.h"
#include "BitStuffer2.h"

File diff suppressed because it is too large Load Diff

@ -0,0 +1,12 @@
diff -rupN --no-dereference gdal-3.4.0-fedora/m4/lib-link.m4 gdal-3.4.0-fedora-new/m4/lib-link.m4
--- gdal-3.4.0-fedora/m4/lib-link.m4 2021-11-04 12:57:06.000000000 +0100
+++ gdal-3.4.0-fedora-new/m4/lib-link.m4 2021-11-09 11:58:38.585300818 +0100
@@ -108,8 +108,6 @@ dnl acl_hardcode_direct,
dnl acl_hardcode_minus_L.
AC_DEFUN([AC_LIB_RPATH],
[
- dnl Tell automake >= 1.10 to complain if config.rpath is missing.
- m4_ifdef([AC_REQUIRE_AUX_FILE], [AC_REQUIRE_AUX_FILE([config.rpath])])
AC_REQUIRE([AC_PROG_CC]) dnl we use $CC, $GCC, $LDFLAGS
AC_REQUIRE([AC_LIB_PROG_LD]) dnl we use $LD, $with_gnu_ld
AC_REQUIRE([AC_CANONICAL_HOST]) dnl we use $host

@ -0,0 +1,11 @@
diff -rupN --no-dereference gdal-3.4.0-fedora/apps/GNUmakefile gdal-3.4.0-fedora-new/apps/GNUmakefile
--- gdal-3.4.0-fedora/apps/GNUmakefile 2021-11-04 12:55:37.000000000 +0100
+++ gdal-3.4.0-fedora-new/apps/GNUmakefile 2021-11-09 11:58:37.658282683 +0100
@@ -232,6 +232,7 @@ gdal-config-inst: gdal-config.in ../GDAL
install: default
for f in $(BIN_LIST) ; do $(INSTALL) $$f $(DESTDIR)$(INST_BIN) ; done
+ for f in $(BIN_LIST) ; do $(INSTALL) .libs/$$f $(DESTDIR)$(INST_BIN) ; done
$(INSTALL_DATA) gdal_utils.h $(DESTDIR)$(INST_INCLUDE)
$(INSTALL) gdal-config-inst $(DESTDIR)$(INST_BIN)/gdal-config

@ -0,0 +1,13 @@
diff -rupN --no-dereference gdal-3.4.0-fedora/frmts/iso8211/GNUmakefile gdal-3.4.0-fedora-new/frmts/iso8211/GNUmakefile
--- gdal-3.4.0-fedora/frmts/iso8211/GNUmakefile 2021-11-04 12:55:37.000000000 +0100
+++ gdal-3.4.0-fedora-new/frmts/iso8211/GNUmakefile 2021-11-09 11:58:37.203273779 +0100
@@ -23,8 +23,7 @@ dist-clean: clean
rm -rf $(DISTDIR)
$(ISOLIB): $(OBJ:.o=.$(OBJ_EXT))
- $(AR) r $(ISOLIB) $?
- $(RANLIB) $(ISOLIB)
+ $(SHELL) $(top_builddir)/libtool --mode=link gcc -static -o $(ISOLIB) $?
8211createfromxml$(EXE): 8211createfromxml.$(OBJ_EXT)
$(LD) $(LDFLAGS) 8211createfromxml.$(OBJ_EXT) $(CONFIG_LIBS) -o 8211createfromxml$(EXE)

@ -0,0 +1,112 @@
diff -rupN --no-dereference gdal-3.4.0-fedora/swig/java/add_javadoc.c gdal-3.4.0-fedora-new/swig/java/add_javadoc.c
--- gdal-3.4.0-fedora/swig/java/add_javadoc.c 2021-11-04 12:55:39.000000000 +0100
+++ gdal-3.4.0-fedora-new/swig/java/add_javadoc.c 2021-11-09 11:58:36.600261974 +0100
@@ -133,22 +133,22 @@ int main(int argc, char* argv[])
FILE* fDst;
JavaDocInstance* instances = (JavaDocInstance*)calloc(sizeof(JavaDocInstance), 3000);
int nInstances = 0;
- char szLine[256];
- char szClass[256];
+ char szLine[512];
+ char szClass[512];
char javadoc[16384];
szClass[0] = 0;
- while(fgets(szLine, 255, fSrc))
+ while(fgets(szLine, 511, fSrc))
{
if (strstr(szLine, "/**") == NULL) continue;
begin:
strcpy(javadoc, szLine);
- while(fgets(szLine, 255, fSrc))
+ while(fgets(szLine, 511, fSrc))
{
strcat(javadoc, szLine);
if (strstr(szLine, "*/"))
break;
}
- while(fgets(szLine, 255, fSrc))
+ while(fgets(szLine, 511, fSrc))
{
if (szLine[0] == 10)
continue;
@@ -188,10 +188,10 @@ begin:
fDst = fopen(szDstName, "wt");
if (fDst == NULL) continue;
szClass[0] = 0;
- char szPackage[256];
+ char szPackage[512];
szPackage[0] = 0;
- while(fgets(szLine, 255, fSrc))
+ while(fgets(szLine, 511, fSrc))
{
char szMethodName[1024];
char* szOriLine = strdup(szLine);
@@ -224,8 +224,10 @@ begin:
if (strstr(szLine, "synchronized "))
{
char* c = strstr(szLine, "synchronized ");
+ char rest[512];
+ strcpy(rest, c + 13);
*c = 0;
- strcat(szLine, c + 13);
+ strcat(szLine, rest);
}
if (strstr(szLine, "public") && !strstr(szLine, "native"))
{
@@ -234,7 +236,7 @@ begin:
strcpy(szMethodName, szLine);
do
{
- fgets(szLine, 255, fSrc);
+ fgets(szLine, 511, fSrc);
strcpy(szMethodName + strlen(szMethodName) - 1, szLine);
} while (!strchr(szMethodName,')'));
strcpy(szLine, szMethodName);
@@ -261,7 +263,7 @@ begin:
{
do
{
- fgets(szLine, 255, fSrc);
+ fgets(szLine, 511, fSrc);
} while (!strchr(szLine,'}'));
}
break;
@@ -289,7 +291,7 @@ begin:
nBrackets --;
}
}
- fgets(szLine, 255, fSrc);
+ fgets(szLine, 511, fSrc);
} while(bFoundOpen == FALSE || nBrackets > 0);
}
else
diff -rupN --no-dereference gdal-3.4.0-fedora/swig/java/javadoc.java gdal-3.4.0-fedora-new/swig/java/javadoc.java
--- gdal-3.4.0-fedora/swig/java/javadoc.java 2021-11-04 12:55:40.000000000 +0100
+++ gdal-3.4.0-fedora-new/swig/java/javadoc.java 2021-11-09 11:58:36.602262013 +0100
@@ -11982,12 +11982,12 @@ public interface osrConstants:public fin
public interface osrConstants:public final static int PROJ_ERR_COORD_TRANSFM
/**
- * Invalid input coordinate. e.g a latitude > 90°.
+ * Invalid input coordinate. e.g a latitude > 90 deg.
*/
public interface osrConstants:public final static int PROJ_ERR_COORD_TRANSFM_INVALID_COORD
/**
- * Coordinate is outside of the projection domain. e.g approximate mercator with \|longitude - lon_0\| > 90°,
+ * Coordinate is outside of the projection domain. e.g approximate mercator with \|longitude - lon_0\| > 90 deg,
* or iterative convergence method failed.
*/
public interface osrConstants:public final static int PROJ_ERR_COORD_TRANSFM_OUTSIDE_PROJECTION_DOMAIN
diff -rupN --no-dereference gdal-3.4.0-fedora/swig/java/java.opt gdal-3.4.0-fedora-new/swig/java/java.opt
--- gdal-3.4.0-fedora/swig/java/java.opt 2021-11-04 12:55:38.000000000 +0100
+++ gdal-3.4.0-fedora-new/swig/java/java.opt 2021-11-09 11:58:36.602262013 +0100
@@ -7,6 +7,6 @@ JAVADOC=$(JAVA_HOME)/bin/javadoc
JAVAC=$(JAVA_HOME)/bin/javac
JAVA=$(JAVA_HOME)/bin/java
JAR=$(JAVA_HOME)/bin/jar
-JAVA_INCLUDE=-I$(JAVA_HOME)/include -I$(JAVA_HOME)/include/linux
+JAVA_INCLUDE=-I/usr/lib/jvm/java/include/ -I/usr/lib/jvm/java/include/linux

@ -0,0 +1,12 @@
diff -rupN --no-dereference gdal-3.4.0-fedora/configure.ac gdal-3.4.0-fedora-new/configure.ac
--- gdal-3.4.0-fedora/configure.ac 2021-11-04 12:55:37.000000000 +0100
+++ gdal-3.4.0-fedora-new/configure.ac 2021-11-09 11:58:38.356296339 +0100
@@ -73,7 +73,7 @@ dnl warning #2304: non-explicit construc
dnl warning #3280: declaration hides member
dnl remark #11074: Inlining inhibited by limit max-size
dnl remark #11076: To get full report use -qopt-report=4 -qopt-report-phase ipo
-AX_CHECK_COMPILE_FLAG([-diag-disable 188,1684,2259,2304,3280,11074,11076],[C_WFLAGS="$C_WFLAGS -diag-disable 188,1684,2259,2304,3280,11074,11076" CXX_WFLAGS="$CXX_WFLAGS -diag-disable 188,1684,2259,2304,3280,11074,11076"],,[$ERROR_ON_UNKNOWN_OPTIONS])
+#AX_CHECK_COMPILE_FLAG([-diag-disable 188,1684,2259,2304,3280,11074,11076],[C_WFLAGS="$C_WFLAGS -diag-disable 188,1684,2259,2304,3280,11074,11076" CXX_WFLAGS="$CXX_WFLAGS -diag-disable 188,1684,2259,2304,3280,11074,11076"],,[$ERROR_ON_UNKNOWN_OPTIONS])
AX_CHECK_COMPILE_FLAG([-Wextra],[C_WFLAGS="$C_WFLAGS -Wextra" CXX_WFLAGS="$CXX_WFLAGS -Wextra"],,[$ERROR_ON_UNKNOWN_OPTIONS])
AX_CHECK_COMPILE_FLAG([-Winit-self],[C_WFLAGS="$C_WFLAGS -Winit-self" CXX_WFLAGS="$CXX_WFLAGS -Winit-self"],,[$ERROR_ON_UNKNOWN_OPTIONS])

@ -0,0 +1,12 @@
diff -rupN --no-dereference gdal-3.4.0-fedora/doc/source/index.rst gdal-3.4.0-fedora-new/doc/source/index.rst
--- gdal-3.4.0-fedora/doc/source/index.rst 2021-11-04 12:55:37.000000000 +0100
+++ gdal-3.4.0-fedora-new/doc/source/index.rst 2021-11-09 11:58:37.885287126 +0100
@@ -4,8 +4,6 @@ GDAL
.. include:: ./about_no_title.rst
-This documentation is also available as a `PDF file <gdal.pdf>`_.
-
.. toctree::
:maxdepth: 2

@ -0,0 +1,12 @@
diff -rupN --no-dereference gdal-3.4.0-fedora/doc/Makefile gdal-3.4.0-fedora-new/doc/Makefile
--- gdal-3.4.0-fedora/doc/Makefile 2021-11-04 12:55:37.000000000 +0100
+++ gdal-3.4.0-fedora-new/doc/Makefile 2021-11-09 11:58:37.435278319 +0100
@@ -2,7 +2,7 @@
#
# You can set these variables from the command line.
-SPHINXOPTS ?= --keep-going -j auto -W
+SPHINXOPTS ?= --keep-going
SPHINXBUILD = sphinx-build
SOURCEDIR = source
BUILDDIR = build

@ -0,0 +1,24 @@
diff -rupN --no-dereference gdal-3.4.0-fedora/frmts/dods/GNUmakefile gdal-3.4.0-fedora-new/frmts/dods/GNUmakefile
--- gdal-3.4.0-fedora/frmts/dods/GNUmakefile 2021-11-04 12:55:37.000000000 +0100
+++ gdal-3.4.0-fedora-new/frmts/dods/GNUmakefile 2021-11-09 11:58:36.942268671 +0100
@@ -4,7 +4,7 @@ include ../../GDALmake.opt
OBJ = dodsdataset2.o
-CPPFLAGS := $(CPPFLAGS) $(DODS_INC) $(LIBXML2_INC)
+CPPFLAGS := $(CPPFLAGS) $(DODS_INC) $(LIBXML2_INC) -I/usr/include/tirpc
default: $(OBJ:.o=.$(OBJ_EXT))
diff -rupN --no-dereference gdal-3.4.0-fedora/ogr/ogrsf_frmts/dods/GNUmakefile gdal-3.4.0-fedora-new/ogr/ogrsf_frmts/dods/GNUmakefile
--- gdal-3.4.0-fedora/ogr/ogrsf_frmts/dods/GNUmakefile 2021-11-04 12:55:37.000000000 +0100
+++ gdal-3.4.0-fedora-new/ogr/ogrsf_frmts/dods/GNUmakefile 2021-11-09 11:58:36.942268671 +0100
@@ -5,7 +5,7 @@ include ../../../GDALmake.opt
OBJ = ogrdodsdriver.o ogrdodsdatasource.o ogrdodslayer.o \
ogrdodssequencelayer.o ogrdodsfielddefn.o ogrdodsgrid.o
-CPPFLAGS := -iquote .. $(CPPFLAGS) $(DODS_INC) $(LIBXML2_INC) -DDO_NOT_USE_DEBUG_BOOL
+CPPFLAGS := -iquote .. $(CPPFLAGS) $(DODS_INC) $(LIBXML2_INC) -DDO_NOT_USE_DEBUG_BOOL -I/usr/include/tirpc
default: $(O_OBJ:.o=.$(OBJ_EXT))
Loading…
Cancel
Save