commit
75449679ac
@ -0,0 +1 @@
|
||||
ff645cefff25ee9bc98bcd233bd20a86392bf77a SOURCES/elfutils-0.185.tar.bz2
|
@ -0,0 +1 @@
|
||||
SOURCES/elfutils-0.185.tar.bz2
|
File diff suppressed because it is too large
Load Diff
@ -0,0 +1,52 @@
|
||||
diff --git a/libdw/Makefile.am b/libdw/Makefile.am
|
||||
index ef566399..c6493a08 100644
|
||||
--- a/libdw/Makefile.am
|
||||
+++ b/libdw/Makefile.am
|
||||
@@ -32,7 +32,7 @@ if BUILD_STATIC
|
||||
AM_CFLAGS += $(fpic_CFLAGS)
|
||||
endif
|
||||
AM_CPPFLAGS += -I$(srcdir)/../libelf -I$(srcdir)/../libdwelf -pthread
|
||||
-VERSION = 1
|
||||
+VERSION = dts.1
|
||||
|
||||
lib_LIBRARIES = libdw.a
|
||||
noinst_LIBRARIES = libdw_pic.a
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index b348a717..e94449c0 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -25,7 +25,7 @@ m4_ifndef([AC_PACKAGE_URL],
|
||||
[Define to home page for this package])
|
||||
AC_SUBST([PACKAGE_URL], ["http://elfutils.org/"])])
|
||||
|
||||
-LIBDEBUGINFOD_SONAME=libdebuginfod.so.1
|
||||
+LIBDEBUGINFOD_SONAME=libdebuginfod.so.dts.1
|
||||
AC_SUBST([LIBDEBUGINFOD_SONAME])
|
||||
|
||||
# We want eu- as default program prefix if none was given by the user.
|
||||
diff --git a/libasm/Makefile.am b/libasm/Makefile.am
|
||||
index 6a191465..912de734 100644
|
||||
--- a/libasm/Makefile.am
|
||||
+++ b/libasm/Makefile.am
|
||||
@@ -30,7 +30,7 @@
|
||||
include $(top_srcdir)/config/eu.am
|
||||
AM_CPPFLAGS += -I$(top_srcdir)/libelf -I$(top_srcdir)/libebl -I$(top_srcdir)/libdw -I$(top_srcdir)/libdwelf
|
||||
|
||||
-VERSION = 1
|
||||
+VERSION = dts.1
|
||||
|
||||
lib_LIBRARIES = libasm.a
|
||||
noinst_LIBRARIES = libasm_pic.a
|
||||
diff --git a/libelf/Makefile.am b/libelf/Makefile.am
|
||||
index 62cb53d6..740e123b 100644
|
||||
--- a/libelf/Makefile.am
|
||||
+++ b/libelf/Makefile.am
|
||||
@@ -32,7 +32,7 @@ if BUILD_STATIC
|
||||
AM_CFLAGS += $(fpic_CFLAGS)
|
||||
endif
|
||||
|
||||
-VERSION = 1
|
||||
+VERSION = dts.1
|
||||
|
||||
lib_LIBRARIES = libelf.a
|
||||
noinst_LIBRARIES = libelf_pic.a
|
@ -0,0 +1,5 @@
|
||||
/* GNU ld script
|
||||
|
||||
Libraries in Developer Toolset are linked in statically to allow
|
||||
compiled binaries to run even when DTS is not installed. */
|
||||
INPUT(libasm.ar)
|
@ -0,0 +1,5 @@
|
||||
/* GNU ld script
|
||||
|
||||
Libraries in Developer Toolset are linked in statically to allow
|
||||
compiled binaries to run even when DTS is not installed. */
|
||||
INPUT(libasm.ar)
|
@ -0,0 +1,7 @@
|
||||
/* GNU ld script
|
||||
|
||||
Static libraries in Developer Toolset are named .ar to prevent
|
||||
brp-strip-static-archive from stripping them. But we still want
|
||||
them to be found in cases like -static -lxyz, hence this linker
|
||||
script. */
|
||||
INPUT(libdebuginfod.ar)
|
@ -0,0 +1,6 @@
|
||||
/* GNU ld script
|
||||
|
||||
Libraries in Developer Toolset are linked in statically to allow
|
||||
compiled binaries to run even when DTS is not installed. */
|
||||
INPUT(libdebuginfod.ar)
|
||||
INPUT(-lcurl)
|
@ -0,0 +1,7 @@
|
||||
/* GNU ld script
|
||||
|
||||
Static libraries in Developer Toolset are named .ar to prevent
|
||||
brp-strip-static-archive from stripping them. But we still want
|
||||
them to be found in cases like -static -lxyz, hence this linker
|
||||
script. */
|
||||
GROUP(libdw.ar -lpthread -ldl)
|
@ -0,0 +1,7 @@
|
||||
/* GNU ld script
|
||||
|
||||
Libraries in Developer Toolset are linked in statically to allow
|
||||
compiled binaries to run even when DTS is not installed. */
|
||||
GROUP(libdw.ar -lpthread -ldl)
|
||||
INPUT(-lzstd -llzma -lbz2 -lz)
|
||||
INPUT(-lelf)
|
@ -0,0 +1,7 @@
|
||||
/* GNU ld script
|
||||
|
||||
Static libraries in Developer Toolset are named .ar to prevent
|
||||
brp-strip-static-archive from stripping them. But we still want
|
||||
them to be found in cases like -static -lxyz, hence this linker
|
||||
script. */
|
||||
INPUT(libelf.ar)
|
@ -0,0 +1,6 @@
|
||||
/* GNU ld script
|
||||
|
||||
Libraries in Developer Toolset are linked in statically to allow
|
||||
compiled binaries to run even when DTS is not installed. */
|
||||
INPUT(libelf.ar)
|
||||
INPUT(-lz)
|
File diff suppressed because it is too large
Load Diff
Loading…
Reference in new issue