f41 imports/f41/frozen-1.2.0-1.el10
Gwyn Ciesla 5 months ago
parent 984a9cada3
commit 56444a30c2

1
.gitignore vendored

@ -1 +1,2 @@
/frozen-1.1.1.tar.gz
/frozen-1.2.0.tar.gz

@ -1,37 +0,0 @@
From 079f73cc5c6413127d47f325cbb34a607e2cb030 Mon Sep 17 00:00:00 2001
From: serge-sans-paille <serge.guelton@telecom-bretagne.eu>
Date: Fri, 16 Dec 2022 22:58:51 +0100
Subject: [PATCH] Workaround gcc 11 limitation
For some reason, gcc sees a constexpr violation here. Trust clang and msvc on this.
---
include/frozen/unordered_set.h | 2 +-
tests/test_unordered_set.cpp | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/include/frozen/unordered_set.h b/include/frozen/unordered_set.h
index 4d16df9..196ea50 100644
--- a/include/frozen/unordered_set.h
+++ b/include/frozen/unordered_set.h
@@ -105,7 +105,7 @@ class unordered_set {
/* lookup */
template <class KeyType, class Hasher, class Equal>
constexpr std::size_t count(KeyType const &key, Hasher const &hash, Equal const &equal) const {
- auto const k = lookup(key, hash);
+ auto const & k = lookup(key, hash);
return equal(k, key);
}
template <class KeyType>
diff --git a/tests/test_unordered_set.cpp b/tests/test_unordered_set.cpp
index e90a0d4..042c1a8 100644
--- a/tests/test_unordered_set.cpp
+++ b/tests/test_unordered_set.cpp
@@ -65,7 +65,7 @@ TEST_CASE("tripleton str frozen unordered set", "[unordered set]") {
constexpr auto max_size = ze_set.max_size();
REQUIRE(max_size == 3);
- constexpr auto nocount = ze_set.count(4);
+ const auto nocount = ze_set.count(4);
REQUIRE(nocount == 0);
constexpr auto count = ze_set.count(1);

@ -1,18 +0,0 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 65fb923..dfcc437 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -126,8 +126,13 @@ if(frozen.installation)
# generate a CMake configuration file for consumption by CMake's `find_package`
# intrinsic
#
+
+ if(${CMAKE_VERSION} VERSION_GREATER "3.14")
+ set(OPTIONAL_ARCH_INDEPENDENT "ARCH_INDEPENDENT")
+ endif()
write_basic_package_version_file("frozenConfigVersion.cmake"
VERSION ${PROJECT_VERSION}
+ ${OPTIONAL_ARCH_INDEPENDENT}
COMPATIBILITY SameMajorVersion)
install(FILES "${PROJECT_BINARY_DIR}/frozenConfigVersion.cmake"

@ -2,18 +2,13 @@
%global debug_package %{nil}
Name: frozen
Version: 1.1.1
Release: 7%{?dist}
Version: 1.2.0
Release: 1%{?dist}
Summary: A header-only, constexpr alternative to gperf for C++14 users
License: Apache-2.0
URL: https://github.com/serge-sans-paille/frozen
Source0: %{url}/archive/%{version}/%{name}-%{version}.tar.gz
# Fixes FTBFS, already present in upstream main branch.
Patch0: includes.patch
Patch1: 079f73cc5c6413127d47f325cbb34a607e2cb030.patch
# related: https://github.com/serge-sans-paille/frozen/pull/167
Patch2: frozen-fix-arch-in-cmake.patch
BuildRequires: gcc-c++
BuildRequires: cmake
@ -36,10 +31,6 @@ Development files for %{name}.
%prep
%setup -q
%patch -P 0 -p0
%patch -P 1 -p1
%patch -P 2 -p1
%build
%cmake -DCMAKE_BUILD_TYPE=Release
%cmake_build
@ -58,6 +49,9 @@ Development files for %{name}.
%{_datadir}/cmake/%{name}/
%changelog
* Tue Sep 03 2024 Gwyn Ciesla <gwync@protonmail.com> - 1.2.0-1
- 1.2.0
* Wed Jul 17 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.1-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild

@ -1,11 +0,0 @@
--- include/frozen/bits/pmh.h~ 2022-03-31 00:56:25.000000000 -0500
+++ include/frozen/bits/pmh.h 2023-07-17 13:42:52.903675376 -0500
@@ -30,6 +30,8 @@
#include <array>
#include <limits>
+#include <cstdint>
+
namespace frozen {
namespace bits {

@ -1 +1 @@
SHA512 (frozen-1.1.1.tar.gz) = e22561a4e634e388e11f95b3005bc711e543013d314f6aaeda34befb2c673aea2d71a717d8822bc8fa85bdc8409945ba2ad91a1bac4f8cb5303080de01a5f60e
SHA512 (frozen-1.2.0.tar.gz) = 644b29f60458fc5193a3fb16a347c190f9694d1bdbc75202aafe8d43eb72ce0433bbeaeb692f8ca485000d68b451ddc0236a1880ebbd64477f73198043d046b3

Loading…
Cancel
Save