commit
62d49747d4
@ -0,0 +1,3 @@
|
||||
2d8d5917a1983ebd04921f2993a88858d6f72dec SOURCES/freetype-2.13.2.tar.xz
|
||||
dbed086b3dba1d748e15b28103081ed30d24e3f3 SOURCES/freetype-doc-2.13.2.tar.xz
|
||||
655c82a431fae7f53a964bda8a7c0671531d05a4 SOURCES/ft2demos-2.13.2.tar.xz
|
@ -0,0 +1,3 @@
|
||||
SOURCES/freetype-2.13.2.tar.xz
|
||||
SOURCES/freetype-doc-2.13.2.tar.xz
|
||||
SOURCES/ft2demos-2.13.2.tar.xz
|
@ -0,0 +1,72 @@
|
||||
--- freetype-2.10.0/include/freetype/ftoutln.h
|
||||
+++ freetype-2.10.0/include/freetype/ftoutln.h
|
||||
@@ -165,6 +165,15 @@ FT_BEGIN_HEADER
|
||||
FT_Int numContours,
|
||||
FT_Outline *anoutline );
|
||||
|
||||
+ /*
|
||||
+ * Kept downstream for ABI compatibility only.
|
||||
+ * It just throws error now. Remove once soname has been bumped.
|
||||
+ */
|
||||
+ FT_EXPORT( FT_Error )
|
||||
+ FT_Outline_New_Internal( FT_Memory memory,
|
||||
+ FT_UInt numPoints,
|
||||
+ FT_Int numContours,
|
||||
+ FT_Outline *anoutline );
|
||||
|
||||
/**************************************************************************
|
||||
*
|
||||
@@ -192,6 +201,13 @@ FT_BEGIN_HEADER
|
||||
FT_Outline_Done( FT_Library library,
|
||||
FT_Outline* outline );
|
||||
|
||||
+ /*
|
||||
+ * Kept downstream for ABI compatibility only.
|
||||
+ * It just throws error now. Remove once soname has been bumped.
|
||||
+ */
|
||||
+ FT_EXPORT( FT_Error )
|
||||
+ FT_Outline_Done_Internal( FT_Memory memory,
|
||||
+ FT_Outline* outline );
|
||||
|
||||
/**************************************************************************
|
||||
*
|
||||
--- freetype-2.10.0/src/base/ftoutln.c
|
||||
+++ freetype-2.10.0/src/base/ftoutln.c
|
||||
@@ -291,6 +291,19 @@
|
||||
|
||||
/* documentation is in ftoutln.h */
|
||||
|
||||
+ /*
|
||||
+ * Kept downstream for ABI compatibility only.
|
||||
+ * It just throws error now. Remove once soname has been bumped.
|
||||
+ */
|
||||
+ FT_EXPORT_DEF( FT_Error )
|
||||
+ FT_Outline_New_Internal( FT_Memory memory,
|
||||
+ FT_UInt numPoints,
|
||||
+ FT_Int numContours,
|
||||
+ FT_Outline *anoutline )
|
||||
+ {
|
||||
+ return FT_THROW( Unimplemented_Feature );
|
||||
+ }
|
||||
+
|
||||
FT_EXPORT_DEF( FT_Error )
|
||||
FT_Outline_New( FT_Library library,
|
||||
FT_UInt numPoints,
|
||||
@@ -423,6 +436,17 @@
|
||||
|
||||
/* documentation is in ftoutln.h */
|
||||
|
||||
+ /*
|
||||
+ * Kept downstream for ABI compatibility only.
|
||||
+ * It just throws error now. Remove once soname has been bumped.
|
||||
+ */
|
||||
+ FT_EXPORT_DEF( FT_Error )
|
||||
+ FT_Outline_Done_Internal( FT_Memory memory,
|
||||
+ FT_Outline* outline )
|
||||
+ {
|
||||
+ return FT_THROW( Unimplemented_Feature );
|
||||
+ }
|
||||
+
|
||||
FT_EXPORT_DEF( FT_Error )
|
||||
FT_Outline_Done( FT_Library library,
|
||||
FT_Outline* outline )
|
@ -0,0 +1,20 @@
|
||||
--- freetype-2.2.1/modules.cfg.orig 2006-07-07 21:01:09.000000000 -0400
|
||||
+++ freetype-2.2.1/modules.cfg 2006-07-07 21:01:54.000000000 -0400
|
||||
@@ -110,7 +110,7 @@
|
||||
|
||||
# TrueType GX/AAT table validation. Needs `ftgxval.c' below.
|
||||
#
|
||||
-# AUX_MODULES += gxvalid
|
||||
+AUX_MODULES += gxvalid
|
||||
|
||||
# Support for streams compressed with gzip (files with suffix .gz).
|
||||
#
|
||||
@@ -124,7 +124,7 @@
|
||||
|
||||
# OpenType table validation. Needs `ftotval.c' below.
|
||||
#
|
||||
-# AUX_MODULES += otvalid
|
||||
+AUX_MODULES += otvalid
|
||||
|
||||
# Auxiliary PostScript driver component to share common code.
|
||||
#
|
@ -0,0 +1,11 @@
|
||||
--- freetype-2.3.0/include/freetype/config/ftoption.h.spf 2007-01-18 14:27:34.000000000 -0500
|
||||
+++ freetype-2.3.0/include/freetype/config/ftoption.h 2007-01-18 14:27:48.000000000 -0500
|
||||
@@ -92,7 +92,7 @@
|
||||
* When this macro is not defined, FreeType offers alternative LCD
|
||||
* rendering technology that produces excellent output.
|
||||
*/
|
||||
-/* #define FT_CONFIG_OPTION_SUBPIXEL_RENDERING */
|
||||
+#define FT_CONFIG_OPTION_SUBPIXEL_RENDERING
|
||||
|
||||
|
||||
/**************************************************************************
|
@ -0,0 +1,17 @@
|
||||
--- ft2demos-2.5.2/Makefile
|
||||
+++ ft2demos-2.5.2/Makefile
|
||||
@@ -296,10 +296,10 @@ else
|
||||
# The following programs are not compiled automatically; either comment
|
||||
# out the affected line or use the program name as a Makefile target.
|
||||
#
|
||||
- # EXES += ftchkwd
|
||||
- # EXES += ftmemchk
|
||||
- # EXES += ftpatchk
|
||||
- # EXES += fttimer
|
||||
+ EXES += ftchkwd
|
||||
+ EXES += ftmemchk
|
||||
+ EXES += ftpatchk
|
||||
+ EXES += fttimer
|
||||
# EXES += testname
|
||||
|
||||
# Not all demo programs have a man page; we thus check for existence in a
|
@ -0,0 +1,11 @@
|
||||
--- freetype-2.8/builds/unix/freetype-config.in.orig 2017-03-30 12:20:23.000000001 +0200
|
||||
+++ freetype-2.8/builds/unix/freetype-config.in 2017-05-16 13:25:39.223041128 +0200
|
||||
@@ -205,7 +205,7 @@ if test "$echo_libs" = "yes" ; then
|
||||
fi
|
||||
|
||||
if test "$echo_libtool" = "yes" ; then
|
||||
- echo ${SYSROOT}$libdir/libfreetype.la
|
||||
+ echo ""
|
||||
fi
|
||||
|
||||
# EOF
|
@ -0,0 +1,65 @@
|
||||
--- freetype-2.9/builds/unix/freetype-config.in
|
||||
+++ freetype-2.9/builds/unix/freetype-config.in
|
||||
@@ -13,45 +13,25 @@ LC_ALL=C
|
||||
export LC_ALL
|
||||
|
||||
|
||||
-# if `pkg-config' is available, use values from `freetype2.pc'
|
||||
-%PKG_CONFIG% --atleast-pkgconfig-version 0.24 >/dev/null 2>&1
|
||||
-if test $? -eq 0 ; then
|
||||
- # note that option `--variable' is not affected by the
|
||||
- # PKG_CONFIG_SYSROOT_DIR environment variable
|
||||
- if test "x$SYSROOT" != "x" ; then
|
||||
- PKG_CONFIG_SYSROOT_DIR="$SYSROOT"
|
||||
- export PKG_CONFIG_SYSROOT_DIR
|
||||
- fi
|
||||
-
|
||||
- prefix=`%PKG_CONFIG% --variable prefix freetype2`
|
||||
- exec_prefix=`%PKG_CONFIG% --variable exec_prefix freetype2`
|
||||
-
|
||||
- includedir=`%PKG_CONFIG% --variable includedir freetype2`
|
||||
- libdir=`%PKG_CONFIG% --variable libdir freetype2`
|
||||
-
|
||||
- version=`%PKG_CONFIG% --modversion freetype2`
|
||||
-
|
||||
- cflags=`%PKG_CONFIG% --cflags freetype2`
|
||||
- dynamic_libs=`%PKG_CONFIG% --libs freetype2`
|
||||
- static_libs=`%PKG_CONFIG% --static --libs freetype2`
|
||||
-else
|
||||
- prefix="%prefix%"
|
||||
- exec_prefix="%exec_prefix%"
|
||||
-
|
||||
- includedir="%includedir%"
|
||||
- libdir="%libdir%"
|
||||
-
|
||||
- version=%ft_version%
|
||||
-
|
||||
- cflags="-I${SYSROOT}$includedir/freetype2"
|
||||
- dynamic_libs="-lfreetype"
|
||||
- static_libs="%LIBSSTATIC_CONFIG%"
|
||||
- if test "${SYSROOT}$libdir" != "/usr/lib" &&
|
||||
- test "${SYSROOT}$libdir" != "/usr/lib64" ; then
|
||||
- libs_L="-L${SYSROOT}$libdir"
|
||||
- fi
|
||||
+# note that option `--variable' is not affected by the
|
||||
+# PKG_CONFIG_SYSROOT_DIR environment variable
|
||||
+if test "x$SYSROOT" != "x" ; then
|
||||
+ PKG_CONFIG_SYSROOT_DIR="$SYSROOT"
|
||||
+ export PKG_CONFIG_SYSROOT_DIR
|
||||
fi
|
||||
|
||||
+prefix=`pkgconf --variable prefix freetype2`
|
||||
+exec_prefix=`pkgconf --variable exec_prefix freetype2`
|
||||
+
|
||||
+includedir=`pkgconf --variable includedir freetype2`
|
||||
+libdir=`pkgconf --variable libdir freetype2`
|
||||
+
|
||||
+version=`pkgconf --modversion freetype2`
|
||||
+
|
||||
+cflags=`pkgconf --cflags freetype2`
|
||||
+dynamic_libs=`pkgconf --libs freetype2`
|
||||
+static_libs=`pkgconf --static --libs freetype2`
|
||||
+
|
||||
orig_prefix=$prefix
|
||||
orig_exec_prefix=$exec_prefix
|
||||
|
@ -0,0 +1,14 @@
|
||||
#ifndef __FTCONFIG_H__MULTILIB
|
||||
#define __FTCONFIG_H__MULTILIB
|
||||
|
||||
#include <bits/wordsize.h>
|
||||
|
||||
#if __WORDSIZE == 32
|
||||
# include "ftconfig-32.h"
|
||||
#elif __WORDSIZE == 64
|
||||
# include "ftconfig-64.h"
|
||||
#else
|
||||
# error "unexpected value for __WORDSIZE macro"
|
||||
#endif
|
||||
|
||||
#endif
|
File diff suppressed because it is too large
Load Diff
Loading…
Reference in new issue