commit
1d743e2681
@ -0,0 +1,3 @@
|
||||
0181862673f7216ad2b5074f95fc131209e30b27 SOURCES/freetype-2.10.4.tar.xz
|
||||
9c86a3225cabc659914095c5f97b4844001bb733 SOURCES/freetype-doc-2.10.4.tar.xz
|
||||
d16eef3cb775532995db5826c4f4f6dbe883cc5b SOURCES/ft2demos-2.10.4.tar.xz
|
@ -0,0 +1,3 @@
|
||||
SOURCES/freetype-2.10.4.tar.xz
|
||||
SOURCES/freetype-doc-2.10.4.tar.xz
|
||||
SOURCES/ft2demos-2.10.4.tar.xz
|
@ -0,0 +1,72 @@
|
||||
--- freetype-2.10.0/include/freetype/ftoutln.h
|
||||
+++ freetype-2.10.0/include/freetype/ftoutln.h
|
||||
@@ -165,6 +165,15 @@ FT_BEGIN_HEADER
|
||||
FT_Int numContours,
|
||||
FT_Outline *anoutline );
|
||||
|
||||
+ /*
|
||||
+ * Kept downstream for ABI compatibility only.
|
||||
+ * It just throws error now. Remove once soname has been bumped.
|
||||
+ */
|
||||
+ FT_EXPORT( FT_Error )
|
||||
+ FT_Outline_New_Internal( FT_Memory memory,
|
||||
+ FT_UInt numPoints,
|
||||
+ FT_Int numContours,
|
||||
+ FT_Outline *anoutline );
|
||||
|
||||
/**************************************************************************
|
||||
*
|
||||
@@ -192,6 +201,13 @@ FT_BEGIN_HEADER
|
||||
FT_Outline_Done( FT_Library library,
|
||||
FT_Outline* outline );
|
||||
|
||||
+ /*
|
||||
+ * Kept downstream for ABI compatibility only.
|
||||
+ * It just throws error now. Remove once soname has been bumped.
|
||||
+ */
|
||||
+ FT_EXPORT( FT_Error )
|
||||
+ FT_Outline_Done_Internal( FT_Memory memory,
|
||||
+ FT_Outline* outline );
|
||||
|
||||
/**************************************************************************
|
||||
*
|
||||
--- freetype-2.10.0/src/base/ftoutln.c
|
||||
+++ freetype-2.10.0/src/base/ftoutln.c
|
||||
@@ -291,6 +291,19 @@
|
||||
|
||||
/* documentation is in ftoutln.h */
|
||||
|
||||
+ /*
|
||||
+ * Kept downstream for ABI compatibility only.
|
||||
+ * It just throws error now. Remove once soname has been bumped.
|
||||
+ */
|
||||
+ FT_EXPORT_DEF( FT_Error )
|
||||
+ FT_Outline_New_Internal( FT_Memory memory,
|
||||
+ FT_UInt numPoints,
|
||||
+ FT_Int numContours,
|
||||
+ FT_Outline *anoutline )
|
||||
+ {
|
||||
+ return FT_THROW( Unimplemented_Feature );
|
||||
+ }
|
||||
+
|
||||
FT_EXPORT_DEF( FT_Error )
|
||||
FT_Outline_New( FT_Library library,
|
||||
FT_UInt numPoints,
|
||||
@@ -423,6 +436,17 @@
|
||||
|
||||
/* documentation is in ftoutln.h */
|
||||
|
||||
+ /*
|
||||
+ * Kept downstream for ABI compatibility only.
|
||||
+ * It just throws error now. Remove once soname has been bumped.
|
||||
+ */
|
||||
+ FT_EXPORT_DEF( FT_Error )
|
||||
+ FT_Outline_Done_Internal( FT_Memory memory,
|
||||
+ FT_Outline* outline )
|
||||
+ {
|
||||
+ return FT_THROW( Unimplemented_Feature );
|
||||
+ }
|
||||
+
|
||||
FT_EXPORT_DEF( FT_Error )
|
||||
FT_Outline_Done( FT_Library library,
|
||||
FT_Outline* outline )
|
@ -0,0 +1,13 @@
|
||||
diff --git a/include/freetype/ftmodapi.h b/include/freetype/ftmodapi.h
|
||||
index 8d039c4f3..88488bfe8 100644
|
||||
--- a/include/freetype/ftmodapi.h
|
||||
+++ b/include/freetype/ftmodapi.h
|
||||
@@ -623,7 +623,7 @@ FT_BEGIN_HEADER
|
||||
* it is bytecode interpreter's execution context, `TT_ExecContext`,
|
||||
* which is declared in FreeType's internal header file `tttypes.h`.
|
||||
*/
|
||||
- typedef FT_Error
|
||||
+ typedef void
|
||||
(*FT_DebugHook_Func)( void* arg );
|
||||
|
||||
|
@ -0,0 +1,43 @@
|
||||
From 53dfdcd8198d2b3201a23c4bad9190519ba918db Mon Sep 17 00:00:00 2001
|
||||
From: Werner Lemberg <wl@gnu.org>
|
||||
Date: Thu, 17 Mar 2022 19:24:16 +0100
|
||||
Subject: [PATCH] [sfnt] Avoid invalid face index.
|
||||
|
||||
Fixes #1138.
|
||||
|
||||
* src/sfnt/sfobjs.c (sfnt_init_face), src/sfnt/sfwoff2.c (woff2_open_font):
|
||||
Check `face_index` before decrementing.
|
||||
---
|
||||
src/sfnt/sfobjs.c | 2 +-
|
||||
src/sfnt/sfwoff2.c | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/sfnt/sfobjs.c b/src/sfnt/sfobjs.c
|
||||
index f9d4d3858..9771c35df 100644
|
||||
--- a/src/sfnt/sfobjs.c
|
||||
+++ b/src/sfnt/sfobjs.c
|
||||
@@ -566,7 +566,7 @@
|
||||
face_index = FT_ABS( face_instance_index ) & 0xFFFF;
|
||||
|
||||
/* value -(N+1) requests information on index N */
|
||||
- if ( face_instance_index < 0 )
|
||||
+ if ( face_instance_index < 0 && face_index > 0 )
|
||||
face_index--;
|
||||
|
||||
if ( face_index >= face->ttc_header.count )
|
||||
diff --git a/src/sfnt/sfwoff2.c b/src/sfnt/sfwoff2.c
|
||||
index cb1e0664a..165b875e5 100644
|
||||
--- a/src/sfnt/sfwoff2.c
|
||||
+++ b/src/sfnt/sfwoff2.c
|
||||
@@ -2085,7 +2085,7 @@
|
||||
/* Validate requested face index. */
|
||||
*num_faces = woff2.num_fonts;
|
||||
/* value -(N+1) requests information on index N */
|
||||
- if ( *face_instance_index < 0 )
|
||||
+ if ( *face_instance_index < 0 && face_index > 0 )
|
||||
face_index--;
|
||||
|
||||
if ( face_index >= woff2.num_fonts )
|
||||
--
|
||||
2.35.1
|
||||
|
@ -0,0 +1,45 @@
|
||||
--- freetype-2.10.4/builds/unix/freetype-config.in
|
||||
+++ freetype-2.10.4/builds/unix/freetype-config.in
|
||||
@@ -32,9 +32,6 @@ cflags=`%PKG_CONFIG% --cflags freetype2`
|
||||
dynamic_libs=`pkgconf --libs freetype2`
|
||||
static_libs=`pkgconf --static --libs freetype2`
|
||||
|
||||
-orig_prefix=$prefix
|
||||
-orig_exec_prefix=$exec_prefix
|
||||
-
|
||||
orig_includedir=$includedir
|
||||
orig_libdir=$libdir
|
||||
|
||||
--- freetype-2.10.4/ft2demos-2.10.4/src/ftbench.c
|
||||
+++ freetype-2.10.4/ft2demos-2.10.4/src/ftbench.c
|
||||
@@ -749,6 +749,7 @@
|
||||
{
|
||||
fprintf( stderr,
|
||||
"couldn't allocate memory to pre-load font file\n" );
|
||||
+ fclose( file );
|
||||
|
||||
return 1;
|
||||
}
|
||||
@@ -758,9 +759,12 @@
|
||||
fprintf( stderr, "read error\n" );
|
||||
free( memory_file );
|
||||
memory_file = NULL;
|
||||
+ fclose( file );
|
||||
|
||||
return 1;
|
||||
}
|
||||
+
|
||||
+ fclose( file );
|
||||
}
|
||||
|
||||
error = FT_New_Memory_Face( lib,
|
||||
--- freetype-2.10.4/ft2demos-2.10.4/src/ftgrid.c
|
||||
+++ freetype-2.10.4/ft2demos-2.10.4/src/ftgrid.c
|
||||
@@ -662,6 +662,7 @@
|
||||
break;
|
||||
|
||||
default:
|
||||
+ free( t );
|
||||
return;
|
||||
}
|
||||
|
@ -0,0 +1,27 @@
|
||||
From 0c2bdb01a2e1d24a3e592377a6d0822856e10df2 Mon Sep 17 00:00:00 2001
|
||||
From: Werner Lemberg <wl@gnu.org>
|
||||
Date: Sat, 19 Mar 2022 09:37:28 +0100
|
||||
Subject: [PATCH] * src/base/ftobjs.c (FT_Request_Size): Guard `face->size`.
|
||||
|
||||
Fixes #1140.
|
||||
---
|
||||
src/base/ftobjs.c | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/src/base/ftobjs.c b/src/base/ftobjs.c
|
||||
index 6492a1517..282c9121a 100644
|
||||
--- a/src/base/ftobjs.c
|
||||
+++ b/src/base/ftobjs.c
|
||||
@@ -3409,6 +3409,9 @@
|
||||
if ( !face )
|
||||
return FT_THROW( Invalid_Face_Handle );
|
||||
|
||||
+ if ( !face->size )
|
||||
+ return FT_THROW( Invalid_Size_Handle );
|
||||
+
|
||||
if ( !req || req->width < 0 || req->height < 0 ||
|
||||
req->type >= FT_SIZE_REQUEST_TYPE_MAX )
|
||||
return FT_THROW( Invalid_Argument );
|
||||
--
|
||||
2.35.1
|
||||
|
@ -0,0 +1,43 @@
|
||||
From 007c109b4594c5e63948bd08b4d5011ad76ffb10 Mon Sep 17 00:00:00 2001
|
||||
From: Ben Wagner <bungeman@google.com>
|
||||
Date: Fri, 23 Oct 2020 08:29:14 +0200
|
||||
Subject: [PATCH] * src/sfnt/pngshim.c (Load_SBit_Png): Fix memory leak
|
||||
(#59322).
|
||||
|
||||
The issue is that `rows` is allocated but will not be freed in the
|
||||
event that the call to `png_read_image` fails and calls `longjmp`.
|
||||
---
|
||||
ChangeLog | 7 +++++++
|
||||
src/sfnt/pngshim.c | 1 +
|
||||
2 files changed, 8 insertions(+)
|
||||
|
||||
diff --git a/ChangeLog b/ChangeLog
|
||||
index 42f7c34ba..ff048b8ab 100644
|
||||
--- a/ChangeLog
|
||||
+++ b/ChangeLog
|
||||
@@ -1,3 +1,10 @@
|
||||
+2020-10-23 Ben Wagner <bungeman@google.com>
|
||||
+
|
||||
+ * src/sfnt/pngshim.c (Load_SBit_Png): Fix memory leak (#59322).
|
||||
+
|
||||
+ The issue is that `rows` is allocated but will not be freed in the
|
||||
+ event that the call to `png_read_image` fails and calls `longjmp`.
|
||||
+
|
||||
2020-10-20 Werner Lemberg <wl@gnu.org>
|
||||
|
||||
* Version 2.10.4 released.
|
||||
diff --git a/src/sfnt/pngshim.c b/src/sfnt/pngshim.c
|
||||
index f55016122..d4e43a9f4 100644
|
||||
--- a/src/sfnt/pngshim.c
|
||||
+++ b/src/sfnt/pngshim.c
|
||||
@@ -443,6 +443,7 @@
|
||||
png_read_end( png, info );
|
||||
|
||||
DestroyExit:
|
||||
+ FT_FREE( rows );
|
||||
png_destroy_read_struct( &png, &info, NULL );
|
||||
FT_Stream_Close( &stream );
|
||||
|
||||
--
|
||||
2.26.2
|
||||
|
@ -0,0 +1,46 @@
|
||||
From 22a0cccb4d9d002f33c1ba7a4b36812c7d4f46b5 Mon Sep 17 00:00:00 2001
|
||||
From: Werner Lemberg <wl@gnu.org>
|
||||
Date: Sat, 19 Mar 2022 06:40:17 +0100
|
||||
Subject: [PATCH] * src/base/ftobjs.c (ft_open_face_internal): Properly guard
|
||||
`face_index`.
|
||||
|
||||
We must ensure that the cast to `FT_Int` doesn't change the sign.
|
||||
|
||||
Fixes #1139.
|
||||
---
|
||||
src/base/ftobjs.c | 9 +++++++++
|
||||
1 file changed, 9 insertions(+)
|
||||
|
||||
From d014387ad4a5dd04d8e7f99587c7dacb70261924 Mon Sep 17 00:00:00 2001
|
||||
From: Werner Lemberg <wl@gnu.org>
|
||||
Date: Sat, 19 Mar 2022 09:30:45 +0100
|
||||
Subject: [PATCH 2/2] * src/base/ftobjs.c (ft_open_face_internal): Thinko.
|
||||
|
||||
---
|
||||
src/base/ftobjs.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/base/ftobjs.c b/src/base/ftobjs.c
|
||||
index 2c0f0e6c9..10952a6c6 100644
|
||||
--- a/src/base/ftobjs.c
|
||||
+++ b/src/base/ftobjs.c
|
||||
@@ -2527,6 +2527,16 @@
|
||||
#endif
|
||||
|
||||
|
||||
+ /* only use lower 31 bits together with sign bit */
|
||||
+ if ( face_index > 0 )
|
||||
+ face_index &= 0x7FFFFFFFL;
|
||||
+ else
|
||||
+ {
|
||||
+ face_index = -face_index;
|
||||
+ face_index &= 0x7FFFFFFFL;
|
||||
+ face_index = -face_index;
|
||||
+ }
|
||||
+
|
||||
#ifdef FT_DEBUG_LEVEL_TRACE
|
||||
FT_TRACE3(( "FT_Open_Face: " ));
|
||||
if ( face_index < 0 )
|
||||
--
|
||||
2.35.1
|
||||
|
@ -0,0 +1,20 @@
|
||||
--- freetype-2.2.1/modules.cfg.orig 2006-07-07 21:01:09.000000000 -0400
|
||||
+++ freetype-2.2.1/modules.cfg 2006-07-07 21:01:54.000000000 -0400
|
||||
@@ -110,7 +110,7 @@
|
||||
|
||||
# TrueType GX/AAT table validation. Needs `ftgxval.c' below.
|
||||
#
|
||||
-# AUX_MODULES += gxvalid
|
||||
+AUX_MODULES += gxvalid
|
||||
|
||||
# Support for streams compressed with gzip (files with suffix .gz).
|
||||
#
|
||||
@@ -124,7 +124,7 @@
|
||||
|
||||
# OpenType table validation. Needs `ftotval.c' below.
|
||||
#
|
||||
-# AUX_MODULES += otvalid
|
||||
+AUX_MODULES += otvalid
|
||||
|
||||
# Auxiliary PostScript driver component to share common code.
|
||||
#
|
@ -0,0 +1,11 @@
|
||||
--- freetype-2.3.0/include/freetype/config/ftoption.h.spf 2007-01-18 14:27:34.000000000 -0500
|
||||
+++ freetype-2.3.0/include/freetype/config/ftoption.h 2007-01-18 14:27:48.000000000 -0500
|
||||
@@ -92,7 +92,7 @@
|
||||
* When this macro is not defined, FreeType offers alternative LCD
|
||||
* rendering technology that produces excellent output.
|
||||
*/
|
||||
-/* #define FT_CONFIG_OPTION_SUBPIXEL_RENDERING */
|
||||
+#define FT_CONFIG_OPTION_SUBPIXEL_RENDERING
|
||||
|
||||
|
||||
/**************************************************************************
|
@ -0,0 +1,17 @@
|
||||
--- ft2demos-2.5.2/Makefile
|
||||
+++ ft2demos-2.5.2/Makefile
|
||||
@@ -296,10 +296,10 @@ else
|
||||
# The following programs are not compiled automatically; either comment
|
||||
# out the affected line or use the program name as a Makefile target.
|
||||
#
|
||||
- # EXES += ftchkwd
|
||||
- # EXES += ftmemchk
|
||||
- # EXES += ftpatchk
|
||||
- # EXES += fttimer
|
||||
+ EXES += ftchkwd
|
||||
+ EXES += ftmemchk
|
||||
+ EXES += ftpatchk
|
||||
+ EXES += fttimer
|
||||
# EXES += testname
|
||||
|
||||
exes: $(EXES:%=$(BIN_DIR_2)/%$E)
|
@ -0,0 +1,11 @@
|
||||
--- freetype-2.8/builds/unix/freetype-config.in.orig 2017-03-30 12:20:23.000000001 +0200
|
||||
+++ freetype-2.8/builds/unix/freetype-config.in 2017-05-16 13:25:39.223041128 +0200
|
||||
@@ -205,7 +205,7 @@ if test "$echo_libs" = "yes" ; then
|
||||
fi
|
||||
|
||||
if test "$echo_libtool" = "yes" ; then
|
||||
- echo ${SYSROOT}$libdir/libfreetype.la
|
||||
+ echo ""
|
||||
fi
|
||||
|
||||
# EOF
|
@ -0,0 +1,65 @@
|
||||
--- freetype-2.9/builds/unix/freetype-config.in
|
||||
+++ freetype-2.9/builds/unix/freetype-config.in
|
||||
@@ -13,45 +13,25 @@ LC_ALL=C
|
||||
export LC_ALL
|
||||
|
||||
|
||||
-# if `pkg-config' is available, use values from `freetype2.pc'
|
||||
-%PKG_CONFIG% --atleast-pkgconfig-version 0.24 >/dev/null 2>&1
|
||||
-if test $? -eq 0 ; then
|
||||
- # note that option `--variable' is not affected by the
|
||||
- # PKG_CONFIG_SYSROOT_DIR environment variable
|
||||
- if test "x$SYSROOT" != "x" ; then
|
||||
- PKG_CONFIG_SYSROOT_DIR="$SYSROOT"
|
||||
- export PKG_CONFIG_SYSROOT_DIR
|
||||
- fi
|
||||
-
|
||||
- prefix=`%PKG_CONFIG% --variable prefix freetype2`
|
||||
- exec_prefix=`%PKG_CONFIG% --variable exec_prefix freetype2`
|
||||
-
|
||||
- includedir=`%PKG_CONFIG% --variable includedir freetype2`
|
||||
- libdir=`%PKG_CONFIG% --variable libdir freetype2`
|
||||
-
|
||||
- version=`%PKG_CONFIG% --modversion freetype2`
|
||||
-
|
||||
- cflags=`%PKG_CONFIG% --cflags freetype2`
|
||||
- dynamic_libs=`%PKG_CONFIG% --libs freetype2`
|
||||
- static_libs=`%PKG_CONFIG% --static --libs freetype2`
|
||||
-else
|
||||
- prefix="%prefix%"
|
||||
- exec_prefix="%exec_prefix%"
|
||||
-
|
||||
- includedir="%includedir%"
|
||||
- libdir="%libdir%"
|
||||
-
|
||||
- version=%ft_version%
|
||||
-
|
||||
- cflags="-I${SYSROOT}$includedir/freetype2"
|
||||
- dynamic_libs="-lfreetype"
|
||||
- static_libs="%LIBSSTATIC_CONFIG%"
|
||||
- if test "${SYSROOT}$libdir" != "/usr/lib" &&
|
||||
- test "${SYSROOT}$libdir" != "/usr/lib64" ; then
|
||||
- libs_L="-L${SYSROOT}$libdir"
|
||||
- fi
|
||||
+# note that option `--variable' is not affected by the
|
||||
+# PKG_CONFIG_SYSROOT_DIR environment variable
|
||||
+if test "x$SYSROOT" != "x" ; then
|
||||
+ PKG_CONFIG_SYSROOT_DIR="$SYSROOT"
|
||||
+ export PKG_CONFIG_SYSROOT_DIR
|
||||
fi
|
||||
|
||||
+prefix=`pkgconf --variable prefix freetype2`
|
||||
+exec_prefix=`pkgconf --variable exec_prefix freetype2`
|
||||
+
|
||||
+includedir=`pkgconf --variable includedir freetype2`
|
||||
+libdir=`pkgconf --variable libdir freetype2`
|
||||
+
|
||||
+version=`pkgconf --modversion freetype2`
|
||||
+
|
||||
+cflags=`pkgconf --cflags freetype2`
|
||||
+dynamic_libs=`pkgconf --libs freetype2`
|
||||
+static_libs=`pkgconf --static --libs freetype2`
|
||||
+
|
||||
orig_prefix=$prefix
|
||||
orig_exec_prefix=$exec_prefix
|
||||
|
@ -0,0 +1,14 @@
|
||||
#ifndef __FTCONFIG_H__MULTILIB
|
||||
#define __FTCONFIG_H__MULTILIB
|
||||
|
||||
#include <bits/wordsize.h>
|
||||
|
||||
#if __WORDSIZE == 32
|
||||
# include "ftconfig-32.h"
|
||||
#elif __WORDSIZE == 64
|
||||
# include "ftconfig-64.h"
|
||||
#else
|
||||
# error "unexpected value for __WORDSIZE macro"
|
||||
#endif
|
||||
|
||||
#endif
|
File diff suppressed because it is too large
Load Diff
Loading…
Reference in new issue