parent
f4bde25659
commit
1eed0765e0
@ -0,0 +1,134 @@
|
||||
diff -urN Firebird-3.0.3.32900-0.old/builds/posix/prefix.linux_riscv64 Firebird-3.0.3.32900-0/builds/posix/prefix.linux_riscv64
|
||||
--- Firebird-3.0.3.32900-0.old/builds/posix/prefix.linux_riscv64 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ Firebird-3.0.3.32900-0/builds/posix/prefix.linux_riscv64 2018-03-19 08:56:57.254118156 +0000
|
||||
@@ -0,0 +1,26 @@
|
||||
+# The contents of this file are subject to the Interbase Public
|
||||
+# License Version 1.0 (the "License"); you may not use this file
|
||||
+# except in compliance with the License. You may obtain a copy
|
||||
+# of the License at http://www.Inprise.com/IPL.html
|
||||
+#
|
||||
+# Software distributed under the License is distributed on an
|
||||
+# "AS IS" basis, WITHOUT WARRANTY OF ANY KIND, either express
|
||||
+# or implied. See the License for the specific language governing
|
||||
+# rights and limitations under the License.
|
||||
+#
|
||||
+# The Original Code was created by Inprise Corporation
|
||||
+# and its predecessors. Portions created by Inprise Corporation are
|
||||
+# Copyright (C) Inprise Corporation.
|
||||
+#
|
||||
+# All Rights Reserved.
|
||||
+# Contributor(s): ______________________________________.
|
||||
+# Start of file prefix.linux: $(VERSION) $(PLATFORM)
|
||||
+#
|
||||
+# Richard W.M. Jones, Red Hat Inc.
|
||||
+
|
||||
+WARN_FLAGS=-Wall -Wno-switch -Wno-parentheses -Wno-unknown-pragmas -Wno-unused-variable -Wno-invalid-offsetof -Wno-narrowing -Wno-unused-local-typedefs
|
||||
+
|
||||
+PROD_FLAGS=-O3 -DLINUX -DRISCV64 -pipe -p -MMD -fPIC -fsigned-char -fmessage-length=0
|
||||
+DEV_FLAGS=-ggdb -DLINUX -DRISCV64 -pipe -p -MMD -fPIC -Wall -fsigned-char -fmessage-length=0 $(WARN_FLAGS)
|
||||
+
|
||||
+CXXFLAGS := $(CXXFLAGS) -std=c++11
|
||||
diff -urN Firebird-3.0.3.32900-0.old/configure.ac Firebird-3.0.3.32900-0/configure.ac
|
||||
--- Firebird-3.0.3.32900-0.old/configure.ac 2018-03-19 08:56:23.222156918 +0000
|
||||
+++ Firebird-3.0.3.32900-0/configure.ac 2018-03-19 08:56:57.254118156 +0000
|
||||
@@ -251,6 +251,18 @@
|
||||
libdir=/usr/lib64
|
||||
;;
|
||||
|
||||
+ riscv64*-*-linux*)
|
||||
+ MAKEFILE_PREFIX=linux_riscv64
|
||||
+ INSTALL_PREFIX=linux
|
||||
+ PLATFORM=LINUX
|
||||
+ AC_DEFINE(LINUX, 1, [Define this if OS is Linux])
|
||||
+ EDITLINE_FLG=Y
|
||||
+ SHRLIB_EXT=so
|
||||
+ STD_EDITLINE=true
|
||||
+ STD_ICU=true
|
||||
+ libdir=/usr/lib64
|
||||
+ ;;
|
||||
+
|
||||
powerpc64le-*-linux*)
|
||||
MAKEFILE_PREFIX=linux_powerpc64el
|
||||
INSTALL_PREFIX=linux
|
||||
diff -urN Firebird-3.0.3.32900-0.old/src/common/classes/DbImplementation.cpp Firebird-3.0.3.32900-0/src/common/classes/DbImplementation.cpp
|
||||
--- Firebird-3.0.3.32900-0.old/src/common/classes/DbImplementation.cpp 2018-02-02 11:00:35.000000000 +0000
|
||||
+++ Firebird-3.0.3.32900-0/src/common/classes/DbImplementation.cpp 2018-03-19 08:56:57.254118156 +0000
|
||||
@@ -49,6 +49,7 @@
|
||||
static const UCHAR CpuArm64 = 15;
|
||||
static const UCHAR CpuPowerPc64el = 16;
|
||||
static const UCHAR CpuM68k = 17;
|
||||
+static const UCHAR CpuRiscV64 = 18;
|
||||
|
||||
static const UCHAR OsWindows = 0;
|
||||
static const UCHAR OsLinux = 1;
|
||||
@@ -89,7 +90,8 @@
|
||||
"Alpha",
|
||||
"ARM64",
|
||||
"PowerPC64el",
|
||||
- "M68k"
|
||||
+ "M68k",
|
||||
+ "RiscV64"
|
||||
};
|
||||
|
||||
const char* operatingSystem[] = {
|
||||
@@ -116,22 +118,22 @@
|
||||
// This table lists pre-fb3 implementation codes
|
||||
const UCHAR backwardTable[FB_NELEM(hardware) * FB_NELEM(operatingSystem)] =
|
||||
{
|
||||
-// Intel AMD Sparc PPC PPC64 MIPSEL MIPS ARM IA64 s390 s390x SH SHEB HPPA Alpha ARM64 PowerPC64el
|
||||
-/* Windows */ 50, 68, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,
|
||||
-/* Linux */ 60, 66, 65, 69, 86, 71, 72, 75, 76, 79, 78, 80, 81, 82, 83, 84, 85,
|
||||
-/* Darwin */ 70, 73, 0, 63, 77, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,
|
||||
-/* Solaris */ 0, 0, 30, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,
|
||||
-/* HPUX */ 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 31, 0, 0, 0,
|
||||
-/* AIX */ 0, 0, 0, 35, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,
|
||||
-/* MVS */ 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,
|
||||
-/* FreeBSD */ 61, 67, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,
|
||||
-/* NetBSD */ 62, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0
|
||||
+// Intel AMD Sparc PPC PPC64 MIPSEL MIPS ARM IA64 s390 s390x SH SHEB HPPA Alpha ARM64 PowerPC64el RiscV64
|
||||
+/* Windows */ 50, 68, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,
|
||||
+/* Linux */ 60, 66, 65, 69, 86, 71, 72, 75, 76, 79, 78, 80, 81, 82, 83, 84, 85, 88,
|
||||
+/* Darwin */ 70, 73, 0, 63, 77, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,
|
||||
+/* Solaris */ 0, 0, 30, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,
|
||||
+/* HPUX */ 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 31, 0, 0, 0, 0,
|
||||
+/* AIX */ 0, 0, 0, 35, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,
|
||||
+/* MVS */ 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,
|
||||
+/* FreeBSD */ 61, 67, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,
|
||||
+/* NetBSD */ 62, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0
|
||||
};
|
||||
|
||||
const UCHAR backEndianess[FB_NELEM(hardware)] =
|
||||
{
|
||||
-// Intel AMD Sparc PPC PPC64 MIPSEL MIPS ARM IA64 s390 s390x SH SHEB HPPA Alpha ARM64 PowerPC64el M68k
|
||||
- 0, 0, 1, 1, 1, 0, 1, 0, 0, 1, 1, 0, 1, 1, 0, 0, 0, 1
|
||||
+// Intel AMD Sparc PPC PPC64 MIPSEL MIPS ARM IA64 s390 s390x SH SHEB HPPA Alpha ARM64 PowerPC64el M68k RiscV64
|
||||
+ 0, 0, 1, 1, 1, 0, 1, 0, 0, 1, 1, 0, 1, 1, 0, 0, 0, 1, 0,
|
||||
};
|
||||
|
||||
} // anonymous namespace
|
||||
diff -urN Firebird-3.0.3.32900-0.old/src/common/common.h Firebird-3.0.3.32900-0/src/common/common.h
|
||||
--- Firebird-3.0.3.32900-0.old/src/common/common.h 2018-03-19 08:56:23.377156741 +0000
|
||||
+++ Firebird-3.0.3.32900-0/src/common/common.h 2018-03-19 08:56:57.255118154 +0000
|
||||
@@ -135,6 +135,10 @@
|
||||
#define FB_CPU CpuArm64
|
||||
#endif /* ARM64 */
|
||||
|
||||
+#ifdef RISCV64
|
||||
+#define FB_CPU CpuRiscV64
|
||||
+#endif /* RISCV64 */
|
||||
+
|
||||
#ifdef sparc
|
||||
#define FB_CPU CpuUltraSparc
|
||||
#define RISC_ALIGNMENT
|
||||
diff -urN Firebird-3.0.3.32900-0.old/src/jrd/inf_pub.h Firebird-3.0.3.32900-0/src/jrd/inf_pub.h
|
||||
--- Firebird-3.0.3.32900-0.old/src/jrd/inf_pub.h 2018-02-02 11:00:36.000000000 +0000
|
||||
+++ Firebird-3.0.3.32900-0/src/jrd/inf_pub.h 2018-03-19 08:56:57.255118154 +0000
|
||||
@@ -245,7 +245,7 @@
|
||||
isc_info_db_impl_linux_ppc64el = 85,
|
||||
isc_info_db_impl_linux_ppc64 = 86,
|
||||
isc_info_db_impl_linux_m68k = 87,
|
||||
-
|
||||
+ isc_info_db_impl_linux_riscv64 = 88,
|
||||
|
||||
isc_info_db_impl_last_value // Leave this LAST!
|
||||
};
|
@ -0,0 +1,29 @@
|
||||
From: asfernandes <asfernandes@users.sourceforge.net>
|
||||
Date: Sat, 5 Mar 2016 03:39:36 +0000
|
||||
Subject: Make the generated code compatible with gcc 6 in C++-14 mode.
|
||||
(cherry picked from commit 3618aa2171674babf79ef935aa049c40a3db1321)
|
||||
Patch-mainline:
|
||||
Git-commit: 3618aa2171674babf79ef935aa049c40a3db1321
|
||||
References: bsc#964466 CORE-5099
|
||||
|
||||
---
|
||||
src/gpre/c_cxx.cpp | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/gpre/c_cxx.cpp b/src/gpre/c_cxx.cpp
|
||||
index df175dca9465..bafce8f282bf 100644
|
||||
--- a/src/gpre/c_cxx.cpp
|
||||
+++ b/src/gpre/c_cxx.cpp
|
||||
@@ -2820,7 +2820,7 @@ static void gen_request(const gpre_req* request)
|
||||
printa(0, "static %sshort\n isc_%dl = %d;",
|
||||
(request->req_flags & REQ_extend_dpb) ? "" : CONST_STR,
|
||||
request->req_ident, request->req_length);
|
||||
- printa(0, "static %schar\n isc_%d [] = {", CONST_STR, request->req_ident);
|
||||
+ printa(0, "static %sunsigned char\n isc_%d [] = {", CONST_STR, request->req_ident);
|
||||
|
||||
const TEXT* string_type = "blr";
|
||||
if (gpreGlob.sw_raw)
|
||||
--
|
||||
2.8.2
|
||||
|
||||
|
Loading…
Reference in new issue