Add patch "STAT_VER changes for different architectures"

i9ce
Sérgio M. Basto 4 years ago
parent fded5b1cc6
commit b05cbb1201

@ -0,0 +1,30 @@
From 57731fb5071b86d70d5a3e207addaabdde23111e Mon Sep 17 00:00:00 2001
From: Dimitri John Ledkov <xnox@ubuntu.com>
Date: Wed, 17 Feb 2021 14:41:43 +0000
Subject: [PATCH] Add _STAT_VER defines for ppc64le, riscv64, s390x.
Signed-off-by: Dimitri John Ledkov <xnox@ubuntu.com>
---
libfakeroot.c | 6 ++++++
1 file changed, 6 insertions(+)
diff --git a/libfakeroot.c b/libfakeroot.c
index 7593dd6..f9ca182 100644
--- a/libfakeroot.c
+++ b/libfakeroot.c
@@ -93,6 +93,12 @@
#ifndef _STAT_VER
#if defined (__aarch64__)
#define _STAT_VER 0
+ #elif defined (__powerpc__) && __WORDSIZE == 64
+ #define _STAT_VER 1
+ #elif defined (__riscv) && __riscv_xlen==64
+ #define _STAT_VER 0
+ #elif defined (__s390x__)
+ #define _STAT_VER 1
#elif defined (__x86_64__)
#define _STAT_VER 1
#else
--
GitLab

@ -22,8 +22,7 @@ Patch6: 0001-libfakeroot.c-define-_STAT_VER-if-not-already-define.patch
Patch7: 0002-libfakeroot.c-add-wrappers-for-new-glibc-2.33-symbol.patch
Patch8: 0003-libfakeroot.c-fix-compile-error-with-DEBUG-enabled.patch
Patch9: 0004-configure.ac-fix-__xmknod-at-pointer-argument.patch
#Patch10: 0005-libfakeroot.c-fix-fts_read-and-fts_children.patch
Patch11: 0006-OS-X-portability.patch
Patch10: 57731fb5071b86d70d5a3e207addaabdde23111e.patch
BuildRequires: make
@ -168,7 +167,7 @@ fi
0002-libfakeroot.c-add-wrappers-for-new-glibc-2.33-symbol.patch
0003-libfakeroot.c-fix-compile-error-with-DEBUG-enabled.patch
0004-configure.ac-fix-__xmknod-at-pointer-argument.patch
0006-OS-X-portability.patch
- Add patch "STAT_VER changes for different architectures"
* Wed Oct 14 2020 Dominik Mierzejewski <rpm@greysector.net> - 1.25.3-1
- update to 1.25.3 (#1886610)

Loading…
Cancel
Save