- update to 2.7 - don't install internal libmp4ff - include manpage - fix build on x86_64 (non-PIC objects in libmp4ff.a) - fix rpaths - make xmms plugin depend on -libs, not the frontendel8
parent
6fb63b583d
commit
6c033c303d
@ -1 +1 @@
|
||||
faad2-2.6.1.tar.gz
|
||||
faad2-2.7.tar.bz2
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -up faad2/frontend/main.c.cve faad2/frontend/main.c
|
||||
--- faad2/frontend/main.c.cve 2007-11-01 13:33:29.000000000 +0100
|
||||
+++ faad2/frontend/main.c 2008-11-10 22:43:49.000000000 +0100
|
||||
@@ -914,6 +914,8 @@ int decodeMP4file(char *mp4file, char *s
|
||||
sample_count = frameInfo.samples;
|
||||
} else {
|
||||
sample_count = (unsigned int)(dur * frameInfo.channels);
|
||||
+ if (sample_count > frameInfo.samples)
|
||||
+ sample_count = frameInfo.samples;
|
||||
|
||||
if (!useAacLength && !initial && (sampleId < numSamples/2) && (sample_count != frameInfo.samples))
|
||||
{
|
@ -0,0 +1,12 @@
|
||||
diff -up faad2-2.7/common/mp4ff/Makefile.in.pic faad2-2.7/common/mp4ff/Makefile.in
|
||||
--- faad2-2.7/common/mp4ff/Makefile.in.pic 2009-02-10 09:36:11.000000000 +0100
|
||||
+++ faad2-2.7/common/mp4ff/Makefile.in 2009-03-14 12:38:40.000000000 +0100
|
||||
@@ -93,7 +94,7 @@ AUTOMAKE = @AUTOMAKE@
|
||||
AWK = @AWK@
|
||||
CC = @CC@
|
||||
CCDEPMODE = @CCDEPMODE@
|
||||
-CFLAGS = @CFLAGS@
|
||||
+CFLAGS = @CFLAGS@ -DPIC -fPIC
|
||||
CPP = @CPP@
|
||||
CPPFLAGS = @CPPFLAGS@
|
||||
CXX = @CXX@
|
Loading…
Reference in new issue