Update to 2.9.1

el9
leigh123linux 5 years ago
parent 02aba6eff4
commit 42d374b5a6

1
.gitignore vendored

@ -1,3 +1,4 @@
faad2-2.7.tar.bz2
/faad2-2.8.1.tar.bz2
/faad2-2.8.8.tar.gz
/faad2-2_9_1.tar.gz

@ -1,25 +0,0 @@
--- faad2/libfaad/bits.c 2007-11-01 13:33:29.000000000 +0100
+++ faad2.new/libfaad/bits.c 2019-03-25 17:29:26.134199188 +0100
@@ -167,7 +167,10 @@
int words = bits >> 5;
int remainder = bits & 0x1F;
- ld->bytes_left = ld->buffer_size - words*4;
+ if (ld->buffer_size < words * 4)
+ ld->bytes_left = 0;
+ else
+ ld->bytes_left = ld->buffer_size - words*4;
if (ld->bytes_left >= 4)
{
--- faad2/libfaad/syntax.c 2019-03-25 17:57:36.930937066 +0100
+++ faad2.new/libfaad/syntax.c 2019-03-25 17:49:26.135368525 +0100
@@ -2292,6 +2292,8 @@
while ((drc->additional_excluded_chns[n-1] = faad_get1bit(ld
DEBUGVAR(1,104,"excluded_channels(): additional_excluded_chns"))) == 1)
{
+ if (i >= MAX_CHANNELS - num_excl_chan - 7)
+ return n;
for (i = num_excl_chan; i < num_excl_chan+7; i++)
{
drc->exclude_mask[i] = faad_get1bit(ld

@ -10,14 +10,3 @@
libmp4ff_a_SOURCES = mp4ff.c mp4atom.c mp4meta.c mp4sample.c mp4util.c \
mp4tagupdate.c mp4ff.h mp4ffint.h
--- a/common/mp4ff/Makefile.in
+++ b/common/mp4ff/Makefile.in
@@ -308,7 +307,7 @@
top_srcdir = @top_srcdir@
noinst_LIBRARIES = libmp4ff.a
noinst_HEADERS = mp4ff.h mp4ffint.h
-libmp4ff_a_CFLAGS = -DUSE_TAGGING=1
+libmp4ff_a_CFLAGS = -DUSE_TAGGING=1 -DPIC -fPIC
libmp4ff_a_SOURCES = mp4ff.c mp4atom.c mp4meta.c mp4sample.c mp4util.c \
mp4tagupdate.c mp4ff.h mp4ffint.h

@ -2,22 +2,25 @@
%global _with_xmms 1
%global xmmsinputplugindir %(xmms-config --input-plugin-dir 2>/dev/null)
%endif
%global _version 2_9_1
Summary: Library and frontend for decoding MPEG2/4 AAC
Name: faad2
Epoch: 1
Version: 2.8.8
Release: 7%{?dist}
Version: 2.9.1
Release: 1%{?dist}
License: GPLv2+
URL: http://www.audiocoding.com/faad2.html
Source: http://downloads.sourceforge.net/sourceforge/faac/%{name}-%{version}.tar.gz
Source: https://github.com/knik0/faad2/archive/%{_version}/%{name}-%{_version}.tar.gz
Patch0: https://github.com/knik0/faad2/commit/5530ffdfa6e9d89f5956b8a0901b5d168ce7d46b.patch#/readd_files_xmms.patch
# fix non-PIC objects in libmp4ff.a
Patch0: %{name}-pic.patch
Patch1: fix_undefined_version.patch
# Security issue from videolan contribs
Patch2: faad2-fix-overflows.patch
Patch1: %{name}-pic.patch
Patch2: fix_undefined_version.patch
BuildRequires: gcc-c++
BuildRequires: automake
BuildRequires: libtool
BuildRequires: libsysfs-devel
%{?_with_xmms:
BuildRequires: id3lib-devel
@ -68,7 +71,11 @@ This package contains an input plugin for xmms.
}
%prep
%autosetup -p1
%setup -q -n %{name}-%{_version}
%patch0 -R -p1
%patch1 -p1
%patch2 -p1
./bootstrap
%build
%configure \
@ -113,6 +120,9 @@ find $RPM_BUILD_ROOT -name '*.la' -or -name '*.a' | xargs rm -f
}
%changelog
* Wed Jan 01 2020 Leigh Scott <leigh123linux@googlemail.com> - 1:2.9.1-1
- Update to 2.9.1
* Fri Aug 09 2019 RPM Fusion Release Engineering <leigh123linux@gmail.com> - 1:2.8.8-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

@ -5,7 +5,7 @@
#endif
-#define FAAD2_VERSION "unknown"
+#define FAAD2_VERSION "2.8.8"
+#define FAAD2_VERSION "2.9.1"
/* object types for AAC */
#define MAIN 1

File diff suppressed because it is too large Load Diff

@ -1 +1 @@
28f6116efdbe9378269f8a6221767d1f faad2-2.8.8.tar.gz
SHA512 (faad2-2_9_1.tar.gz) = 1015f5b49baebf6c9404cfcd7b9d524cc76a57abcd1a46bb851463ae5226bfd8b80155b661708f66548466422855cd7aeec5676463cd1346c5fb1dc0821621ce

Loading…
Cancel
Save