Added yandex support(fix)

i9-beta
Alexey Berezhok 1 year ago committed by Sergey Cherevko
parent 8d9521c40f
commit 32fddc15eb
Signed by: scherevko
GPG Key ID: D87CBBC16D2E4A72

@ -4,8 +4,6 @@ Date: Mon, 15 May 2023 19:07:27 +0300
Subject: [PATCH] Added yandex backend support(prebuild)
---
.gitignore | 1 +
.vscode/c_cpp_properties.json | 3 +-
CMakeLists.txt | 11 +
config.h.in | 6 +
...gnome.evolution-data-server.gschema.xml.in | 10 +
@ -38,29 +36,6 @@ Subject: [PATCH] Added yandex backend support(prebuild)
create mode 100644 src/modules/yandex-backend/CMakeLists.txt
create mode 100644 src/modules/yandex-backend/module-yandex-backend.c
diff --git a/.gitignore b/.gitignore
index 726890e..575a9f0 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,4 @@ _build
.build
*.orig
*.rej
+.vscode/
diff --git a/.vscode/c_cpp_properties.json b/.vscode/c_cpp_properties.json
index a070080..6cc85df 100644
--- a/.vscode/c_cpp_properties.json
+++ b/.vscode/c_cpp_properties.json
@@ -6,7 +6,8 @@
"${workspaceFolder}/**",
"/usr/include/goa-1.0",
"/usr/include/glib-2.0",
- "/usr/lib64/glib-2.0/include/"
+ "/usr/lib64/glib-2.0/include/",
+ "/usr/include/libsoup-2.4"
],
"defines": [],
"compilerPath": "/usr/bin/gcc",
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2bad65e..d7deb4a 100644
--- a/CMakeLists.txt

@ -425,6 +425,7 @@ find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \;
%{modules_dir}/module-secret-monitor.so
%{modules_dir}/module-webdav-backend.so
%{modules_dir}/module-yahoo-backend.so
%{modules_dir}/module-yandex-backend.so
%files devel
%{_includedir}/evolution-data-server/camel
@ -525,6 +526,9 @@ find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \;
* Tue Oct 10 2023 Milan Crha <mcrha@redhat.com> - 3.40.4-7
- Resolves: RHEL-12405 (Move WebKitGTK parts in Evolution Data Server into optional subpackage)
* Tue May 23 2023 Alexey Berezhok <alexey.berezhok@msvsphere.ru> - 3.40.4-6.inferit.2
- Added yandex provider support
* Tue May 23 2023 Alexey Berezhok <alexey.berezhok@msvsphere.ru> - 3.40.4-6.inferit.1
- Added fix for pesign-client for db unlocking

Loading…
Cancel
Save