|
|
|
@ -4,8 +4,6 @@ Date: Mon, 15 May 2023 19:07:27 +0300
|
|
|
|
|
Subject: [PATCH] Added yandex backend support(prebuild)
|
|
|
|
|
|
|
|
|
|
---
|
|
|
|
|
.gitignore | 1 +
|
|
|
|
|
.vscode/c_cpp_properties.json | 3 +-
|
|
|
|
|
CMakeLists.txt | 11 +
|
|
|
|
|
config.h.in | 6 +
|
|
|
|
|
...gnome.evolution-data-server.gschema.xml.in | 10 +
|
|
|
|
@ -38,29 +36,6 @@ Subject: [PATCH] Added yandex backend support(prebuild)
|
|
|
|
|
create mode 100644 src/modules/yandex-backend/CMakeLists.txt
|
|
|
|
|
create mode 100644 src/modules/yandex-backend/module-yandex-backend.c
|
|
|
|
|
|
|
|
|
|
diff --git a/.gitignore b/.gitignore
|
|
|
|
|
index 726890e..575a9f0 100644
|
|
|
|
|
--- a/.gitignore
|
|
|
|
|
+++ b/.gitignore
|
|
|
|
|
@@ -3,3 +3,4 @@ _build
|
|
|
|
|
.build
|
|
|
|
|
*.orig
|
|
|
|
|
*.rej
|
|
|
|
|
+.vscode/
|
|
|
|
|
diff --git a/.vscode/c_cpp_properties.json b/.vscode/c_cpp_properties.json
|
|
|
|
|
index a070080..6cc85df 100644
|
|
|
|
|
--- a/.vscode/c_cpp_properties.json
|
|
|
|
|
+++ b/.vscode/c_cpp_properties.json
|
|
|
|
|
@@ -6,7 +6,8 @@
|
|
|
|
|
"${workspaceFolder}/**",
|
|
|
|
|
"/usr/include/goa-1.0",
|
|
|
|
|
"/usr/include/glib-2.0",
|
|
|
|
|
- "/usr/lib64/glib-2.0/include/"
|
|
|
|
|
+ "/usr/lib64/glib-2.0/include/",
|
|
|
|
|
+ "/usr/include/libsoup-2.4"
|
|
|
|
|
],
|
|
|
|
|
"defines": [],
|
|
|
|
|
"compilerPath": "/usr/bin/gcc",
|
|
|
|
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
|
|
|
index 2bad65e..d7deb4a 100644
|
|
|
|
|
--- a/CMakeLists.txt
|
|
|
|
|