parent
27b0c7eb9d
commit
762b23577b
@ -1,162 +1,86 @@
|
||||
From 0db724a7da5dca0507eddd75124d2374c2b5244b Mon Sep 17 00:00:00 2001
|
||||
From: Sergey Cherevko <s.cherevko@msvsphere.ru>
|
||||
Date: Wed, 17 May 2023 12:56:28 +0300
|
||||
From 5d431acad965384bec4cf0df1d07f59ddbd414ef Mon Sep 17 00:00:00 2001
|
||||
From: tigro <tigro@msvsphere-os.ru>
|
||||
Date: Tue, 12 Dec 2023 16:25:36 +0300
|
||||
Subject: [PATCH] eth fast fabric 11 msvsphere_support
|
||||
|
||||
---
|
||||
CommonInstall/util_init.pl | 14 +++++++++++++-
|
||||
MakeTools/funcs-ext.sh | 10 ++++++++++
|
||||
OpenIb_Host/update_mpi_spec.sh | 2 +-
|
||||
get_id_and_versionid.sh | 7 +++++++
|
||||
update_eth_spec.sh | 2 +-
|
||||
5 files changed, 32 insertions(+), 3 deletions(-)
|
||||
CommonInstall/util_init.pl | 2 ++
|
||||
MakeTools/funcs-ext.sh | 1 +
|
||||
OpenIb_Host/build_packages.sh | 2 +-
|
||||
OpenIb_Host/get_id_and_versionid.sh | 1 +
|
||||
build_package.sh | 2 +-
|
||||
5 files changed, 6 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/CommonInstall/util_init.pl b/CommonInstall/util_init.pl
|
||||
index 07220bd..8e85334 100755
|
||||
index 452b93d..d3f5a4a 100755
|
||||
--- a/CommonInstall/util_init.pl
|
||||
+++ b/CommonInstall/util_init.pl
|
||||
@@ -213,7 +213,7 @@ sub os_vendor_version($)
|
||||
chop($rval);
|
||||
$rval="ES".$rval;
|
||||
if ( -e "/etc/redhat-release" ) {
|
||||
- if (!system("grep -qi centos /etc/redhat-release") || !system("grep -qi rocky /etc/redhat-release") || !system("grep -qi almalinux /etc/redhat-release") || !system("grep -qi circle /etc/redhat-release")) {
|
||||
+ if (!system("grep -qi centos /etc/redhat-release") || !system("grep -qi rocky /etc/redhat-release") || !system("grep -qi almalinux /etc/redhat-release") || !system("grep -qi circle /etc/redhat-release")) || !system("grep -qi msvsphere /etc/redhat-release")) {
|
||||
$rval = `cat /etc/redhat-release | cut -d' ' -f4`;
|
||||
$rval =~ m/(\d+).(\d+)/;
|
||||
if ($2 eq "0") {
|
||||
@@ -261,6 +261,12 @@ sub os_vendor_version($)
|
||||
$rval = `cat /etc/redhat-release`;
|
||||
$rval =~ m/(\d+).(\d+)/;
|
||||
$rval="ES".$1.$2;
|
||||
+ } elsif (!system("grep -qi msvsphere /etc/redhat-release")) {
|
||||
+ # Find a number of the form "#.#" and output the portion
|
||||
+ # to the left of the decimal point.
|
||||
+ $rval = `cat /etc/redhat-release`;
|
||||
+ $rval =~ m/(\d+).(\d+)/;
|
||||
+ $rval="ES".$1.$2;
|
||||
} elsif (!system("grep -qi circle /etc/redhat-release")) {
|
||||
# Find a number of the form "#.#" and output the portion
|
||||
# to the left of the decimal point.
|
||||
@@ -324,6 +330,8 @@ sub determine_os_version()
|
||||
$CUR_DISTRO_VENDOR = "redhat";
|
||||
} elsif ( -s "/etc/almalinux-release" ) {
|
||||
$CUR_DISTRO_VENDOR = "redhat";
|
||||
+ } elsif ( -s "/etc/sphere-release" ) {
|
||||
+ $CUR_DISTRO_VENDOR = "redhat";
|
||||
} elsif ( -s "/etc/circle-releas" ) {
|
||||
$CUR_DISTRO_VENDOR = "redhat";
|
||||
} elsif ( -s "/etc/UnitedLinux-release" ) {
|
||||
@@ -345,6 +353,7 @@ sub determine_os_version()
|
||||
"centos" => "redhat",
|
||||
"rocky" => "redhat",
|
||||
"almalinux" => "redhat",
|
||||
+ "msvsphere" => "redhat",
|
||||
"circle" => "redhat",
|
||||
"sles" => "SuSE",
|
||||
"sle_hpc" => "SuSE",
|
||||
@@ -355,6 +364,7 @@ sub determine_os_version()
|
||||
"centos" => $NETWORK_CONF_DIR,
|
||||
"rocky" => $NETWORK_CONF_DIR,
|
||||
"almalinux" => $NETWORK_CONF_DIR,
|
||||
+ "msvsphere" => $NETWORK_CONF_DIR,
|
||||
"circle" => $NETWORK_CONF_DIR,
|
||||
"sles" => "/etc/sysconfig/network",
|
||||
"sle_hpc" => "/etc/sysconfig/network",
|
||||
@@ -390,6 +400,8 @@ sub determine_os_version()
|
||||
$CUR_DISTRO_VENDOR = "redhat";
|
||||
} elsif ($CUR_DISTRO_VENDOR eq "almalinux") {
|
||||
$CUR_DISTRO_VENDOR = "redhat";
|
||||
+ } elsif ($CUR_DISTRO_VENDOR eq "msvsphere") {
|
||||
+ $CUR_DISTRO_VENDOR = "redhat";
|
||||
} elsif ($CUR_DISTRO_VENDOR eq "circle") {
|
||||
$CUR_DISTRO_VENDOR = "redhat";
|
||||
}
|
||||
@@ -246,6 +246,7 @@ sub determine_os_version()
|
||||
"centos" => "redhat",
|
||||
"rocky" => "redhat",
|
||||
"almalinux" => "redhat",
|
||||
+ "msvsphere" => "redhat",
|
||||
"circle" => "redhat",
|
||||
"oracle" => "redhat",
|
||||
"opencloudos" => "opencloudos",
|
||||
@@ -258,6 +259,7 @@ sub determine_os_version()
|
||||
"centos" => $NETWORK_CONF_DIR,
|
||||
"rocky" => $NETWORK_CONF_DIR,
|
||||
"almalinux" => $NETWORK_CONF_DIR,
|
||||
+ "msvsphere" => $NETWORK_CONF_DIR,
|
||||
"circle" => $NETWORK_CONF_DIR,
|
||||
"oracle" => $NETWORK_CONF_DIR,
|
||||
"opencloudos" => $NETWORK_CONF_DIR,
|
||||
diff --git a/MakeTools/funcs-ext.sh b/MakeTools/funcs-ext.sh
|
||||
index a5ee8ab..26def32 100755
|
||||
index c97531e..b51ceea 100755
|
||||
--- a/MakeTools/funcs-ext.sh
|
||||
+++ b/MakeTools/funcs-ext.sh
|
||||
@@ -731,6 +731,9 @@ function os_vendor()
|
||||
almalinux)
|
||||
rval=redhat
|
||||
;;
|
||||
+ msvsphere)
|
||||
+ rval=redhat
|
||||
+ ;;
|
||||
circle)
|
||||
rval=redhat
|
||||
;;
|
||||
@@ -772,6 +775,9 @@ function os_vendor()
|
||||
then
|
||||
rval=redhat
|
||||
elif [ $rval = 'almalinux' ]
|
||||
+ then
|
||||
+ rval=redhat
|
||||
+ elif [ $rval = 'msvsphere' ]
|
||||
then
|
||||
rval=redhat
|
||||
elif [ $rval = 'circle' ]
|
||||
@@ -859,6 +865,10 @@ function os_vendor_version()
|
||||
then
|
||||
# AlmaLinux
|
||||
rval="ES"`cat /etc/redhat-release | sed -r 's/^.+([[:digit:]])\.([[:digit:]]).+$/\1\2/'`
|
||||
+ elif grep -qi msvsphere /etc/redhat-release
|
||||
+ then
|
||||
+ # MSVSphere
|
||||
+ rval="ES"`cat /etc/redhat-release | sed -r 's/^.+([[:digit:]])\.([[:digit:]]).+$/\1\2/'`
|
||||
elif grep -qi circle /etc/redhat-release
|
||||
then
|
||||
# Circle Linux
|
||||
diff --git a/OpenIb_Host/update_mpi_spec.sh b/OpenIb_Host/update_mpi_spec.sh
|
||||
index abf1f2d..a057439 100755
|
||||
--- a/OpenIb_Host/update_mpi_spec.sh
|
||||
+++ b/OpenIb_Host/update_mpi_spec.sh
|
||||
@@ -33,7 +33,7 @@
|
||||
id=$(./get_id_and_versionid.sh | cut -f1 -d' ')
|
||||
versionid=$(./get_id_and_versionid.sh | cut -f2 -d' ')
|
||||
|
||||
-if [ "$id" = "rhel" -o "$id" = "centos" -o "$id" = "rocky" -o "$id" = "almalinux" -o "$id" = "circle" ]
|
||||
+if [ "$id" = "rhel" -o "$id" = "centos" -o "$id" = "rocky" -o "$id" = "almalinux" -o "$id" = "msvsphere" -o "$id" = "circle" ]
|
||||
then
|
||||
@@ -738,6 +738,7 @@ function os_vendor()
|
||||
[fedora]="redhat"
|
||||
[rocky]="redhat"
|
||||
[almalinux]="redhat"
|
||||
+ [msvsphere]="redhat"
|
||||
[circle]="redhat"
|
||||
[ol]="redhat"
|
||||
[opencloudos]="opencloudos"
|
||||
diff --git a/OpenIb_Host/build_packages.sh b/OpenIb_Host/build_packages.sh
|
||||
index b8cd62c..7a11acd 100755
|
||||
--- a/OpenIb_Host/build_packages.sh
|
||||
+++ b/OpenIb_Host/build_packages.sh
|
||||
@@ -42,7 +42,7 @@ echo "Packages version [$pkgversion] release [$pkgrelease], args [$BUILD_ARGS]"
|
||||
build_deb="no"
|
||||
spec_mpi="UNDEFINED"
|
||||
spec_ff="UNDEFINED"
|
||||
-if [ "$id" = "rhel" -o "$id" = "centos" -o "$id" = "rocky" -o "$id" = "almalinux" -o "$id" = "circle" -o "$id" = "ol" ]; then
|
||||
+if [ "$id" = "rhel" -o "$id" = "centos" -o "$id" = "rocky" -o "$id" = "almalinux" -o "$id" = "msvsphere" -o "$id" = "circle" -o "$id" = "ol" ]; then
|
||||
GE_8_0=$(echo "$versionid >= 8.0" | bc)
|
||||
sed -i "s/__RPM_REQ/Requires: openblas-devel/" mpi-apps.spec
|
||||
diff --git a/get_id_and_versionid.sh b/get_id_and_versionid.sh
|
||||
index deaeb43..d89ac76 100755
|
||||
--- a/get_id_and_versionid.sh
|
||||
+++ b/get_id_and_versionid.sh
|
||||
@@ -33,6 +33,9 @@ else
|
||||
then
|
||||
rval=redhat
|
||||
elif [ $rval = 'almalinux' ]
|
||||
+ then
|
||||
+ rval=redhat
|
||||
+ elif [ $rval = 'msvsphere' ]
|
||||
then
|
||||
rval=redhat
|
||||
elif [ $rval = 'circle' ]
|
||||
@@ -84,6 +87,10 @@ else
|
||||
then
|
||||
# AlmaLinux
|
||||
rval=`cat /etc/redhat-release | sed -r 's/^.+([[:digit:]])\.([[:digit:]]).+$/\1.\2/'`
|
||||
+ elif grep -qi msvsphere /etc/redhat-release
|
||||
+ then
|
||||
+ # MSVSphere
|
||||
+ rval=`cat /etc/redhat-release | sed -r 's/^.+([[:digit:]])\.([[:digit:]]).+$/\1.\2/'`
|
||||
elif grep -qi circle /etc/redhat-release
|
||||
then
|
||||
# Circle Linux
|
||||
diff --git a/update_eth_spec.sh b/update_eth_spec.sh
|
||||
index 83a44ad..3f47460 100755
|
||||
--- a/update_eth_spec.sh
|
||||
+++ b/update_eth_spec.sh
|
||||
@@ -51,7 +51,7 @@ fi
|
||||
|
||||
source ./OpenIb_Host/ff_filegroups.sh
|
||||
if [ $GE_8_0 = 1 ]; then
|
||||
spec_mpi="mpi-apps.spec.rh8+"
|
||||
diff --git a/OpenIb_Host/get_id_and_versionid.sh b/OpenIb_Host/get_id_and_versionid.sh
|
||||
index 36f5500..41b4ee9 100755
|
||||
--- a/OpenIb_Host/get_id_and_versionid.sh
|
||||
+++ b/OpenIb_Host/get_id_and_versionid.sh
|
||||
@@ -13,6 +13,7 @@ declare -A vendor_map=(
|
||||
[centos]="rhel"
|
||||
[rocky]="rhel"
|
||||
[almalinux]="rhel"
|
||||
+ [msvsphere]="rhel"
|
||||
[circle]="rhel"
|
||||
[ol]="ol"
|
||||
[opencloudos]="ocs"
|
||||
diff --git a/build_package.sh b/build_package.sh
|
||||
index 58beffe..4bd6c18 100755
|
||||
--- a/build_package.sh
|
||||
+++ b/build_package.sh
|
||||
@@ -3,7 +3,7 @@
|
||||
read id versionid <<< $(OpenIb_Host/get_id_and_versionid.sh)
|
||||
|
||||
-if [ "$id" = "rhel" -o "$id" = "centos" -o "$id" = "rocky" -o "$id" = "almalinux" -o "$id" = "circle" ]
|
||||
+if [ "$id" = "rhel" -o "$id" = "centos" -o "$id" = "rocky" -o "$id" = "almalinux" -o "$id" = "msvsphere" -o "$id" = "circle" ]
|
||||
then
|
||||
# __RPM_REQ_BASIC -
|
||||
sed -i "s/__RPM_REQ_BASIC1/expect%{?_isa}, tcl%{?_isa}, libibverbs-utils%{?_isa}, librdmacm-utils%{?_isa}, net-snmp%{?_isa}, net-snmp-utils%{?_isa}/g" eth-tools.spec
|
||||
case $id in
|
||||
- rhel|centos|rocky|almalinux|circle|ol)
|
||||
+ rhel|centos|rocky|almalinux|msvsphere|circle|ol)
|
||||
spec_ff="OpenIb_Host/eth-tools.spec.rh" ;;
|
||||
fedora)
|
||||
spec_ff="OpenIb_Host/eth-tools.spec.fedora" ;;
|
||||
--
|
||||
2.39.2
|
||||
2.43.0
|
||||
|
||||
|
Loading…
Reference in new issue