|
|
|
@ -1,17 +1,30 @@
|
|
|
|
|
From 0db724a7da5dca0507eddd75124d2374c2b5244b Mon Sep 17 00:00:00 2001
|
|
|
|
|
From: Sergey Cherevko <s.cherevko@msvsphere.ru>
|
|
|
|
|
Date: Wed, 17 May 2023 12:56:28 +0300
|
|
|
|
|
Subject: [PATCH] eth fast fabric 11 msvsphere_support
|
|
|
|
|
|
|
|
|
|
---
|
|
|
|
|
CommonInstall/util_init.pl | 14 +++++++++++++-
|
|
|
|
|
MakeTools/funcs-ext.sh | 10 ++++++++++
|
|
|
|
|
OpenIb_Host/update_mpi_spec.sh | 2 +-
|
|
|
|
|
get_id_and_versionid.sh | 7 +++++++
|
|
|
|
|
update_eth_spec.sh | 2 +-
|
|
|
|
|
5 files changed, 32 insertions(+), 3 deletions(-)
|
|
|
|
|
|
|
|
|
|
diff --git a/CommonInstall/util_init.pl b/CommonInstall/util_init.pl
|
|
|
|
|
index 650bc7f..25c505b 100755
|
|
|
|
|
index 07220bd..8e85334 100755
|
|
|
|
|
--- a/CommonInstall/util_init.pl
|
|
|
|
|
+++ b/CommonInstall/util_init.pl
|
|
|
|
|
@@ -211,7 +211,7 @@ sub os_vendor_version($)
|
|
|
|
|
chop($rval);
|
|
|
|
|
$rval="ES".$rval;
|
|
|
|
|
if ( -e "/etc/redhat-release" ) {
|
|
|
|
|
- if (!system("grep -qi centos /etc/redhat-release") || !system("grep -qi rocky /etc/redhat-release") || !system("grep -qi almalinux /etc/redhat-release") || !system("grep -qi circle /etc/redhat-release")) {
|
|
|
|
|
+ if (!system("grep -qi centos /etc/redhat-release") || !system("grep -qi rocky /etc/redhat-release") || !system("grep -qi almalinux /etc/redhat-release") || !system("grep -qi circle /etc/redhat-release") || !system("grep -qi msvsphere /etc/redhat-release")) {
|
|
|
|
|
$rval = `cat /etc/redhat-release | cut -d' ' -f4`;
|
|
|
|
|
$rval =~ m/(\d+).(\d+)/;
|
|
|
|
|
if ($2 eq "0") {
|
|
|
|
|
@@ -258,6 +258,12 @@ sub os_vendor_version($)
|
|
|
|
|
@@ -213,7 +213,7 @@ sub os_vendor_version($)
|
|
|
|
|
chop($rval);
|
|
|
|
|
$rval="ES".$rval;
|
|
|
|
|
if ( -e "/etc/redhat-release" ) {
|
|
|
|
|
- if (!system("grep -qi centos /etc/redhat-release") || !system("grep -qi rocky /etc/redhat-release") || !system("grep -qi almalinux /etc/redhat-release") || !system("grep -qi circle /etc/redhat-release")) {
|
|
|
|
|
+ if (!system("grep -qi centos /etc/redhat-release") || !system("grep -qi rocky /etc/redhat-release") || !system("grep -qi almalinux /etc/redhat-release") || !system("grep -qi circle /etc/redhat-release")) || !system("grep -qi msvsphere /etc/redhat-release")) {
|
|
|
|
|
$rval = `cat /etc/redhat-release | cut -d' ' -f4`;
|
|
|
|
|
$rval =~ m/(\d+).(\d+)/;
|
|
|
|
|
if ($2 eq "0") {
|
|
|
|
|
@@ -261,6 +261,12 @@ sub os_vendor_version($)
|
|
|
|
|
$rval = `cat /etc/redhat-release`;
|
|
|
|
|
$rval =~ m/(\d+).(\d+)/;
|
|
|
|
|
$rval="ES".$1.$2;
|
|
|
|
@ -24,7 +37,7 @@ index 650bc7f..25c505b 100755
|
|
|
|
|
} elsif (!system("grep -qi circle /etc/redhat-release")) {
|
|
|
|
|
# Find a number of the form "#.#" and output the portion
|
|
|
|
|
# to the left of the decimal point.
|
|
|
|
|
@@ -321,6 +327,8 @@ sub determine_os_version()
|
|
|
|
|
@@ -324,6 +330,8 @@ sub determine_os_version()
|
|
|
|
|
$CUR_DISTRO_VENDOR = "redhat";
|
|
|
|
|
} elsif ( -s "/etc/almalinux-release" ) {
|
|
|
|
|
$CUR_DISTRO_VENDOR = "redhat";
|
|
|
|
@ -33,23 +46,23 @@ index 650bc7f..25c505b 100755
|
|
|
|
|
} elsif ( -s "/etc/circle-releas" ) {
|
|
|
|
|
$CUR_DISTRO_VENDOR = "redhat";
|
|
|
|
|
} elsif ( -s "/etc/UnitedLinux-release" ) {
|
|
|
|
|
@@ -342,6 +350,7 @@ sub determine_os_version()
|
|
|
|
|
@@ -345,6 +353,7 @@ sub determine_os_version()
|
|
|
|
|
"centos" => "redhat",
|
|
|
|
|
"rocky" => "redhat",
|
|
|
|
|
"almalinux" => "redhat",
|
|
|
|
|
+ "msvsphere" => "redhat",
|
|
|
|
|
"circle" => "redhat",
|
|
|
|
|
"sles" => "SuSE",
|
|
|
|
|
"sle_hpc" => "SuSE"
|
|
|
|
|
@@ -351,6 +360,7 @@ sub determine_os_version()
|
|
|
|
|
"sle_hpc" => "SuSE",
|
|
|
|
|
@@ -355,6 +364,7 @@ sub determine_os_version()
|
|
|
|
|
"centos" => $NETWORK_CONF_DIR,
|
|
|
|
|
"rocky" => $NETWORK_CONF_DIR,
|
|
|
|
|
"almalinux" => $NETWORK_CONF_DIR,
|
|
|
|
|
+ "msvsphere" => $NETWORK_CONF_DIR,
|
|
|
|
|
"circle" => $NETWORK_CONF_DIR,
|
|
|
|
|
"sles" => "/etc/sysconfig/network",
|
|
|
|
|
"sle_hpc" => "/etc/sysconfig/network"
|
|
|
|
|
@@ -385,6 +395,8 @@ sub determine_os_version()
|
|
|
|
|
"sle_hpc" => "/etc/sysconfig/network",
|
|
|
|
|
@@ -390,6 +400,8 @@ sub determine_os_version()
|
|
|
|
|
$CUR_DISTRO_VENDOR = "redhat";
|
|
|
|
|
} elsif ($CUR_DISTRO_VENDOR eq "almalinux") {
|
|
|
|
|
$CUR_DISTRO_VENDOR = "redhat";
|
|
|
|
@ -59,7 +72,7 @@ index 650bc7f..25c505b 100755
|
|
|
|
|
$CUR_DISTRO_VENDOR = "redhat";
|
|
|
|
|
}
|
|
|
|
|
diff --git a/MakeTools/funcs-ext.sh b/MakeTools/funcs-ext.sh
|
|
|
|
|
index 8457db0..36a37cc 100755
|
|
|
|
|
index a5ee8ab..26def32 100755
|
|
|
|
|
--- a/MakeTools/funcs-ext.sh
|
|
|
|
|
+++ b/MakeTools/funcs-ext.sh
|
|
|
|
|
@@ -731,6 +731,9 @@ function os_vendor()
|
|
|
|
@ -72,7 +85,7 @@ index 8457db0..36a37cc 100755
|
|
|
|
|
circle)
|
|
|
|
|
rval=redhat
|
|
|
|
|
;;
|
|
|
|
|
@@ -769,6 +772,9 @@ function os_vendor()
|
|
|
|
|
@@ -772,6 +775,9 @@ function os_vendor()
|
|
|
|
|
then
|
|
|
|
|
rval=redhat
|
|
|
|
|
elif [ $rval = 'almalinux' ]
|
|
|
|
@ -82,7 +95,7 @@ index 8457db0..36a37cc 100755
|
|
|
|
|
then
|
|
|
|
|
rval=redhat
|
|
|
|
|
elif [ $rval = 'circle' ]
|
|
|
|
|
@@ -856,6 +862,10 @@ function os_vendor_version()
|
|
|
|
|
@@ -859,6 +865,10 @@ function os_vendor_version()
|
|
|
|
|
then
|
|
|
|
|
# AlmaLinux
|
|
|
|
|
rval="ES"`cat /etc/redhat-release | sed -r 's/^.+([[:digit:]])\.([[:digit:]]).+$/\1\2/'`
|
|
|
|
@ -94,7 +107,7 @@ index 8457db0..36a37cc 100755
|
|
|
|
|
then
|
|
|
|
|
# Circle Linux
|
|
|
|
|
diff --git a/OpenIb_Host/update_mpi_spec.sh b/OpenIb_Host/update_mpi_spec.sh
|
|
|
|
|
index a3bf2ba..8fedffb 100755
|
|
|
|
|
index abf1f2d..a057439 100755
|
|
|
|
|
--- a/OpenIb_Host/update_mpi_spec.sh
|
|
|
|
|
+++ b/OpenIb_Host/update_mpi_spec.sh
|
|
|
|
|
@@ -33,7 +33,7 @@
|
|
|
|
@ -132,10 +145,10 @@ index deaeb43..d89ac76 100755
|
|
|
|
|
then
|
|
|
|
|
# Circle Linux
|
|
|
|
|
diff --git a/update_eth_spec.sh b/update_eth_spec.sh
|
|
|
|
|
index 9551461..196daeb 100755
|
|
|
|
|
index 83a44ad..3f47460 100755
|
|
|
|
|
--- a/update_eth_spec.sh
|
|
|
|
|
+++ b/update_eth_spec.sh
|
|
|
|
|
@@ -48,7 +48,7 @@ fi
|
|
|
|
|
@@ -51,7 +51,7 @@ fi
|
|
|
|
|
|
|
|
|
|
source ./OpenIb_Host/ff_filegroups.sh
|
|
|
|
|
|
|
|
|
@ -144,3 +157,6 @@ index 9551461..196daeb 100755
|
|
|
|
|
then
|
|
|
|
|
# __RPM_REQ_BASIC -
|
|
|
|
|
sed -i "s/__RPM_REQ_BASIC1/expect%{?_isa}, tcl%{?_isa}, libibverbs-utils%{?_isa}, librdmacm-utils%{?_isa}, net-snmp%{?_isa}, net-snmp-utils%{?_isa}/g" eth-tools.spec
|
|
|
|
|
--
|
|
|
|
|
2.39.2
|
|
|
|
|
|