parent
c4d2825430
commit
331c9c3654
@ -0,0 +1,146 @@
|
||||
diff --git a/CommonInstall/util_init.pl b/CommonInstall/util_init.pl
|
||||
index 650bc7f..25c505b 100755
|
||||
--- a/CommonInstall/util_init.pl
|
||||
+++ b/CommonInstall/util_init.pl
|
||||
@@ -211,7 +211,7 @@ sub os_vendor_version($)
|
||||
chop($rval);
|
||||
$rval="ES".$rval;
|
||||
if ( -e "/etc/redhat-release" ) {
|
||||
- if (!system("grep -qi centos /etc/redhat-release") || !system("grep -qi rocky /etc/redhat-release") || !system("grep -qi almalinux /etc/redhat-release") || !system("grep -qi circle /etc/redhat-release")) {
|
||||
+ if (!system("grep -qi centos /etc/redhat-release") || !system("grep -qi rocky /etc/redhat-release") || !system("grep -qi almalinux /etc/redhat-release") || !system("grep -qi circle /etc/redhat-release") || !system("grep -qi msvsphere /etc/redhat-release")) {
|
||||
$rval = `cat /etc/redhat-release | cut -d' ' -f4`;
|
||||
$rval =~ m/(\d+).(\d+)/;
|
||||
if ($2 eq "0") {
|
||||
@@ -258,6 +258,12 @@ sub os_vendor_version($)
|
||||
$rval = `cat /etc/redhat-release`;
|
||||
$rval =~ m/(\d+).(\d+)/;
|
||||
$rval="ES".$1.$2;
|
||||
+ } elsif (!system("grep -qi msvsphere /etc/redhat-release")) {
|
||||
+ # Find a number of the form "#.#" and output the portion
|
||||
+ # to the left of the decimal point.
|
||||
+ $rval = `cat /etc/redhat-release`;
|
||||
+ $rval =~ m/(\d+).(\d+)/;
|
||||
+ $rval="ES".$1.$2;
|
||||
} elsif (!system("grep -qi circle /etc/redhat-release")) {
|
||||
# Find a number of the form "#.#" and output the portion
|
||||
# to the left of the decimal point.
|
||||
@@ -321,6 +327,8 @@ sub determine_os_version()
|
||||
$CUR_DISTRO_VENDOR = "redhat";
|
||||
} elsif ( -s "/etc/almalinux-release" ) {
|
||||
$CUR_DISTRO_VENDOR = "redhat";
|
||||
+ } elsif ( -s "/etc/sphere-release" ) {
|
||||
+ $CUR_DISTRO_VENDOR = "redhat";
|
||||
} elsif ( -s "/etc/circle-releas" ) {
|
||||
$CUR_DISTRO_VENDOR = "redhat";
|
||||
} elsif ( -s "/etc/UnitedLinux-release" ) {
|
||||
@@ -342,6 +350,7 @@ sub determine_os_version()
|
||||
"centos" => "redhat",
|
||||
"rocky" => "redhat",
|
||||
"almalinux" => "redhat",
|
||||
+ "msvsphere" => "redhat",
|
||||
"circle" => "redhat",
|
||||
"sles" => "SuSE",
|
||||
"sle_hpc" => "SuSE"
|
||||
@@ -351,6 +360,7 @@ sub determine_os_version()
|
||||
"centos" => $NETWORK_CONF_DIR,
|
||||
"rocky" => $NETWORK_CONF_DIR,
|
||||
"almalinux" => $NETWORK_CONF_DIR,
|
||||
+ "msvsphere" => $NETWORK_CONF_DIR,
|
||||
"circle" => $NETWORK_CONF_DIR,
|
||||
"sles" => "/etc/sysconfig/network",
|
||||
"sle_hpc" => "/etc/sysconfig/network"
|
||||
@@ -385,6 +395,8 @@ sub determine_os_version()
|
||||
$CUR_DISTRO_VENDOR = "redhat";
|
||||
} elsif ($CUR_DISTRO_VENDOR eq "almalinux") {
|
||||
$CUR_DISTRO_VENDOR = "redhat";
|
||||
+ } elsif ($CUR_DISTRO_VENDOR eq "msvsphere") {
|
||||
+ $CUR_DISTRO_VENDOR = "redhat";
|
||||
} elsif ($CUR_DISTRO_VENDOR eq "circle") {
|
||||
$CUR_DISTRO_VENDOR = "redhat";
|
||||
}
|
||||
diff --git a/MakeTools/funcs-ext.sh b/MakeTools/funcs-ext.sh
|
||||
index 8457db0..36a37cc 100755
|
||||
--- a/MakeTools/funcs-ext.sh
|
||||
+++ b/MakeTools/funcs-ext.sh
|
||||
@@ -731,6 +731,9 @@ function os_vendor()
|
||||
almalinux)
|
||||
rval=redhat
|
||||
;;
|
||||
+ msvsphere)
|
||||
+ rval=redhat
|
||||
+ ;;
|
||||
circle)
|
||||
rval=redhat
|
||||
;;
|
||||
@@ -769,6 +772,9 @@ function os_vendor()
|
||||
then
|
||||
rval=redhat
|
||||
elif [ $rval = 'almalinux' ]
|
||||
+ then
|
||||
+ rval=redhat
|
||||
+ elif [ $rval = 'msvsphere' ]
|
||||
then
|
||||
rval=redhat
|
||||
elif [ $rval = 'circle' ]
|
||||
@@ -856,6 +862,10 @@ function os_vendor_version()
|
||||
then
|
||||
# AlmaLinux
|
||||
rval="ES"`cat /etc/redhat-release | sed -r 's/^.+([[:digit:]])\.([[:digit:]]).+$/\1\2/'`
|
||||
+ elif grep -qi msvsphere /etc/redhat-release
|
||||
+ then
|
||||
+ # MSVSphere
|
||||
+ rval="ES"`cat /etc/redhat-release | sed -r 's/^.+([[:digit:]])\.([[:digit:]]).+$/\1\2/'`
|
||||
elif grep -qi circle /etc/redhat-release
|
||||
then
|
||||
# Circle Linux
|
||||
diff --git a/OpenIb_Host/update_mpi_spec.sh b/OpenIb_Host/update_mpi_spec.sh
|
||||
index a3bf2ba..8fedffb 100755
|
||||
--- a/OpenIb_Host/update_mpi_spec.sh
|
||||
+++ b/OpenIb_Host/update_mpi_spec.sh
|
||||
@@ -33,7 +33,7 @@
|
||||
id=$(./get_id_and_versionid.sh | cut -f1 -d' ')
|
||||
versionid=$(./get_id_and_versionid.sh | cut -f2 -d' ')
|
||||
|
||||
-if [ "$id" = "rhel" -o "$id" = "centos" -o "$id" = "rocky" -o "$id" = "almalinux" -o "$id" = "circle" ]
|
||||
+if [ "$id" = "rhel" -o "$id" = "centos" -o "$id" = "rocky" -o "$id" = "almalinux" -o "$id" = "msvsphere" -o "$id" = "circle" ]
|
||||
then
|
||||
GE_8_0=$(echo "$versionid >= 8.0" | bc)
|
||||
sed -i "s/__RPM_REQ/Requires: openblas-devel/" mpi-apps.spec
|
||||
diff --git a/get_id_and_versionid.sh b/get_id_and_versionid.sh
|
||||
index deaeb43..d89ac76 100755
|
||||
--- a/get_id_and_versionid.sh
|
||||
+++ b/get_id_and_versionid.sh
|
||||
@@ -33,6 +33,9 @@ else
|
||||
then
|
||||
rval=redhat
|
||||
elif [ $rval = 'almalinux' ]
|
||||
+ then
|
||||
+ rval=redhat
|
||||
+ elif [ $rval = 'msvsphere' ]
|
||||
then
|
||||
rval=redhat
|
||||
elif [ $rval = 'circle' ]
|
||||
@@ -84,6 +87,10 @@ else
|
||||
then
|
||||
# AlmaLinux
|
||||
rval=`cat /etc/redhat-release | sed -r 's/^.+([[:digit:]])\.([[:digit:]]).+$/\1.\2/'`
|
||||
+ elif grep -qi msvsphere /etc/redhat-release
|
||||
+ then
|
||||
+ # MSVSphere
|
||||
+ rval=`cat /etc/redhat-release | sed -r 's/^.+([[:digit:]])\.([[:digit:]]).+$/\1.\2/'`
|
||||
elif grep -qi circle /etc/redhat-release
|
||||
then
|
||||
# Circle Linux
|
||||
diff --git a/update_eth_spec.sh b/update_eth_spec.sh
|
||||
index 9551461..196daeb 100755
|
||||
--- a/update_eth_spec.sh
|
||||
+++ b/update_eth_spec.sh
|
||||
@@ -48,7 +48,7 @@ fi
|
||||
|
||||
source ./OpenIb_Host/ff_filegroups.sh
|
||||
|
||||
-if [ "$id" = "rhel" -o "$id" = "centos" -o "$id" = "rocky" -o "$id" = "almalinux" -o "$id" = "circle" ]
|
||||
+if [ "$id" = "rhel" -o "$id" = "centos" -o "$id" = "rocky" -o "$id" = "almalinux" -o "$id" = "msvsphere" -o "$id" = "circle" ]
|
||||
then
|
||||
# __RPM_REQ_BASIC -
|
||||
sed -i "s/__RPM_REQ_BASIC1/expect%{?_isa}, tcl%{?_isa}, libibverbs-utils%{?_isa}, librdmacm-utils%{?_isa}, net-snmp%{?_isa}, net-snmp-utils%{?_isa}/g" eth-tools.spec
|
Loading…
Reference in new issue