import dtc-1.7.0-12.el10

i10c changed/i10c/dtc-1.7.0-12.el10
Arkady L. Shane 2 months ago
parent 0eef95ecb0
commit 65c012827b
Signed by: tigro
GPG Key ID: 1EC08A25C9DB2503

@ -0,0 +1,63 @@
From 418bb0eb622691af31b1b638ce287fc85fac16b2 Mon Sep 17 00:00:00 2001
From: Miroslav Rezanina <mrezanin@redhat.com>
Date: Fri, 1 Nov 2024 07:44:36 -0400
Subject: [PATCH 1/2] pylibfdt/libfdt.i: Use SWIG_AppendOutput
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
RH-Author: Miroslav Rezanina <mrezanin@redhat.com>
RH-MergeRequest: 2: Fix build in RHEL 10
RH-Jira: RHEL-64318 RHEL-65448
RH-Commit: [1/2] 7874ef09ebd58c2591e42cebe821dc6b20719dc3 (mrezanin/centos-src-dtc)
Swig has changed language specific AppendOutput functions. The helper
macro SWIG_AppendOutput remains unchanged. Use that instead
of SWIG_Python_AppendOutput, which would require an extra parameter
since swig 4.3.0.
| /home/flk/poky/build-hypr/tmp/work/x86_64-linux/python3-dtc-native/1.7.0/git/pylibfdt/libfdt_wrap.c: In function _wrap_fdt_next_node:
| /home/flk/poky/build-hypr/tmp/work/x86_64-linux/python3-dtc-native/1.7.0/git/pylibfdt/libfdt_wrap.c:5598:17: error: too few arguments to function SWIG_Python_AppendOutput
| 5598 | resultobj = SWIG_Python_AppendOutput(resultobj, val);
Signed-off-by: Markus Volk <f_l_k@t-online.de>
Signed-off-by: David Gibson <david@gibson.dropbear.id.au>
Signed-off-by: Miroslav Rezanina <mrezanin@redhat.com>
---
pylibfdt/libfdt.i | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/pylibfdt/libfdt.i b/pylibfdt/libfdt.i
index 2361e22..e04053e 100644
--- a/pylibfdt/libfdt.i
+++ b/pylibfdt/libfdt.i
@@ -1080,7 +1080,7 @@ typedef uint32_t fdt32_t;
fdt_string(fdt1, fdt32_to_cpu($1->nameoff)));
buff = PyByteArray_FromStringAndSize(
(const char *)($1 + 1), fdt32_to_cpu($1->len));
- resultobj = SWIG_Python_AppendOutput(resultobj, buff);
+ resultobj = SWIG_AppendOutput(resultobj, buff);
}
}
@@ -1121,7 +1121,7 @@ typedef uint32_t fdt32_t;
%typemap(argout) int *depth {
PyObject *val = Py_BuildValue("i", *arg$argnum);
- resultobj = SWIG_Python_AppendOutput(resultobj, val);
+ resultobj = SWIG_AppendOutput(resultobj, val);
}
%apply int *depth { int *depth };
@@ -1137,7 +1137,7 @@ typedef uint32_t fdt32_t;
if (PyTuple_GET_SIZE(resultobj) == 0)
resultobj = val;
else
- resultobj = SWIG_Python_AppendOutput(resultobj, val);
+ resultobj = SWIG_AppendOutput(resultobj, val);
}
}
--
2.39.3

@ -8,7 +8,7 @@
Name: dtc
Version: 1.7.0
Release: 10%{?dist}
Release: 12%{?dist}
Summary: Device Tree Compiler
License: GPL-2.0-or-later
URL: https://devicetree.org/
@ -16,6 +16,8 @@ URL: https://devicetree.org/
Source0: https://www.kernel.org/pub/software/utils/%{name}/%{name}-%{version}.tar.xz
Patch1: 0001-pylibfdt-Makefile.pylibfdt-Use-CFLAGS-when-building-.patch
# For RHEL-64318 - [RHEL10][CS10] dtc fails to build with Swig 4.3.0
Patch2: dtc-pylibfdt-libfdt.i-Use-SWIG_AppendOutput.patch
BuildRequires: gcc make
BuildRequires: flex bison swig
@ -118,7 +120,7 @@ sed -i 's@--prefix=$(PREFIX)@--prefix=$(PREFIX) --root=/@' pylibfdt/Makefile.pyl
%build
export SETUPTOOLS_SCM_PRETEND_VERSION=%{version}
%{make_build} EXTRA_CFLAGS="%{build_cflags}" LDFLAGS="%{build_ldflags}"
%{make_build} EXTRA_CFLAGS="%{build_cflags} -Wno-redundant-decls -Wno-cast-qual -Wno-missing-prototypes" LDFLAGS="%{build_ldflags}"
%if %{with_mingw}
%mingw_meson -Dtools=false
@ -186,9 +188,21 @@ rm -f $RPM_BUILD_ROOT/%{_bindir}/ftdump
%endif
%changelog
* Tue Nov 26 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 1.7.0-10
* Tue Nov 26 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 1.7.0-12
- Rebuilt for MSVSphere 10
* Tue Nov 12 2024 Miroslav Rezanina <mrezanin@redhat.com> - 1.7.0-12
- dtc-pylibfdt-libfdt.i-Use-SWIG_AppendOutput.patch [RHEL-64318 RHEL-65448]
- dtc-Disable-problematic-waring-flags.patch [RHEL-64318 RHEL-65448]
- Resolves: RHEL-64318
([RHEL10][CS10] dtc fails to build with Swig 4.3.0)
- Resolves: RHEL-65448
([RHEL10][CS10][FTBFS] dtc fails to build on CS10 and RHEL10)
* Tue Oct 29 2024 Troy Dawson <tdawson@redhat.com> - 1.7.0-11
- Bump release for October 2024 mass rebuild:
Resolves: RHEL-64018
* Fri Jun 28 2024 Miroslav Rezanina <mrezanin@redhat.com> - 1.7.0-10
- Fix missing dynamic tags for aarch64 python3 pylibfdt
- Resolves: RHEL-33493

Loading…
Cancel
Save