Upgrade dpkg to 1.19.x, 1.19.7

Won't be possible build on el7
Remove hacks for tar <= 1.28 on el7 (patch 3)
Remove hacks buil on el6 (patch 2)
Remove hack for crapy /usr/lib/rpm/perl.req in EL7 (#1510214)
Disable our custom dpkg-req
epel9
Sérgio M. Basto 5 years ago
parent a5845d34be
commit 68f350a263

1
.gitignore vendored

@ -11,3 +11,4 @@ dpkg_1.15.5.6.tar.bz2
/dpkg_1.18.22.tar.xz
/dpkg_1.18.24.tar.xz
/dpkg_1.18.25.tar.xz
/dpkg_1.19.7.tar.xz

@ -1,29 +0,0 @@
clamp-mtime only available in tar 1.28 but we may distar it in epel7
man tar
--clamp-mtime
Only set time when the file is more recent than what was given with --mtime.
--- ./scripts/Dpkg/Source/Archive.pm.orig 2018-09-23 14:50:58.650262327 +0100
+++ ./scripts/Dpkg/Source/Archive.pm 2018-09-23 14:51:10.640395035 +0100
@@ -52,7 +52,7 @@ sub create {
# Call tar creation process
$spawn_opts{delete_env} = [ 'TAR_OPTIONS' ];
$spawn_opts{exec} = [ $Dpkg::PROGTAR, '-cf', '-', '--format=gnu', '--sort=name',
- '--mtime', "\@$mtime", '--clamp-mtime', '--null',
+ '--mtime', "\@$mtime", '--null',
'--numeric-owner', '--owner=0', '--group=0',
@{$opts{options}}, '-T', '-' ];
*$self->{pid} = spawn(%spawn_opts);
--- ./dpkg-deb/build.c.orig 2018-09-23 14:50:06.952690066 +0100
+++ ./dpkg-deb/build.c 2018-09-23 14:50:22.771865176 +0100
@@ -450,7 +450,7 @@ tarball_pack(const char *dir, filenames_
command_init(&cmd, TAR, "tar -cf");
command_add_args(&cmd, "tar", "-cf", "-", "--format=gnu",
- "--mtime", mtime, "--clamp-mtime", NULL);
+ "--mtime", mtime, NULL);
/* Mode might become a positional argument, pass it before -T. */
if (mode)
command_add_args(&cmd, "--mode", mode, NULL);

@ -1,16 +0,0 @@
diff -up ./debian/dpkg.logrotate.orig ./debian/dpkg.logrotate
--- ./debian/dpkg.logrotate.orig 2013-06-30 10:04:23.369382622 +0300
+++ ./debian/dpkg.logrotate 2013-06-30 10:04:39.268407865 +0300
@@ -7,12 +7,3 @@
notifempty
create 644 root root
}
-/var/log/alternatives.log {
- monthly
- rotate 12
- compress
- delaycompress
- missingok
- notifempty
- create 644 root root
-}

@ -1,20 +0,0 @@
--- ./scripts/Makefile.in.orig 2015-04-10 01:37:03.000000000 +0100
+++ ./scripts/Makefile.in 2015-07-02 04:16:51.404577510 +0100
@@ -415,7 +415,7 @@ bin_SCRIPTS = \
dpkg-source \
dpkg-vendor
-changelogdir = $(pkglibdir)/parsechangelog
+changelogdir = $(pkglibexecdir)/parsechangelog
changelog_SCRIPTS = \
changelog/debian
@@ -516,7 +516,7 @@ do_perl_subst = $(AM_V_GEN) \
sed -e "s:^\#![[:space:]]*/usr/bin/perl:\#!$(PERL):" \
-e "s:\$$CONFDIR[[:space:]]*=[[:space:]]*['\"][^'\"]*['\"]:\$$CONFDIR='$(pkgconfdir)':" \
-e "s:\$$ADMINDIR[[:space:]]*=[[:space:]]*['\"][^'\"]*['\"]:\$$ADMINDIR='$(admindir)':" \
- -e "s:\$$LIBDIR[[:space:]]*=[[:space:]]*['\"][^'\"]*['\"]:\$$LIBDIR='$(pkglibdir)':" \
+ -e "s:\$$LIBDIR[[:space:]]*=[[:space:]]*['\"][^'\"]*['\"]:\$$LIBDIR='$(pkglibexecdir)':" \
-e "s:\$$DATADIR[[:space:]]*=[[:space:]]*['\"][^'\"]*['\"]:\$$DATADIR='$(pkgdatadir)':" \
-e "s:\$$PROGVERSION[[:space:]]*=[[:space:]]*['\"][^'\"]*[\"']:\$$PROGVERSION='$(PACKAGE_VERSION)':"

@ -2,8 +2,8 @@
%global pkgdatadir %{_datadir}/dpkg
Name: dpkg
Version: 1.18.25
Release: 10%{?dist}
Version: 1.19.7
Release: 1%{?dist}
Summary: Package maintenance system for Debian Linux
# The entire source code is GPLv2+ with exception of the following
# lib/dpkg/md5.c, lib/dpkg/md5.h - Public domain
@ -14,9 +14,6 @@ Summary: Package maintenance system for Debian Linux
License: GPLv2 and GPLv2+ and LGPLv2+ and Public Domain and BSD
URL: https://tracker.debian.org/pkg/dpkg
Source0: http://ftp.debian.org/debian/pool/main/d/dpkg/%{name}_%{version}.tar.xz
Patch1: dpkg-fix-logrotate.patch
Patch2: dpkg-perl-libexecdir.epel6.patch
Patch3: dpkg-clamp-mtime.patch
BuildRequires: gcc-c++
BuildRequires: zlib-devel bzip2-devel libselinux-devel gettext ncurses-devel
@ -169,14 +166,6 @@ user interfaces.
%prep
%setup -q
%patch1 -p1
%if 0%{?rhel} && 0%{?rhel} < 7
%patch2 -p1
%endif
%if 0%{?rhel} && 0%{?rhel} < 8
%patch3 -p1
%endif
# Filter unwanted Requires:
cat << \EOF > %{name}-req
@ -185,13 +174,8 @@ cat << \EOF > %{name}-req
sed -e '/perl(Dselect::Ftp)/d' -e '/perl(extra)/d' -e '/perl(file)/d' -e '/perl(dpkg-gettext.pl)/d' -e '/perl(controllib.pl)/d' -e '/perl(in)/d'
EOF
%define __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
chmod +x %{__perl_requires}
# https://bugzilla.redhat.com/show_bug.cgi?id=1510214
# crapy /usr/lib/rpm/perl.req in EL7
# mark string "use --format" as requires perl(--format)
sed -i 's/^use --/may use --/' scripts/dpkg-source.pl
#define __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
#chmod +x %{__perl_requires}
%build
%if 0%{?fedora} || 0%{?rhel} > 6
@ -336,6 +320,8 @@ create_logfile
%{_mandir}/man1/dpkg-divert.1.gz
%{_mandir}/man1/dpkg-statoverride.1.gz
%{_mandir}/man8/start-stop-daemon.8.gz
%{_mandir}/man5/deb-src-rules.5.gz
%{_mandir}/man7/deb-version.7.gz
%{_mandir}/*/man1/dpkg.1.gz
%{_mandir}/*/man1/dpkg-deb.1.gz
%{_mandir}/*/man1/dpkg-maintscript-helper.1.gz
@ -346,6 +332,10 @@ create_logfile
%{_mandir}/*/man1/dpkg-divert.1.gz
%{_mandir}/*/man1/dpkg-statoverride.1.gz
%{_mandir}/*/man8/start-stop-daemon.8.gz
%{_mandir}/*/man5/deb-src-rules.5.gz
%{_mandir}/*/man7/deb-version.7.gz
%{_datadir}/polkit-1/actions/org.dpkg.pkexec.update-alternatives.policy
%files devel
%{_libdir}/libdpkg.a
@ -412,7 +402,7 @@ create_logfile
%{_mandir}/man5/deb-preinst.5.gz
%{_mandir}/man5/deb-prerm.5.gz
%{_mandir}/man5/deb-triggers.5.gz
%{_mandir}/man5/deb-version.5.gz
#{_mandir}/man5/deb-version.5.gz
%{_mandir}/man5/deb.5.gz
%{_mandir}/man5/deb822.5.gz
%{_mandir}/man5/dsc.5.gz
@ -453,7 +443,7 @@ create_logfile
%{_mandir}/*/man5/deb-preinst.5.gz
%{_mandir}/*/man5/deb-prerm.5.gz
%{_mandir}/*/man5/deb-triggers.5.gz
%{_mandir}/*/man5/deb-version.5.gz
#{_mandir}/*/man5/deb-version.5.gz
%{_mandir}/*/man5/deb.5.gz
%{_mandir}/*/man5/deb822.5.gz
%{_mandir}/*/man5/dsc.5.gz
@ -466,7 +456,7 @@ create_logfile
%files -n dselect -f dselect.lang
%doc dselect/methods/multicd/README.multicd
#doc dselect/methods/multicd/README.multicd
%config(noreplace) %{pkgconfdir}/dselect.cfg
%{_bindir}/dselect
%{perl_vendorlib}/Dselect
@ -480,6 +470,14 @@ create_logfile
%changelog
* Thu Nov 14 2019 Sérgio Basto <sergio@serjux.com> - 1.19.7-1
- Upgrade dpkg to 1.19.x 1.19.7
- Won't be possible build on el7
- Remove hacks for tar <= 1.28 on el7 (patch 3)
- Remove hacks buil on el6 (patch 2)
- Remove hack for crapy /usr/lib/rpm/perl.req in EL7 (#1510214)
- Disable our custom dpkg-req
* Wed Jul 24 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.18.25-10
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

@ -1 +1 @@
SHA512 (dpkg_1.18.25.tar.xz) = a26907c32ea02044d8729b70996b786204d3ce89ac294a8422b009688ab9bf886f593cb37430e84593dec2c26cfbc01a458d47fbda749decdf8acbfb72e07bb3
SHA512 (dpkg_1.19.7.tar.xz) = 9ca441dc265baf5359c71617aef1c57504a7097c26ea57108b88dadc511bfa9918fcc765d8c67cec9def9916c5df92d6cabe508446dbc7223a29b45260445e81

Loading…
Cancel
Save