Won't be possible build on el7 Remove hacks for tar <= 1.28 on el7 (patch 3) Remove hacks buil on el6 (patch 2) Remove hack for crapy /usr/lib/rpm/perl.req in EL7 (#1510214) Disable our custom dpkg-reqepel9
parent
a5845d34be
commit
68f350a263
@ -1,29 +0,0 @@
|
||||
clamp-mtime only available in tar 1.28 but we may distar it in epel7
|
||||
|
||||
|
||||
man tar
|
||||
--clamp-mtime
|
||||
Only set time when the file is more recent than what was given with --mtime.
|
||||
|
||||
--- ./scripts/Dpkg/Source/Archive.pm.orig 2018-09-23 14:50:58.650262327 +0100
|
||||
+++ ./scripts/Dpkg/Source/Archive.pm 2018-09-23 14:51:10.640395035 +0100
|
||||
@@ -52,7 +52,7 @@ sub create {
|
||||
# Call tar creation process
|
||||
$spawn_opts{delete_env} = [ 'TAR_OPTIONS' ];
|
||||
$spawn_opts{exec} = [ $Dpkg::PROGTAR, '-cf', '-', '--format=gnu', '--sort=name',
|
||||
- '--mtime', "\@$mtime", '--clamp-mtime', '--null',
|
||||
+ '--mtime', "\@$mtime", '--null',
|
||||
'--numeric-owner', '--owner=0', '--group=0',
|
||||
@{$opts{options}}, '-T', '-' ];
|
||||
*$self->{pid} = spawn(%spawn_opts);
|
||||
--- ./dpkg-deb/build.c.orig 2018-09-23 14:50:06.952690066 +0100
|
||||
+++ ./dpkg-deb/build.c 2018-09-23 14:50:22.771865176 +0100
|
||||
@@ -450,7 +450,7 @@ tarball_pack(const char *dir, filenames_
|
||||
|
||||
command_init(&cmd, TAR, "tar -cf");
|
||||
command_add_args(&cmd, "tar", "-cf", "-", "--format=gnu",
|
||||
- "--mtime", mtime, "--clamp-mtime", NULL);
|
||||
+ "--mtime", mtime, NULL);
|
||||
/* Mode might become a positional argument, pass it before -T. */
|
||||
if (mode)
|
||||
command_add_args(&cmd, "--mode", mode, NULL);
|
@ -1,16 +0,0 @@
|
||||
diff -up ./debian/dpkg.logrotate.orig ./debian/dpkg.logrotate
|
||||
--- ./debian/dpkg.logrotate.orig 2013-06-30 10:04:23.369382622 +0300
|
||||
+++ ./debian/dpkg.logrotate 2013-06-30 10:04:39.268407865 +0300
|
||||
@@ -7,12 +7,3 @@
|
||||
notifempty
|
||||
create 644 root root
|
||||
}
|
||||
-/var/log/alternatives.log {
|
||||
- monthly
|
||||
- rotate 12
|
||||
- compress
|
||||
- delaycompress
|
||||
- missingok
|
||||
- notifempty
|
||||
- create 644 root root
|
||||
-}
|
@ -1,20 +0,0 @@
|
||||
--- ./scripts/Makefile.in.orig 2015-04-10 01:37:03.000000000 +0100
|
||||
+++ ./scripts/Makefile.in 2015-07-02 04:16:51.404577510 +0100
|
||||
@@ -415,7 +415,7 @@ bin_SCRIPTS = \
|
||||
dpkg-source \
|
||||
dpkg-vendor
|
||||
|
||||
-changelogdir = $(pkglibdir)/parsechangelog
|
||||
+changelogdir = $(pkglibexecdir)/parsechangelog
|
||||
changelog_SCRIPTS = \
|
||||
changelog/debian
|
||||
|
||||
@@ -516,7 +516,7 @@ do_perl_subst = $(AM_V_GEN) \
|
||||
sed -e "s:^\#![[:space:]]*/usr/bin/perl:\#!$(PERL):" \
|
||||
-e "s:\$$CONFDIR[[:space:]]*=[[:space:]]*['\"][^'\"]*['\"]:\$$CONFDIR='$(pkgconfdir)':" \
|
||||
-e "s:\$$ADMINDIR[[:space:]]*=[[:space:]]*['\"][^'\"]*['\"]:\$$ADMINDIR='$(admindir)':" \
|
||||
- -e "s:\$$LIBDIR[[:space:]]*=[[:space:]]*['\"][^'\"]*['\"]:\$$LIBDIR='$(pkglibdir)':" \
|
||||
+ -e "s:\$$LIBDIR[[:space:]]*=[[:space:]]*['\"][^'\"]*['\"]:\$$LIBDIR='$(pkglibexecdir)':" \
|
||||
-e "s:\$$DATADIR[[:space:]]*=[[:space:]]*['\"][^'\"]*['\"]:\$$DATADIR='$(pkgdatadir)':" \
|
||||
-e "s:\$$PROGVERSION[[:space:]]*=[[:space:]]*['\"][^'\"]*[\"']:\$$PROGVERSION='$(PACKAGE_VERSION)':"
|
||||
|
@ -1 +1 @@
|
||||
SHA512 (dpkg_1.18.25.tar.xz) = a26907c32ea02044d8729b70996b786204d3ce89ac294a8422b009688ab9bf886f593cb37430e84593dec2c26cfbc01a458d47fbda749decdf8acbfb72e07bb3
|
||||
SHA512 (dpkg_1.19.7.tar.xz) = 9ca441dc265baf5359c71617aef1c57504a7097c26ea57108b88dadc511bfa9918fcc765d8c67cec9def9916c5df92d6cabe508446dbc7223a29b45260445e81
|
||||
|
Loading…
Reference in new issue