New upstream release 3.0.0

epel8
Milan Bouchet-Valat 7 years ago
parent 110249b4d3
commit 53d1072c7a
No known key found for this signature in database
GPG Key ID: F728B326BC2095CD

1
.gitignore vendored

@ -1,2 +1,3 @@
/double-conversion-2.0.0.tar.gz
/double-conversion-2.0.1.tar.gz
/double-conversion-3.0.0.tar.gz

@ -1,17 +0,0 @@
diff --git a/double-conversionConfig.cmake.in b/double-conversionConfig.cmake.in
index bbe784b..6c967f4 100644
--- a/double-conversionConfig.cmake.in
+++ b/double-conversionConfig.cmake.in
@@ -8,10 +8,9 @@ get_filename_component(double-conversion_CMAKE_DIR "${CMAKE_CURRENT_LIST_FILE}"
if(EXISTS "${double-conversion_CMAKE_DIR}/CMakeCache.txt")
include("${double-conversion_CMAKE_DIR}/double-conversionBuildTreeSettings.cmake")
else()
- set(double-conversion_INCLUDE_DIRS
- "${double-conversion_CMAKE_DIR}/@CONF_REL_INCLUDE_DIR@/include/double-conversion")
+ set(double-conversion_INCLUDE_DIRS "@INCLUDE_INSTALL_DIR@/double-conversion")
endif()
-include("${double-conversion_CMAKE_DIR}/double-conversionLibraryDepends.cmake")
+include("@LIB_INSTALL_DIR@/cmake/double-conversion/double-conversionLibraryDepends.cmake")
set(double-conversion_LIBRARIES double-conversion)

@ -1,106 +0,0 @@
commit c7734598e2ee084c17e1b8a41daa569fb021d593
Author: Florian Loitsch <florian@loitsch.com>
Date: Sat Mar 8 15:02:13 2014 +0100
Support shared libraries with Cmake. Improve README.
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5bf382e..7b09be0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,8 +2,12 @@ cmake_minimum_required(VERSION 2.8)
project(double-conversion)
# pick a version #
-set(double-conversion_VERSION
- 1.1.1)
+set(double-conversion_VERSION 2.0.1)
+set(double-conversion_SOVERSION_MAJOR 1)
+set(double-conversion_SOVERSION_MINOR 0)
+set(double-conversion_SOVERSION_PATCH 0)
+set(double-conversion_SOVERSION
+ ${double-conversion_SOVERSION_MAJOR}.${double-conversion_SOVERSION_MINOR}.${double-conversion_SOVERSION_PATCH})
# set paths for install -- empty initially
# Offer the user the choice of overriding the installation directories
diff --git a/Changelog b/Changelog
index 516f6d2..526756b 100644
--- a/Changelog
+++ b/Changelog
@@ -1,3 +1,8 @@
+2014-03-08:
+ Update version number for cmake.
+ Support shared libraries with cmake.
+ Add build instructions to the README.
+
2014-01-12:
Tagged v2.0.1.
Fix compilation for ARMv8 64bit (used wrong define).
diff --git a/README b/README
index f186b42..167f9c5 100644
--- a/README
+++ b/README
@@ -9,3 +9,46 @@ it can be used more easily in other projects.
There is extensive documentation in src/double-conversion.h. Other examples can
be found in test/cctest/test-conversions.cc.
+
+
+Building
+========
+
+This library can be built with scons [0] or cmake [1].
+The checked-in Makefile simply forwards to scons, and provides a
+shortcut to run all tests:
+
+ make
+ make test
+
+Scons
+-----
+
+The easiest way to install this library is to use `scons`. It builds
+the static and shared library, and is set up to install those at the
+correct locations:
+
+ scons install
+
+Use the `DESTDIR` option to change the target directory:
+
+ scons DESTDIR=alternative_directory install
+
+Cmake
+-----
+
+To use cmake run `cmake .` in the root directory. This overwrites the
+existing Makefile.
+
+Use `-DBUILD_SHARED_LIBS=ON` to enable the compilation of shared libraries.
+Note that this disables static libraries. There is currently no way to
+build both libraries at the same time with cmake.
+
+Use `-DBUILD_TESTING=ON` to build the test executable.
+
+ cmake . -DBUILD_TESTING=ON
+ make
+ test/cctest/cctest --list | tr -d '<' | xargs test/cctest/cctest
+
+[0]: http://www.scons.org
+[1]: http://www.cmake.org
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 7f5c985..0da50b1 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -29,6 +29,12 @@ ${headers}
set_target_properties(double-conversion
PROPERTIES PUBLIC_HEADER "${headers}")
+if (BUILD_SHARED_LIBS)
+ set_target_properties(double-conversion
+ PROPERTIES VERSION ${double-conversion_SOVERSION}
+ SOVERSION ${double-conversion_SOVERSION_MAJOR})
+endif()
+
#
# install command to set up library install
# given the above PUBLIC_HEADER property set, this

@ -2,17 +2,12 @@
Summary: Library providing binary-decimal and decimal-binary routines for IEEE doubles
Name: double-conversion
Version: 2.0.1
Release: 11%{?dist}
Version: 3.0.0
Release: 1%{?dist}
License: BSD
Group: Development/Libraries
Source0: https://github.com/floitsch/double-conversion/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
# Upstream patch to support SOVERSION
Patch0: double-conversion-soversion.patch
# Use install paths in installed cmake files
# https://github.com/floitsch/double-conversion/pull/9
Patch1: double-conversion-cmake.patch
URL: https://github.com/floitsch/double-conversion
Source0: https://github.com/google/double-conversion/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
URL: https://github.com/google/double-conversion
BuildRequires: cmake
%description
@ -43,12 +38,6 @@ Static %{name} library.
%prep
%setup -q
%patch0 -p1 -b .soversion
%patch1 -p1 -b .cmake
# Fix up install locations
# https://github.com/floitsch/double-conversion/issues/8
sed -i -e s,lib/CMake,%{_lib}/cmake, CMakeLists.txt
sed -i -e s,/lib,/%{_lib}, src/CMakeLists.txt
%build
mkdir -p build-shared
@ -85,7 +74,7 @@ popd
%postun -p /sbin/ldconfig
%files
%doc LICENSE README AUTHORS Changelog
%doc LICENSE README.md AUTHORS Changelog
%{_libdir}/libdouble-conversion.so.1*
%files devel
@ -99,6 +88,9 @@ popd
%endif
%changelog
* Mon Sep 4 2017 Milan Bouchet-Valat <nalimilan@club.fr> - 3.0.0-1
- New upstream release.
* Sun Aug 06 2017 Björn Esser <besser82@fedoraproject.org> - 2.0.1-11
- Rebuilt for AutoReq cmake-filesystem

@ -1 +1 @@
60c564ad17a19924bfec831ebd09edea double-conversion-2.0.1.tar.gz
SHA512 (double-conversion-3.0.0.tar.gz) = 5057af6e72f2aaace56ebdd9a0ddfa34318cbdfeabec5c361b60e6c92f160c8999c046c50f8c6f8d590eb8e97aa70bb6e97ba8148f0dc95dbc42f204fcdc1abf

Loading…
Cancel
Save