diff --git a/djvulibre-3.5.16-extraqualif.patch b/djvulibre-3.5.16-extraqualif.patch
new file mode 100644
index 0000000..521e7b6
--- /dev/null
+++ b/djvulibre-3.5.16-extraqualif.patch
@@ -0,0 +1,28 @@
+diff -Naupr djvulibre-3.5.16.orig/libdjvu/ByteStream.h djvulibre-3.5.16/libdjvu/ByteStream.h
+--- djvulibre-3.5.16.orig/libdjvu/ByteStream.h 2003-11-07 23:08:20.000000000 +0100
++++ djvulibre-3.5.16/libdjvu/ByteStream.h 2006-01-30 11:22:17.000000000 +0100
+@@ -242,7 +242,7 @@ public:
+ and writes it to the specified stream. */
+ void formatmessage( const char *fmt, ... );
+ /** Looks up the message and writes it to the specified stream. */
+- void ByteStream::writemessage( const char *message );
++ void writemessage( const char *message );
+ /** Writes a one-byte integer to a ByteStream. */
+ void write8 (unsigned int card8);
+ /** Writes a two-bytes integer to a ByteStream.
+diff -Naupr djvulibre-3.5.16.orig/libdjvu/GURL.h djvulibre-3.5.16/libdjvu/GURL.h
+--- djvulibre-3.5.16.orig/libdjvu/GURL.h 2003-11-07 23:08:21.000000000 +0100
++++ djvulibre-3.5.16/libdjvu/GURL.h 2006-01-30 11:18:17.000000000 +0100
+@@ -278,10 +278,10 @@ public:
+ //@}
+
+ /// Returns TRUE if #gurl1# and #gurl2# are the same
+- bool GURL::operator==(const GURL & gurl2) const;
++ bool operator==(const GURL & gurl2) const;
+
+ /// Returns TRUE if #gurl1# and #gurl2# are different
+- bool GURL::operator!=(const GURL & gurl2) const;
++ bool operator!=(const GURL & gurl2) const;
+
+ /// Assignment operator
+ GURL & operator=(const GURL & url);
diff --git a/djvulibre.spec b/djvulibre.spec
index c08d3f3..08b0516 100644
--- a/djvulibre.spec
+++ b/djvulibre.spec
@@ -1,15 +1,21 @@
Summary: DjVu viewers, encoders and utilities
Name: djvulibre
-Version: 3.5.15
-Release: 3%{?dist}
+Version: 3.5.16
+Release: 1%{?dist}
License: GPL
Group: Applications/Publishing
URL: http://djvulibre.djvuzone.org/
Source: http://dl.sf.net/djvu/djvulibre-%{version}.tar.gz
-Patch0: djvulibre-3.5.15-gcc401.patch
+Patch0: djvulibre-3.5.16-extraqualif.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
-BuildRequires: xorg-x11-devel, qt-devel, libjpeg-devel, libtiff-devel
+BuildRequires: qt-devel, libjpeg-devel, libtiff-devel
BuildRequires: mozilla, redhat-menus, hicolor-icon-theme
+# Use monolithic X up to FC4, and modular X for FC5+ and non-Fedora
+%if %{!?fedora:5}%{?fedora} >= 5
+BuildRequires: libXt-devel
+%else
+BuildRequires: xorg-x11-devel
+%endif
# Provide these here, they're so small, it's not worth splitting them out
Provides: mozilla-djvulibre = %{version}-%{release}
Provides: djvulibre-devel = %{version}-%{release}
@@ -32,7 +38,7 @@ compatible with version 3.5 of the LizardTech DjVu software suite.
%prep
%setup
-%patch0 -p1 -b .gcc401
+%patch0 -p1 -b .extraqualif
%build
@@ -96,9 +102,15 @@ update-desktop-database /usr/share/applications || :
%changelog
-* Mon Mar 6 2006 Matthias Saou 3.5.15-3
+* Mon Mar 6 2006 Matthias Saou 3.5.16-2
- FC5 rebuild.
+* Mon Jan 30 2006 Matthias Saou 3.5.16-1
+- Update to 3.5.16.
+- Add conditional to build with/without modular X depending on FC version.
+- Remove no longer needed gcc4 patch.
+- Add extra qualification patch.
+
* Thu Aug 4 2005 Matthias Saou 3.5.15-2
- Include djvulibre-3.5.15-gcc401.patch to fix compilation with gcc 4.0.1.
- Add hicolor-icon-theme build req for /usr/share/icons/hicolor/48x48/mimetypes