You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
debhelper/debhelper-find-perm.patch

32 lines
1.4 KiB

diff -up ./dh_suidregister.orig ./dh_suidregister
--- ./dh_suidregister.orig 2013-05-14 06:00:14.170057295 -0400
+++ ./dh_suidregister 2013-05-14 06:00:25.236037285 -0400
@@ -53,7 +53,7 @@ foreach my $package (@{$dh{DOPACKAGES}})
if (! @files && ! $suid) {
# No files specified (and no empty debian/suid file), so
# guess what files to process.
- @files=split(/\n/,`find $tmp -type f -perm +6000`);
+ @files=split(/\n/,`find $tmp -type f -perm /6000`);
# Strip the debian working directory off of the filenames.
$tostrip="$tmp/";
diff -up ./Makefile.orig ./Makefile
--- ./Makefile.orig 2013-05-14 05:59:05.747127850 -0400
+++ ./Makefile 2013-05-14 05:59:17.529103009 -0400
@@ -1,5 +1,5 @@
# List of files of dh_* commands. Sorted for debhelper man page.
-COMMANDS=$(shell find . -maxdepth 1 -type f -perm +100 -name "dh_*" -printf "%f\n" | sort)
+COMMANDS=$(shell find . -maxdepth 1 -type f -perm /100 -name "dh_*" -printf "%f\n" | sort)
# Find deprecated commands by looking at their synopsis.
DEPRECATED=$(shell egrep -l '^dh_.* - .*deprecated' $(COMMANDS))
@@ -44,7 +44,7 @@ POD2MAN=pod2man -c Debhelper -r "$(VERSI
LANGS=$(notdir $(basename $(wildcard man/po4a/po/*.po)))
build: version debhelper.7
- find . -maxdepth 1 -type f -perm +100 -name "dh*" \
+ find . -maxdepth 1 -type f -perm /100 -name "dh*" \
-exec $(POD2MAN) {} {}.1 \;
po4a --previous -L UTF-8 man/po4a/po4a.cfg
set -e; \