c8-stream-rhel8
imports/c8-stream-rhel8/criu-3.18-4.module+el8.9.0+19090+d2921118
parent
c7e5fe7737
commit
536aa1df7c
@ -1 +1 @@
|
|||||||
91eb1ccac61a7d538db14884091883c6dab5481a SOURCES/criu-3.15.tar.bz2
|
f359d9a3af080f5d3293c847af5ab10f58639d85 SOURCES/criu-3.18.tar.gz
|
||||||
|
@ -1 +1 @@
|
|||||||
SOURCES/criu-3.15.tar.bz2
|
SOURCES/criu-3.18.tar.gz
|
||||||
|
@ -0,0 +1,57 @@
|
|||||||
|
From 4878775c8e0f2ea6869aff139d219f6eb0c4006c Mon Sep 17 00:00:00 2001
|
||||||
|
From: Adrian Reber <areber@redhat.com>
|
||||||
|
Date: Fri, 28 Jan 2022 15:10:31 +0000
|
||||||
|
Subject: [PATCH] Fix building with annobin
|
||||||
|
|
||||||
|
Annobin (used at least in Fedora and RHEL) injects annotation into the
|
||||||
|
compiled objects which break the parasite and restorer.
|
||||||
|
|
||||||
|
This removes the annobin flags as used in Fedora and RHEL and makes CRIU
|
||||||
|
work on Fedora and RHEL with annobin enabled.
|
||||||
|
|
||||||
|
Signed-off-by: Adrian Reber <areber@redhat.com>
|
||||||
|
---
|
||||||
|
compel/plugins/Makefile | 2 +-
|
||||||
|
criu/pie/Makefile | 2 +-
|
||||||
|
criu/pie/Makefile.library | 2 +-
|
||||||
|
3 files changed, 3 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/compel/plugins/Makefile b/compel/plugins/Makefile
|
||||||
|
index e5fa781ac..37630d438 100644
|
||||||
|
--- a/compel/plugins/Makefile
|
||||||
|
+++ b/compel/plugins/Makefile
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-CFLAGS := $(filter-out -pg $(CFLAGS-GCOV) $(CFLAGS-ASAN),$(CFLAGS))
|
||||||
|
+CFLAGS := $(filter-out -pg $(CFLAGS-GCOV) $(CFLAGS-ASAN) -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1,$(CFLAGS))
|
||||||
|
CFLAGS += -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=0
|
||||||
|
CFLAGS += -Wp,-U_FORTIFY_SOURCE -Wp,-D_FORTIFY_SOURCE=0
|
||||||
|
|
||||||
|
diff --git a/criu/pie/Makefile b/criu/pie/Makefile
|
||||||
|
index 265dcf82b..386626334 100644
|
||||||
|
--- a/criu/pie/Makefile
|
||||||
|
+++ b/criu/pie/Makefile
|
||||||
|
@@ -4,7 +4,7 @@
|
||||||
|
|
||||||
|
target := parasite restorer
|
||||||
|
|
||||||
|
-CFLAGS := $(filter-out -pg $(CFLAGS-GCOV) $(CFLAGS-ASAN),$(CFLAGS))
|
||||||
|
+CFLAGS := $(filter-out -pg $(CFLAGS-GCOV) $(CFLAGS-ASAN) -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1,$(CFLAGS))
|
||||||
|
CFLAGS += $(CFLAGS_PIE)
|
||||||
|
ccflags-y += -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=0
|
||||||
|
ccflags-y += -Wp,-U_FORTIFY_SOURCE -Wp,-D_FORTIFY_SOURCE=0
|
||||||
|
diff --git a/criu/pie/Makefile.library b/criu/pie/Makefile.library
|
||||||
|
index da2a2fab3..6247afe7e 100644
|
||||||
|
--- a/criu/pie/Makefile.library
|
||||||
|
+++ b/criu/pie/Makefile.library
|
||||||
|
@@ -21,7 +21,7 @@ ifeq ($(ARCH),arm)
|
||||||
|
lib-y += ./$(ARCH_DIR)/pie-cacheflush.o
|
||||||
|
endif
|
||||||
|
|
||||||
|
-CFLAGS := $(filter-out -pg $(CFLAGS-GCOV) $(CFLAGS-ASAN),$(CFLAGS))
|
||||||
|
+CFLAGS := $(filter-out -pg $(CFLAGS-GCOV) $(CFLAGS-ASAN) -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1,$(CFLAGS))
|
||||||
|
CFLAGS += $(CFLAGS_PIE)
|
||||||
|
|
||||||
|
ifeq ($(ARCH),mips)
|
||||||
|
--
|
||||||
|
2.34.1
|
||||||
|
|
@ -0,0 +1,27 @@
|
|||||||
|
From 341ef149ee259d9432ea4c01507eefab2ef8b83c Mon Sep 17 00:00:00 2001
|
||||||
|
From: Radostin Stoyanov <radostin@redhat.com>
|
||||||
|
Date: Thu, 14 Oct 2021 12:58:56 +0100
|
||||||
|
Subject: [PATCH] criu.pc: Add libprotobuf-c as a dependency
|
||||||
|
|
||||||
|
CRIU has a dependency on protobuf-c-devel. We express this dependency
|
||||||
|
in pkgconfig to be auto-detected when building a package.
|
||||||
|
|
||||||
|
Signed-off-by: Radostin Stoyanov <radostin@redhat.com>
|
||||||
|
---
|
||||||
|
lib/c/criu.pc.in | 1 +
|
||||||
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
|
diff --git a/lib/c/criu.pc.in b/lib/c/criu.pc.in
|
||||||
|
index 33986d10d..bcced5033 100644
|
||||||
|
--- a/lib/c/criu.pc.in
|
||||||
|
+++ b/lib/c/criu.pc.in
|
||||||
|
@@ -4,5 +4,6 @@ includedir=@includedir@
|
||||||
|
Name: CRIU
|
||||||
|
Description: RPC library for userspace checkpoint and restore
|
||||||
|
Version: @version@
|
||||||
|
+Requires.private: libprotobuf-c
|
||||||
|
Libs: -L${libdir} -lcriu
|
||||||
|
Cflags: -I${includedir}
|
||||||
|
--
|
||||||
|
2.31.1
|
||||||
|
|
@ -0,0 +1,30 @@
|
|||||||
|
import os
|
||||||
|
from setuptools import setup, find_packages
|
||||||
|
|
||||||
|
print(find_packages('.'))
|
||||||
|
|
||||||
|
def get_version():
|
||||||
|
version = '0.0.1'
|
||||||
|
env = os.environ
|
||||||
|
if 'CRIU_VERSION_MAJOR' in env and 'CRIU_VERSION_MINOR' in env:
|
||||||
|
version = '{}.{}'.format(
|
||||||
|
env['CRIU_VERSION_MAJOR'],
|
||||||
|
env['CRIU_VERSION_MINOR']
|
||||||
|
)
|
||||||
|
if 'CRIU_VERSION_SUBLEVEL' in env and env['CRIU_VERSION_SUBLEVEL']:
|
||||||
|
version += '.' + env['CRIU_VERSION_SUBLEVEL']
|
||||||
|
return version
|
||||||
|
|
||||||
|
|
||||||
|
setup(
|
||||||
|
name='pycriu',
|
||||||
|
version=get_version(),
|
||||||
|
description='CRiu Image Tool',
|
||||||
|
author='CRIU team',
|
||||||
|
author_email='criu@openvz.org',
|
||||||
|
license='GPLv2',
|
||||||
|
url='https://github.com/checkpoint-restore/criu',
|
||||||
|
packages=['pycriu','pycriu.images'],
|
||||||
|
package_dir = {'pycriu': '.', 'pycriu.images':'images'}
|
||||||
|
|
||||||
|
)
|
Loading…
Reference in new issue