parent
9af00017f7
commit
19974e2b80
@ -1,2 +1,2 @@
|
||||
91f03b578aff0fda6b9d3e2185e6ea5e588c6d47 SOURCES/compiler-rt-14.0.6.src.tar.xz
|
||||
b8d2648a01d36ed0186fd2c5af325fd28797f9a0 SOURCES/tstellar-gpg-key.asc
|
||||
40f2a886636168f6478e20933906bcece2fd6b97 SOURCES/compiler-rt-15.0.7.src.tar.xz
|
||||
347bdd5ee6d6b93c9644c268511815912c0fb2dc SOURCES/release-keys.asc
|
||||
|
@ -1,2 +1,2 @@
|
||||
SOURCES/compiler-rt-14.0.6.src.tar.xz
|
||||
SOURCES/tstellar-gpg-key.asc
|
||||
SOURCES/compiler-rt-15.0.7.src.tar.xz
|
||||
SOURCES/release-keys.asc
|
||||
|
@ -1,37 +0,0 @@
|
||||
commit b18bde7a9bd6ed80f5721c47c805f0158b4fe9f8
|
||||
Author: Timm Bäder <tbaeder@redhat.com>
|
||||
Date: Wed Mar 9 07:17:21 2022 +0100
|
||||
|
||||
[compiler-rt] Add LLVM cmake package in standalone builds
|
||||
|
||||
So the other files from the toplevel cmake/Modules directory have a
|
||||
chance of being found.
|
||||
|
||||
diff --git a/compiler-rt/CMakeLists.txt b/compiler-rt/CMakeLists.txt
|
||||
index 3a41aa43e406..6516e10fa3c5 100644
|
||||
--- a/compiler-rt/CMakeLists.txt
|
||||
+++ b/compiler-rt/CMakeLists.txt
|
||||
@@ -28,6 +28,12 @@ else()
|
||||
set(CMAKE_CFG_RESOLVED_INTDIR "")
|
||||
endif()
|
||||
|
||||
+if(COMPILER_RT_STANDALONE_BUILD)
|
||||
+ # Needed to find the other modules from the toplevel cmake/Modules dir
|
||||
+ find_package(LLVM REQUIRED HINTS "${LLVM_CMAKE_DIR}")
|
||||
+ list(APPEND CMAKE_MODULE_PATH "${LLVM_DIR}")
|
||||
+endif()
|
||||
+
|
||||
include(SetPlatformToolchainTools)
|
||||
include(base-config-ix)
|
||||
include(CompilerRTUtils)
|
||||
diff --git a/compiler-rt/test/CMakeLists.txt b/compiler-rt/test/CMakeLists.txt
|
||||
index 5c2b634e1180..098fb0481517 100644
|
||||
--- a/compiler-rt/test/CMakeLists.txt
|
||||
+++ b/compiler-rt/test/CMakeLists.txt
|
||||
@@ -1,6 +1,3 @@
|
||||
-# Needed for lit support in standalone builds.
|
||||
-include(AddLLVM)
|
||||
-
|
||||
option(COMPILER_RT_TEST_STANDALONE_BUILD_LIBS
|
||||
"When set to ON and testing in a standalone build, test the runtime \
|
||||
libraries built by this standalone build rather than the runtime libraries \
|
Binary file not shown.
Binary file not shown.
Loading…
Reference in new issue