You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
cockpit/SOURCES/0001-Adds-MSVSphere-brandin...

88 lines
2.5 KiB

From fc676ccfa2932d62c09d6e47300147ab69aec6c0 Mon Sep 17 00:00:00 2001
From: Eugene Zamriy <ezamriy@msvsphere-os.ru>
Date: Mon, 20 Nov 2023 21:15:12 +0300
Subject: [PATCH 1/6] Adds MSVSphere branding directory
---
Makefile.am | 1 +
src/branding/msvsphere/Makefile.am | 11 +++++++++
src/branding/msvsphere/branding.css | 36 +++++++++++++++++++++++++++++
3 files changed, 48 insertions(+)
create mode 100644 src/branding/msvsphere/Makefile.am
create mode 100644 src/branding/msvsphere/branding.css
diff --git a/Makefile.am b/Makefile.am
index 7901fcc0d..5f2696062 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -174,6 +174,7 @@ include src/branding/debian/Makefile.am
include src/branding/default/Makefile.am
include src/branding/fedora/Makefile.am
include src/branding/kubernetes/Makefile.am
+include src/branding/msvsphere/Makefile.am
include src/branding/opensuse/Makefile.am
include src/branding/registry/Makefile.am
include src/branding/rhel/Makefile.am
diff --git a/src/branding/msvsphere/Makefile.am b/src/branding/msvsphere/Makefile.am
new file mode 100644
index 000000000..7425bdd0f
--- /dev/null
+++ b/src/branding/msvsphere/Makefile.am
@@ -0,0 +1,11 @@
+msvspherebrandingdir = $(datadir)/cockpit/branding/msvsphere
+
+dist_msvspherebranding_DATA = \
+ src/branding/msvsphere/branding.css \
+ $(NULL)
+
+# Opportunistically use sphere-logos ... yes they're called 'fedora'
+install-data-hook::
+ ln -sTfr $(DESTDIR)/usr/share/pixmaps/system-logo-white.png $(DESTDIR)$(msvspherebrandingdir)/logo.png
+ ln -sTfr $(DESTDIR)/usr/share/pixmaps/fedora-logo-sprite.png $(DESTDIR)$(msvspherebrandingdir)/apple-touch-icon.png
+ ln -sTfr $(DESTDIR)/etc/favicon.png $(DESTDIR)$(msvspherebrandingdir)/favicon.ico
diff --git a/src/branding/msvsphere/branding.css b/src/branding/msvsphere/branding.css
new file mode 100644
index 000000000..2b87b42bc
--- /dev/null
+++ b/src/branding/msvsphere/branding.css
@@ -0,0 +1,36 @@
+/* MSVSphere Branding */
+
+:root {
+ --ct-color-host-accent: #cc0000 !important;
+}
+
+body.login-pf {
+ background: url("bg-plain.jpg") no-repeat 50% 0;
+ background-size: cover;
+ background-color: #101010;
+}
+
+#badge {
+ width: 225px;
+ height: 80px;
+ background-image: url("logo.png");
+ background-size: contain;
+ background-repeat: no-repeat;
+}
+
+#brand {
+ font-size: 18pt;
+ text-transform: uppercase;
+}
+
+#brand:before {
+ content: "${NAME}";
+}
+
+#index-brand {
+ font-weight: bold;
+}
+
+#index-brand:before {
+ content: "${NAME}";
+}
--
2.43.0