You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
cfitsio/cfitsio.patch

37 lines
1.2 KiB

diff -u cfitsio/configure cfitsio-new/configure
--- cfitsio/configure 2005-07-28 17:26:13.000000000 -0400
+++ cfitsio-new/configure 2005-11-13 14:36:39.000000000 -0500
@@ -1251,7 +1251,8 @@
SHLIB_SUFFIX=".sl"
;;
lnx)
- SHLIB_LD=":"
+ SHLIB_LD="cc -shared -Wl,-soname,libcfitsio.so.0"
+ SHLIB_SUFFIX=".so.0"
;;
osf)
SHLIB_LD="ld -shared -expect_unresolved '*'"
@@ -1271,7 +1272,7 @@
# Darwin uses gcc (=cc), but needs different flags (see above)
# if test "x$GCC" = xyes; then
if test "x$GCC" = xyes && test "x$EXT" != xdarwin && test "x$EXT" != xcygwin; then
- SHLIB_LD="$CC -shared"
+ SHLIB_LD="cc -shared -Wl,-soname,libcfitsio.so.0"
lhea_shlib_cflags='-fPIC'
fi
if test "x$lhea_shlib_cflags" != x; then
diff -u old/Makefile.in new/Makefile.in
--- old/Makefile.in 2006-10-12 17:14:41.000000000 -0400
+++ new/Makefile.in 2006-12-05 16:36:24.000000000 -0500
@@ -21,8 +21,8 @@
prefix = @prefix@
exec_prefix = @exec_prefix@
CFITSIO_PREFIX = $(prefix)
-CFITSIO_LIB = $(exec_prefix)/lib
-CFITSIO_INCLUDE = $(prefix)/include
+CFITSIO_LIB = $(exec_prefix)/$(LIBDIR)
+CFITSIO_INCLUDE = $(prefix)/$(INCLUDEDIR)
INSTALL_DIRS = @INSTALL_ROOT@ ${CFITSIO_LIB} ${CFITSIO_LIB}/pkgconfig ${CFITSIO_INCLUDE}