You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
cfitsio/cfitsio.patch

43 lines
1.3 KiB

diff -u cfitsio/configure cfitsio-new/configure
--- cfitsio/configure 2005-07-28 17:26:13.000000000 -0400
+++ cfitsio-new/configure 2005-11-13 14:36:39.000000000 -0500
@@ -1251,7 +1251,8 @@
SHLIB_SUFFIX=".sl"
;;
lnx)
- SHLIB_LD=":"
+ SHLIB_LD="cc -shared -Wl,-soname,libcfitsio.so.0"
+ SHLIB_SUFFIX=".so.0"
;;
osf)
SHLIB_LD="ld -shared -expect_unresolved '*'"
@@ -1271,7 +1272,7 @@
# Darwin uses gcc (=cc), but needs different flags (see above)
# if test "x$GCC" = xyes; then
if test "x$GCC" = xyes && test "x$EXT" != xdarwin && test "x$EXT" != xcygwin; then
- SHLIB_LD="$CC -shared"
+ SHLIB_LD="cc -shared -Wl,-soname,libcfitsio.so.0"
lhea_shlib_cflags='-fPIC'
fi
if test "x$lhea_shlib_cflags" != x; then
diff -u cfitsio/Makefile.in cfitsio-new/Makefile.in
--- cfitsio/Makefile.in 2005-04-26 11:48:05.000000000 -0400
+++ cfitsio-new/Makefile.in 2005-11-13 13:52:27.000000000 -0500
@@ -19,8 +19,8 @@
#
CFITSIO_PREFIX = @CFITSIO_PREFIX@
-CFITSIO_LIB = ${CFITSIO_PREFIX}/lib
-CFITSIO_INCLUDE = ${CFITSIO_PREFIX}/include
+CFITSIO_LIB = ${CFITSIO_PREFIX}/${LIBDIR}
+CFITSIO_INCLUDE = ${CFITSIO_PREFIX}/${INCLUDEDIR}
SHELL = /bin/sh
RANLIB = @RANLIB@
@@ -146,4 +146,4 @@
objs: ${CORE_OBJECTS}
${CFITSIO_PREFIX} ${CFITSIO_LIB} ${CFITSIO_INCLUDE}:
- @if [ ! -d $@ ]; then mkdir $@; fi
+ @if [ ! -d $@ ]; then mkdir -p $@; fi