You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
cfitsio/cfitsio.patch

35 lines
1.2 KiB

diff -ur cfitsio/configure cfitsio-fixed/configure
--- cfitsio/configure 2012-04-13 21:16:16.000000000 +0200
+++ cfitsio-fixed/configure 2012-04-24 13:54:49.295113574 +0200
@@ -3908,7 +3908,8 @@
SHLIB_SUFFIX=".sl"
;;
lnx)
- SHLIB_LD=":"
+ SHLIB_LD="cc -shared -Wl,-soname,libcfitsio.so.0"
+ SHLIB_SUFFIX=".so.0"
;;
osf)
SHLIB_LD="ld -shared -expect_unresolved '*'"
@@ -3929,7 +3930,7 @@
# Darwin uses gcc (=cc), but needs different flags (see above)
# if test "x$GCC" = xyes; then
if test "x$GCC" = xyes && test "x$EXT" != xdarwin && test "x$EXT" != xcygwin; then
- SHLIB_LD="$CC -shared"
+ SHLIB_LD="cc -shared -Wl,-soname,libcfitsio.so.0"
lhea_shlib_cflags='-fPIC'
fi
if test "x$lhea_shlib_cflags" != x; then
diff -ur cfitsio/Makefile.in cfitsio-fixed/Makefile.in
--- cfitsio/Makefile.in 2012-04-13 21:16:08.000000000 +0200
+++ cfitsio-fixed/Makefile.in 2012-04-24 13:55:38.543470352 +0200
@@ -87,7 +87,7 @@
shared: libcfitsio${SHLIB_SUFFIX}
libcfitsio${SHLIB_SUFFIX}: ${OBJECTS}
- ${SHLIB_LD} ${LDFLAGS} -o $@ ${OBJECTS}
+ ${SHLIB_LD} ${LDFLAGS} -o $@ ${OBJECTS} -lpthread -lm
install: libcfitsio.a $(INSTALL_DIRS)
@if [ -f libcfitsio.a ]; then \