You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
cfitsio/cfitsio.patch

37 lines
1.3 KiB

diff -ur cfitsio/configure cfitsio-fixed-configure/configure
--- cfitsio/configure 2010-01-08 13:03:29.000000000 -0500
+++ cfitsio-fixed-configure/configure 2010-01-27 15:46:34.000000000 -0500
@@ -4058,7 +4058,8 @@
SHLIB_SUFFIX=".sl"
;;
lnx)
- SHLIB_LD=":"
+ SHLIB_LD="cc -shared -Wl,-soname,libcfitsio.so.0"
+ SHLIB_SUFFIX=".so.0"
;;
osf)
SHLIB_LD="ld -shared -expect_unresolved '*'"
@@ -4079,7 +4080,7 @@
# Darwin uses gcc (=cc), but needs different flags (see above)
# if test "x$GCC" = xyes; then
if test "x$GCC" = xyes && test "x$EXT" != xdarwin && test "x$EXT" != xcygwin; then
- SHLIB_LD="$CC -shared"
+ SHLIB_LD="cc -shared -Wl,-soname,libcfitsio.so.0"
lhea_shlib_cflags='-fPIC'
fi
if test "x$lhea_shlib_cflags" != x; then
diff -ur cfitsio/Makefile.in cfitsio-fixed-configure/Makefile.in
--- cfitsio/Makefile.in 2010-01-08 13:03:30.000000000 -0500
+++ cfitsio-fixed-configure/Makefile.in 2010-01-27 15:46:34.000000000 -0500
@@ -22,8 +22,8 @@
exec_prefix = @exec_prefix@
DESTDIR =
CFITSIO_PREFIX = $(prefix)
-CFITSIO_LIB = $(DESTDIR)$(exec_prefix)/lib
-CFITSIO_INCLUDE = $(DESTDIR)$(prefix)/include
+CFITSIO_LIB = $(DESTDIR)$(exec_prefix)/$(LIBDIR)
+CFITSIO_INCLUDE = $(DESTDIR)$(prefix)/$(INCLUDEDIR)
INSTALL_DIRS = $(DESTDIR)@INSTALL_ROOT@ ${CFITSIO_LIB} ${CFITSIO_LIB}/pkgconfig ${CFITSIO_INCLUDE}