You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
37 lines
1.3 KiB
37 lines
1.3 KiB
diff -ur cfitsio/configure cfitio-fixed/configure
|
|
--- cfitsio/configure 2009-09-03 16:33:59.000000000 -0400
|
|
+++ cfitio-fixed/configure 2009-11-02 15:33:12.000000000 -0500
|
|
@@ -4061,7 +4061,8 @@
|
|
SHLIB_SUFFIX=".sl"
|
|
;;
|
|
lnx)
|
|
- SHLIB_LD=":"
|
|
+ SHLIB_LD="cc -shared -Wl,-soname,libcfitsio.so.0"
|
|
+ SHLIB_SUFFIX=".so.0"
|
|
;;
|
|
osf)
|
|
SHLIB_LD="ld -shared -expect_unresolved '*'"
|
|
@@ -4082,7 +4083,7 @@
|
|
# Darwin uses gcc (=cc), but needs different flags (see above)
|
|
# if test "x$GCC" = xyes; then
|
|
if test "x$GCC" = xyes && test "x$EXT" != xdarwin && test "x$EXT" != xcygwin; then
|
|
- SHLIB_LD="$CC -shared"
|
|
+ SHLIB_LD="cc -shared -Wl,-soname,libcfitsio.so.0"
|
|
lhea_shlib_cflags='-fPIC'
|
|
fi
|
|
if test "x$lhea_shlib_cflags" != x; then
|
|
diff -ur cfitsio/Makefile.in cfitio-fixed/Makefile.in
|
|
--- cfitsio/Makefile.in 2009-07-14 16:40:37.000000000 -0400
|
|
+++ cfitio-fixed/Makefile.in 2009-11-02 15:33:12.000000000 -0500
|
|
@@ -22,8 +22,8 @@
|
|
exec_prefix = @exec_prefix@
|
|
DESTDIR =
|
|
CFITSIO_PREFIX = $(prefix)
|
|
-CFITSIO_LIB = $(DESTDIR)$(exec_prefix)/lib
|
|
-CFITSIO_INCLUDE = $(DESTDIR)$(prefix)/include
|
|
+CFITSIO_LIB = $(DESTDIR)$(exec_prefix)/$(LIBDIR)
|
|
+CFITSIO_INCLUDE = $(DESTDIR)$(prefix)/$(INCLUDEDIR)
|
|
INSTALL_DIRS = $(DESTDIR)@INSTALL_ROOT@ ${CFITSIO_LIB} ${CFITSIO_LIB}/pkgconfig ${CFITSIO_INCLUDE}
|
|
|
|
|