auto-import cfitsio-3.004-0.10.b on branch devel from

cfitsio-3.004-0.10.b.src.rpm
epel9
Matthew D Truch 19 years ago
parent 9302152050
commit 9f3ec05775

@ -0,0 +1,42 @@
diff -u cfitsio/configure cfitsio-new/configure
--- cfitsio/configure 2005-07-28 17:26:13.000000000 -0400
+++ cfitsio-new/configure 2005-11-13 14:36:39.000000000 -0500
@@ -1251,7 +1251,8 @@
SHLIB_SUFFIX=".sl"
;;
lnx)
- SHLIB_LD=":"
+ SHLIB_LD="cc -shared -Wl,-soname,libcfitsio.so.0"
+ SHLIB_SUFFIX=".so.0"
;;
osf)
SHLIB_LD="ld -shared -expect_unresolved '*'"
@@ -1271,7 +1272,7 @@
# Darwin uses gcc (=cc), but needs different flags (see above)
# if test "x$GCC" = xyes; then
if test "x$GCC" = xyes && test "x$EXT" != xdarwin && test "x$EXT" != xcygwin; then
- SHLIB_LD="$CC -shared"
+ SHLIB_LD="cc -shared -Wl,-soname,libcfitsio.so.0"
lhea_shlib_cflags='-fPIC'
fi
if test "x$lhea_shlib_cflags" != x; then
diff -u cfitsio/Makefile.in cfitsio-new/Makefile.in
--- cfitsio/Makefile.in 2005-04-26 11:48:05.000000000 -0400
+++ cfitsio-new/Makefile.in 2005-11-13 13:52:27.000000000 -0500
@@ -19,8 +19,8 @@
#
CFITSIO_PREFIX = @CFITSIO_PREFIX@
-CFITSIO_LIB = ${CFITSIO_PREFIX}/lib
-CFITSIO_INCLUDE = ${CFITSIO_PREFIX}/include
+CFITSIO_LIB = ${CFITSIO_PREFIX}/${LIBDIR}
+CFITSIO_INCLUDE = ${CFITSIO_PREFIX}/${INCLUDEDIR}
SHELL = /bin/sh
RANLIB = @RANLIB@
@@ -146,4 +146,4 @@
objs: ${CORE_OBJECTS}
${CFITSIO_PREFIX} ${CFITSIO_LIB} ${CFITSIO_INCLUDE}:
- @if [ ! -d $@ ]; then mkdir $@; fi
+ @if [ ! -d $@ ]; then mkdir -p $@; fi

@ -1,12 +1,13 @@
Name: cfitsio
Version: 3.004
Release: 0.9.b
Release: 0.10.b%{?dist}
Summary: Library for manipulating FITS data files
Group: Development/Libraries
License: GPL
URL: ftp://heasarc.gsfc.nasa.gov/software/fitsio/c/cfitsio3004bbeta.tar.gz
Source0: cfitsio3004bbeta.tar.gz
Patch: cfitsio.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: gcc-gfortran
@ -35,34 +36,26 @@ Headers required when building a program against the cfitsio library.
%prep
%setup -q -n cfitsio
%patch -p1
%build
FC=g95
export FC
%configure --prefix=%{buildroot}/%{_prefix} --includedir=%{buildroot}/%{_includedir}/%{name}
cat Makefile | \
sed -e 's|cc -shared|cc -shared -Wl,-soname,libcfitsio.so.0|g' \
> Makefile.new
mv Makefile.new Makefile
#cat Makefile | \
# sed -e 's|cc -shared|cc -shared -Wl,-soname,libcfitsio.so.0|g' \
# > Makefile.new
#mv Makefile.new Makefile
make shared %{?_smp_mflags}
unset FC
%install
rm -rf %{buildroot}
mkdir -p %{buildroot}
CFITSIO_LIB = %{buildroot}%{_libdir}
CFITSIO_INCLUDE = %{buildroot}%{_includedir}/%{name}
export CFITSIO_LIB
export CFITSIO_INCLUDE
make install
#move headers to correct location (configure doesn't obey --includedir)
mkdir -p %{buildroot}%{_libdir}
LIBDIR=%{_lib} INCLUDEDIR=include/%{name} make install
pushd %{buildroot}%{_libdir}
ln -s libcfitsio.so libcfitsio.so.0
ln -s libcfitsio.so.0 libcfitsio.so
popd
unset CFITSIO_LIB
unset CFITSIO_INCLUDE
%clean
rm -rf %{buildroot}
@ -74,14 +67,19 @@ rm -rf %{buildroot}
%files
%defattr(-,root,root,-)
%doc README Licence.txt changes.txt fitsio.doc fitsio.ps cfitsio.doc cfitsio.ps
%{_libdir}/libcfitsio.so*
%{_libdir}/libcfitsio.so.*
%files devel
%{_includedir}/%{name}
%{_libdir}/libcfitsio.a
%{_libdir}/libcfitsio.so
%changelog
* Sat Nov 12 2005 Matthew Truch <matt at truch.net> - 3.004-0.9.b
* Sun Nov 13 2005 Matthew Truch <matt at truch.net> - 3.004-0.10.b
- Set environment variables correctly.
- Include patch so Makefile will put things where they belong.
* Sun Nov 13 2005 Matthew Truch <matt at truch.net> - 3.004-0.9.b
- Set libdir and includedir correctly for build process.
* Sat Nov 12 2005 Matthew Truch <matt at truch.net> - 3.004-0.8.b

Loading…
Cancel
Save