|
|
|
@ -1,7 +1,7 @@
|
|
|
|
|
diff -u cfitsio/configure cfitsio-new/configure
|
|
|
|
|
--- cfitsio/configure 2005-07-28 17:26:13.000000000 -0400
|
|
|
|
|
+++ cfitsio-new/configure 2005-11-13 14:36:39.000000000 -0500
|
|
|
|
|
@@ -1251,7 +1251,8 @@
|
|
|
|
|
diff -u cfitsio/configure cfitsio-fixed/configure
|
|
|
|
|
--- cfitsio/configure 2007-11-05 15:52:57.000000000 -0500
|
|
|
|
|
+++ cfitsio-fixed/configure 2008-09-19 18:50:51.000000000 -0400
|
|
|
|
|
@@ -3397,7 +3397,8 @@
|
|
|
|
|
SHLIB_SUFFIX=".sl"
|
|
|
|
|
;;
|
|
|
|
|
lnx)
|
|
|
|
@ -11,7 +11,7 @@ diff -u cfitsio/configure cfitsio-new/configure
|
|
|
|
|
;;
|
|
|
|
|
osf)
|
|
|
|
|
SHLIB_LD="ld -shared -expect_unresolved '*'"
|
|
|
|
|
@@ -1271,7 +1272,7 @@
|
|
|
|
|
@@ -3418,7 +3419,7 @@
|
|
|
|
|
# Darwin uses gcc (=cc), but needs different flags (see above)
|
|
|
|
|
# if test "x$GCC" = xyes; then
|
|
|
|
|
if test "x$GCC" = xyes && test "x$EXT" != xdarwin && test "x$EXT" != xcygwin; then
|
|
|
|
@ -20,17 +20,17 @@ diff -u cfitsio/configure cfitsio-new/configure
|
|
|
|
|
lhea_shlib_cflags='-fPIC'
|
|
|
|
|
fi
|
|
|
|
|
if test "x$lhea_shlib_cflags" != x; then
|
|
|
|
|
diff -u old/Makefile.in new/Makefile.in
|
|
|
|
|
--- old/Makefile.in 2006-10-12 17:14:41.000000000 -0400
|
|
|
|
|
+++ new/Makefile.in 2006-12-05 16:36:24.000000000 -0500
|
|
|
|
|
@@ -21,8 +21,8 @@
|
|
|
|
|
prefix = @prefix@
|
|
|
|
|
diff -u cfitsio/Makefile.in cfitsio-fixed/Makefile.in
|
|
|
|
|
--- cfitsio/Makefile.in 2008-01-14 13:30:51.000000000 -0500
|
|
|
|
|
+++ cfitsio-fixed/Makefile.in 2008-09-19 18:51:41.000000000 -0400
|
|
|
|
|
@@ -22,8 +22,8 @@
|
|
|
|
|
exec_prefix = @exec_prefix@
|
|
|
|
|
DESTDIR =
|
|
|
|
|
CFITSIO_PREFIX = $(prefix)
|
|
|
|
|
-CFITSIO_LIB = $(exec_prefix)/lib
|
|
|
|
|
-CFITSIO_INCLUDE = $(prefix)/include
|
|
|
|
|
+CFITSIO_LIB = $(exec_prefix)/$(LIBDIR)
|
|
|
|
|
+CFITSIO_INCLUDE = $(prefix)/$(INCLUDEDIR)
|
|
|
|
|
INSTALL_DIRS = @INSTALL_ROOT@ ${CFITSIO_LIB} ${CFITSIO_LIB}/pkgconfig ${CFITSIO_INCLUDE}
|
|
|
|
|
-CFITSIO_LIB = $(DESTDIR)$(exec_prefix)/lib
|
|
|
|
|
-CFITSIO_INCLUDE = $(DESTDIR)$(prefix)/include
|
|
|
|
|
+CFITSIO_LIB = $(DESTDIR)$(exec_prefix)/$(LIBDIR)
|
|
|
|
|
+CFITSIO_INCLUDE = $(DESTDIR)$(prefix)/$(INCLUDEDIR)
|
|
|
|
|
INSTALL_DIRS = $(DESTDIR)@INSTALL_ROOT@ ${CFITSIO_LIB} ${CFITSIO_LIB}/pkgconfig ${CFITSIO_INCLUDE}
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|