Modified patches

epel9
Pasrario 13 years ago
parent 9d14a7f4ba
commit 400b474848

@ -16,8 +16,8 @@ diff -ur cfitsio/Makefile.in cfitsio-zlib/Makefile.in
shared: libcfitsio${SHLIB_SUFFIX}
libcfitsio${SHLIB_SUFFIX}: ${OBJECTS}
- ${SHLIB_LD} ${LDFLAGS} -o $@ ${OBJECTS} -lpthread -lm
+ ${SHLIB_LD} ${LDFLAGS} -o $@ ${OBJECTS} -lpthread -lm -lz
- ${SHLIB_LD} ${LDFLAGS} -o $@ ${OBJECTS} -lm ${LIBS}
+ ${SHLIB_LD} ${LDFLAGS} -o $@ ${OBJECTS} -lm ${LIBS} -lz
install: libcfitsio.a $(INSTALL_DIRS)
@if [ -f libcfitsio.a ]; then \

@ -1,6 +1,6 @@
diff -ur cfitsio/configure cfitsio-fixed/configure
--- cfitsio/configure 2012-04-13 21:16:16.000000000 +0200
+++ cfitsio-fixed/configure 2012-04-24 13:54:49.295113574 +0200
+++ cfitsio-fixed/configure 2012-08-30 08:25:25.681081693 +0200
@@ -3908,7 +3908,8 @@
SHLIB_SUFFIX=".sl"
;;
@ -16,19 +16,7 @@ diff -ur cfitsio/configure cfitsio-fixed/configure
# if test "x$GCC" = xyes; then
if test "x$GCC" = xyes && test "x$EXT" != xdarwin && test "x$EXT" != xcygwin; then
- SHLIB_LD="$CC -shared"
+ SHLIB_LD="cc -shared -Wl,-soname,libcfitsio.so.0"
+ SHLIB_LD="$CC -shared -Wl,-soname,libcfitsio.so.0"
lhea_shlib_cflags='-fPIC'
fi
if test "x$lhea_shlib_cflags" != x; then
diff -ur cfitsio/Makefile.in cfitsio-fixed/Makefile.in
--- cfitsio/Makefile.in 2012-04-13 21:16:08.000000000 +0200
+++ cfitsio-fixed/Makefile.in 2012-04-24 13:55:38.543470352 +0200
@@ -87,7 +87,7 @@
shared: libcfitsio${SHLIB_SUFFIX}
libcfitsio${SHLIB_SUFFIX}: ${OBJECTS}
- ${SHLIB_LD} ${LDFLAGS} -o $@ ${OBJECTS}
+ ${SHLIB_LD} ${LDFLAGS} -o $@ ${OBJECTS} -lpthread -lm
install: libcfitsio.a $(INSTALL_DIRS)
@if [ -f libcfitsio.a ]; then \

@ -5,9 +5,11 @@ Summary: Library for manipulating FITS data files
Group: Development/Libraries
License: MIT
URL: http://heasarc.gsfc.nasa.gov/fitsio/
Source0: ftp://heasarc.gsfc.nasa.gov/software/fitsio/c/cfitsio3300.tar.gz
Source0: ftp://heasarc.gsfc.nasa.gov/software/fitsio/c/cfitsio3310.tar.gz
Patch0: cfitsio.patch
# Unbundles zlib
Patch1: cfitsio-zlib.patch
# Removes the runtime check of the version of the library
Patch2: cfitsio-noversioncheck.patch
BuildRequires: gcc-gfortran zlib-devel
@ -144,10 +146,11 @@ cp -p f{,un}pack %{buildroot}%{_bindir}/
%changelog
* Wed Aug 29 2012 Sergio Pascual <sergiopr@fedoraproject.org> - 3.310-2
- Removed check at runtime of the version of the program
- Removed check at runtime of the version of the library
* Wed Aug 29 2012 Sergio Pascual <sergiopr@fedoraproject.org> - 3.310-1
- New upstream version
- Modified cfitsio.patch for new version
* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.300-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild

Loading…
Cancel
Save