You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
18 lines
493 B
18 lines
493 B
diff --git a/bin/named/Makefile.am b/bin/named/Makefile.am
|
|
index 57a023b..085f2f7 100644
|
|
--- a/bin/named/Makefile.am
|
|
+++ b/bin/named/Makefile.am
|
|
@@ -32,9 +32,12 @@ AM_CPPFLAGS += \
|
|
endif HAVE_LIBXML2
|
|
|
|
AM_CPPFLAGS += \
|
|
+ -fpie \
|
|
-DNAMED_LOCALSTATEDIR=\"${localstatedir}\" \
|
|
-DNAMED_SYSCONFDIR=\"${sysconfdir}\"
|
|
|
|
+AM_LDFLAGS += -pie -Wl,-z,relro,-z,now,-z,nodlopen,-z,noexecstack
|
|
+
|
|
sbin_PROGRAMS = named
|
|
|
|
nodist_named_SOURCES = xsl.c
|