You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
19 lines
563 B
19 lines
563 B
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -41,6 +41,15 @@ option(ENABLE_TESTS "Enable compilation
|
|
include(GNUInstallDirs)
|
|
|
|
|
|
+set(PACKAGE_VERSION "${PROJECT_VERSION}")
|
|
+set(prefix ${CMAKE_INSTALL_PREFIX})
|
|
+set(exec_prefix ${prefix}/bin)
|
|
+set(libdir ${CMAKE_INSTALL_LIBDIR})
|
|
+set(includedir ${prefix}/include)
|
|
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/libbcg729.pc.in ${CMAKE_CURRENT_BINARY_DIR}/libbcg729.pc)
|
|
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/libbcg729.pc DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig")
|
|
+
|
|
+
|
|
include_directories(
|
|
include
|
|
src
|