Switch to arpack-ng sources, updating to 3.0.1.

epel9
Jussi Lehtola 13 years ago
parent 70c19b8b35
commit 9d57fae8cc

1
.gitignore vendored

@ -1,2 +1,3 @@
arpack96.tar.gz
patch.tar.gz
/arpack_3.0.1.tar.gz

@ -1,37 +0,0 @@
BSD Software License
Pertains to ARPACK and P_ARPACK
Copyright (c) 1996-2008 Rice University.
Developed by D.C. Sorensen, R.B. Lehoucq, C. Yang, and K. Maschhoff.
All rights reserved.
Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are
met:
- Redistributions of source code must retain the above copyright
notice, this list of conditions and the following disclaimer.
- Redistributions in binary form must reproduce the above copyright
notice, this list of conditions and the following disclaimer listed
in this license in the documentation and/or other materials
provided with the distribution.
- Neither the name of the copyright holders nor the names of its
contributors may be used to endorse or promote products derived from
this software without specific prior written permission.
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

@ -1,45 +0,0 @@
--- ARPACK/ARmake.inc~ 1996-04-26 21:12:57.000000000 +0200
+++ ARPACK/ARmake.inc 2003-07-19 11:57:10.000000000 +0200
@@ -25,7 +25,7 @@
# | other than your home directory. |
# %--------------------------------------%
#
-home = $(HOME)/ARPACK
+home = $(PWD)/.
#
# %--------------------------------------%
# | The platform identifier to suffix to |
@@ -43,7 +43,7 @@
UTILdir = $(home)/UTIL
SRCdir = $(home)/SRC
#
-DIRS = $(BLASdir) $(LAPACKdir) $(UTILdir) $(SRCdir)
+#DIRS = $(BLASdir) $(LAPACKdir) $(UTILdir) $(SRCdir)
#
# %-------------------------------------------------------------------%
# | Comment out the previous line and uncomment the following |
@@ -51,13 +51,13 @@
# | NOTE: ARPACK assumes the use of LAPACK version 2 codes. |
# %-------------------------------------------------------------------%
#
-#DIRS = $(UTILdir) $(SRCdir)
+DIRS = $(UTILdir) $(SRCdir)
#
# %---------------------------------------------------%
# | The name of the libraries to be created/linked to |
# %---------------------------------------------------%
#
-ARPACKLIB = $(home)/libarpack_$(PLAT).a
+ARPACKLIB = $(home)/libarpack.a
LAPACKLIB =
BLASLIB =
#
@@ -112,7 +112,7 @@
LN = ln
LNFLAGS = -s
-MAKE = /bin/make
+MAKE = make
RM = rm
RMFLAGS = -f

@ -1,11 +0,0 @@
diff -up ARPACK/UTIL/second.f.etime ARPACK/UTIL/second.f
--- ARPACK/UTIL/second.f.etime 2008-09-24 22:40:53.000000000 +0200
+++ ARPACK/UTIL/second.f 2008-09-24 22:42:03.000000000 +0200
@@ -21,7 +21,6 @@
* ..
* .. External Functions ..
REAL ETIME
- EXTERNAL ETIME
* ..
* .. Executable Statements ..
*

File diff suppressed because it is too large Load Diff

@ -1,27 +1,26 @@
%bcond_without gfortran
Summary: Fortran77 subroutines for solving large scale eigenvalue problems
Summary: Fortran 77 subroutines for solving large scale eigenvalue problems
Name: arpack
Version: 2.1
Release: 13%{?dist}
Version: 3.0.1
Release: 1%{?dist}
License: BSD
Group: Development/Libraries
URL: http://www.caam.rice.edu/software/ARPACK/
Source0: http://www.caam.rice.edu/software/ARPACK/SRC/arpack96.tar.gz
Source1: http://www.caam.rice.edu/software/ARPACK/SRC/patch.tar.gz
Source2: http://www.caam.rice.edu/software/ARPACK/RiceBSD.txt
Patch0: arpack-2.1-redhat.patch
# see http://www.ann.jussieu.fr/pipermail/freefempp/2006/000213.html
Patch1: arpack-second-bug.patch
Patch2: arpack-etime.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
BuildRequires: %{?with_gfortran:gcc-gfortran}%{!?with_gfortran:/usr/bin/f77}
URL: http://forge.scilab.org/index.php/p/arpack-ng/
Source0: http://forge.scilab.org/upload/arpack-ng/files/arpack_%{version}.tar.gz
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
%if 0%{?rhel} == 4
# The correct dependency would be the following, but it doesn't exist on RHEL4/3
#BuildRequires: lapack-devel
BuildRequires: %{_libdir}/liblapack.so
BuildRequires: gcc-g77
BuildRequires: lapack
%else
BuildRequires: gcc-gfortran
BuildRequires: atlas-devel
%endif
Provides: arpack-ng = %{version}-%{release}
%description
ARPACK is a collection of Fortran77 subroutines designed to solve large
ARPACK is a collection of Fortran 77 subroutines designed to solve large
scale eigenvalue problems.
The package is designed to compute a few eigenvalues and corresponding
@ -36,56 +35,52 @@ Restarted Arnoldi Method (IRAM).
Summary: Files needed for developing arpack based applications
Group: Development/Libraries
Requires: arpack = %{version}-%{release}
Provides: arpack-ng-devel = %{version}-%{release}
%description devel
ARPACK is a collection of Fortran77 subroutines designed to solve
ARPACK is a collection of Fortran 77 subroutines designed to solve
large scale eigenvalue problems. This package contains the so
library links used for building arpack based applications.
%package doc
Summary: Examples for the use of arpack
Group: Documentation
%if 0%{?rhel} > 5 || 0%{?fedora} > 12
BuildArch: noarch
%endif
%description doc
This package contains examples for the use of arpack.
%package static
Summary: Static library for developing arpack based applications
Group: Development/Libraries
Requires: arpack-devel = %{version}-%{release}
Provides: arpack-ng-static = %{version}-%{release}
%description static
ARPACK is a collection of Fortran77 subroutines designed to solve
ARPACK is a collection of Fortran 77 subroutines designed to solve
large scale eigenvalue problems. This package contains the static
library and so links used for building arpack based applications.
%prep
%setup -q -b 1 -n ARPACK
%patch0 -p1 -b .rh
%patch1 -p1 -b .sb
%patch2 -p1 -b .etime
mkdir static shared
%setup -q -n arpack-ng-%{version}
%build
cd shared
for dir in ../SRC ../UTIL; do
make -f $dir/Makefile VPATH=$dir srcdir=$dir \
%{?with_gfortran:FC=gfortran} FFLAGS="%{optflags} -fPIC" \
single double complex complex16
done
gcc -shared -llapack -Wl,-soname,libarpack.so.2 -o libarpack.so.2.1 *.o
cd ..
cd static
for dir in ../SRC ../UTIL; do
make -f $dir/Makefile VPATH=$dir srcdir=$dir \
%{?with_gfortran:FC=gfortran} FFLAGS="%{optflags}" LDFLAGS="-s" \
all
done
ar rv libarpack.a *.o
ranlib libarpack.a
cd ..
%{configure} --enable-shared --enable-static \
%if 0%{?rhel} == 4
--with-blas="-lblas" --with-lapack="-llapack"
%else
--with-blas="-L%{_libdir}/atlas -lf77blas -latlas" --with-lapack="-L%{_libdir}/atlas -llapack -latlas"
%endif
make %{?_smp_mflags}
%install
rm -rf %{buildroot}
mkdir -p %{buildroot}%{_libdir}
install -p -m644 static/libarpack.a %{buildroot}%{_libdir}
install -p -m755 shared/libarpack.so.2.1 %{buildroot}%{_libdir}
ln -s libarpack.so.2.1 %{buildroot}%{_libdir}/libarpack.so.2
ln -s libarpack.so.2 %{buildroot}%{_libdir}/libarpack.so
cp -p %{SOURCE2} .
make install DESTDIR=%{buildroot}
# Get rid of .la files
rm -rf %{buildroot}%{_libdir}/*.la
%clean
rm -rf %{buildroot}
@ -96,7 +91,7 @@ rm -rf %{buildroot}
%files
%defattr(-,root,root,-)
%doc RiceBSD.txt
%doc CHANGES COPYING
%{_libdir}/libarpack.so.*
%files devel
@ -104,10 +99,19 @@ rm -rf %{buildroot}
%doc DOCUMENTS EXAMPLES
%{_libdir}/libarpack.so
%files doc
%defattr(-,root,root,-)
%doc EXAMPLES/ DOCUMENTS/
%files static
%defattr(-,root,root,-)
%{_libdir}/libarpack.a
%changelog
* Tue Dec 13 2011 Jussi Lehtola <jussilehtola@fedoraproject.org> - 3.0.1-1
- Change sources to arpack-ng, which provides an up-to-date version of ARPACK.
- Include examples and documentation in a new -doc package.
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1-13
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild

@ -1,2 +1 @@
fffaa970198b285676f4156cebc8626e arpack96.tar.gz
14830d758f195f272b8594a493501fa2 patch.tar.gz
de04b99fa44be6835e8b7c572b94e55a arpack_3.0.1.tar.gz

Loading…
Cancel
Save