Import arpack.

epel9
athimm 17 years ago
parent ce6939ffdf
commit 4223f4ba9c

@ -0,0 +1,2 @@
arpack96.tar.gz
patch.tar.gz

Binary file not shown.

@ -0,0 +1,43 @@
Rice BSD Software License
Permits source and binary redistribution of the software ARPACK and
P_ARPACK for both non-commercial and commercial use.
Copyright (©) 2001, Rice University
Developed by D.C. Sorensen, R.B. Lehoucq, C. Yang, and K. Maschhoff.
All rights reserved.
Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are
met:
o Redistributions of source code must retain the above copyright
notice, this list of conditions and the following disclaimer.
o Redistributions in binary form must reproduce the above copyright
notice, this list of conditions and the following disclaimer in the
documentation and/or other materials provided with the distribution.
o If you modify the source for these routines we ask that you change
the name of the routine and comment the changes made to the
original.
o Written notification is provided to the developers of intent to use
this software. Also, we ask that use of ARPACK is properly cited in
any resulting publications or software documentation.
o Neither the name of Rice University (RICE) nor the names of its
contributors may be used to endorse or promote products derived from
this software without specific prior written permission.
THIS SOFTWARE IS PROVIDED BY RICE AND CONTRIBUTORS "AS IS" AND ANY
EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL RICE OR CONTRIBUTORS BE
LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR
BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE
OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN
IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

@ -0,0 +1,45 @@
--- ARPACK/ARmake.inc~ 1996-04-26 21:12:57.000000000 +0200
+++ ARPACK/ARmake.inc 2003-07-19 11:57:10.000000000 +0200
@@ -25,7 +25,7 @@
# | other than your home directory. |
# %--------------------------------------%
#
-home = $(HOME)/ARPACK
+home = $(PWD)/.
#
# %--------------------------------------%
# | The platform identifier to suffix to |
@@ -43,7 +43,7 @@
UTILdir = $(home)/UTIL
SRCdir = $(home)/SRC
#
-DIRS = $(BLASdir) $(LAPACKdir) $(UTILdir) $(SRCdir)
+#DIRS = $(BLASdir) $(LAPACKdir) $(UTILdir) $(SRCdir)
#
# %-------------------------------------------------------------------%
# | Comment out the previous line and uncomment the following |
@@ -51,13 +51,13 @@
# | NOTE: ARPACK assumes the use of LAPACK version 2 codes. |
# %-------------------------------------------------------------------%
#
-#DIRS = $(UTILdir) $(SRCdir)
+DIRS = $(UTILdir) $(SRCdir)
#
# %---------------------------------------------------%
# | The name of the libraries to be created/linked to |
# %---------------------------------------------------%
#
-ARPACKLIB = $(home)/libarpack_$(PLAT).a
+ARPACKLIB = $(home)/libarpack.a
LAPACKLIB =
BLASLIB =
#
@@ -112,7 +112,7 @@
LN = ln
LNFLAGS = -s
-MAKE = /bin/make
+MAKE = make
RM = rm
RMFLAGS = -f

File diff suppressed because it is too large Load Diff

@ -0,0 +1,127 @@
%bcond_without gfortran
Summary: Fortran77 subroutines for solving large scale eigenvalue problems
Name: arpack
Version: 2.1
Release: 7%{?dist}
License: Freely distributable
Group: Development/Libraries
URL: http://www.caam.rice.edu/software/ARPACK/
Source0: http://www.caam.rice.edu/software/ARPACK/SRC/arpack96.tar.gz
Source1: http://www.caam.rice.edu/software/ARPACK/SRC/patch.tar.gz
Source2: http://www.caam.rice.edu/software/ARPACK/RiceBSD.doc
Source3: RiceBSD.txt
# https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=148107
Source4: clarification-note-by-authors.txt
Patch0: arpack-2.1-redhat.patch
# see http://www.ann.jussieu.fr/pipermail/freefempp/2006/000213.html
Patch1: arpack-second-bug.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
BuildRequires: %{?with_gfortran:gcc-gfortran}%{!?with_gfortran:/usr/bin/f77}
# The correct dependency would be the following, but it doesn't exist on RHEL4/3
#BuildRequires: lapack-devel
BuildRequires: %{_libdir}/liblapack.so
%description
ARPACK is a collection of Fortran77 subroutines designed to solve large
scale eigenvalue problems.
The package is designed to compute a few eigenvalues and corresponding
eigenvectors of a general n by n matrix A. It is most appropriate for
large sparse or structured matrices A where structured means that a
matrix-vector product w <- Av requires order n rather than the usual
order n**2 floating point operations. This software is based upon an
algorithmic variant of the Arnoldi process called the Implicitly
Restarted Arnoldi Method (IRAM).
%package devel
Summary: Files needed for developing arpack based applications
Group: Development/Libraries
Requires: arpack = %{version}-%{release}
%description devel
ARPACK is a collection of Fortran77 subroutines designed to solve
large scale eigenvalue problems. This package contains the so
library links used for building arpack based applications.
%package static
Summary: Static library for developing arpack based applications
Group: Development/Libraries
Requires: arpack-devel = %{version}-%{release}
%description static
ARPACK is a collection of Fortran77 subroutines designed to solve
large scale eigenvalue problems. This package contains the static
library and so links used for building arpack based applications.
%prep
%setup -q -b 1 -n ARPACK
%patch -p1 -b .rh
%patch1 -p1 -b .sb
mkdir static shared
%build
cd shared
for dir in ../SRC ../UTIL; do
make -f $dir/Makefile VPATH=$dir srcdir=$dir \
%{?with_gfortran:FC=gfortran} FFLAGS="%{optflags} -fPIC" \
single double complex complex16
done
gcc -shared -llapack -Wl,-soname,libarpack.so.2 -o libarpack.so.2.1 *.o
cd ..
cd static
for dir in ../SRC ../UTIL; do
make -f $dir/Makefile VPATH=$dir srcdir=$dir \
%{?with_gfortran:FC=gfortran} FFLAGS="%{optflags}" LDFLAGS="-s" \
all
done
ar rv libarpack.a *.o
ranlib libarpack.a
cd ..
%install
rm -rf %{buildroot}
mkdir -p %{buildroot}%{_libdir}
install -p -m644 static/libarpack.a %{buildroot}%{_libdir}
install -p -m755 shared/libarpack.so.2.1 %{buildroot}%{_libdir}
ln -s libarpack.so.2.1 %{buildroot}%{_libdir}/libarpack.so.2
ln -s libarpack.so.2 %{buildroot}%{_libdir}/libarpack.so
cp -p %{SOURCE2} %{SOURCE3} %{SOURCE4} .
%clean
rm -rf %{buildroot}
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root,-)
%doc RiceBSD.doc clarification-note-by-authors.txt
%{_libdir}/libarpack.so.*
%files devel
%defattr(-,root,root,-)
%doc DOCUMENTS EXAMPLES
%{_libdir}/libarpack.so
%files static
%{_libdir}/libarpack.a
%changelog
* Wed Oct 24 2007 Dominik 'Rathann' Mierzejewski <rpm@greysector.net> 2.1-7
- apply Frederic Hecht's patch for eigenvalue bug
- move static libs to separate package
* Mon Mar 26 2007 Axel Thimm <Axel.Thimm@ATrpms.net> - 2.1-6
- Add license and clarification note
- Add lapack support
* Thu Nov 9 2006 Axel Thimm <Axel.Thimm@ATrpms.net> - 2.1-4
- Freshen up for submitting to fedora extras.
- Fix permissions of so file.
- Add forgotten ldconfig
- Remove dot from summaries.
* Wed Jul 16 2003 Axel Thimm <Axel.Thimm@ATrpms.net>
- Initial build.

@ -0,0 +1,102 @@
X-Mozilla-Status: 0011
X-Mozilla-Status2: 00000000
Received: from zuk35exm65.ds.mot.com ([10.178.1.44]) by zuk35exm62.ds.mot.com with Microsoft SMTPSVC(6.0.3790.2709);
Tue, 13 Feb 2007 19:53:15 +0000
Received: from az33exr02.mot.com ([10.64.251.232]) by zuk35exm65.ds.mot.com with Microsoft SMTPSVC(6.0.3790.2709);
Tue, 13 Feb 2007 19:53:14 +0000
Received: from motgate3.mot.com (motgate3.mot.com [144.189.100.103])
by az33exr02.mot.com (8.13.1/8.13.0) with ESMTP id l1DJrDDS020683
for <David.Bateman@motorola.com>; Tue, 13 Feb 2007 13:53:13 -0600 (CST)
Received: from mail128.messagelabs.com (mail128.messagelabs.com [216.82.250.131])
by motgate3.mot.com (8.12.11/Motorola) with SMTP id l1DJr8gl023906
for <David.Bateman@motorola.com>; Tue, 13 Feb 2007 12:53:11 -0700 (MST)
X-VirusChecked: Checked
X-Env-Sender: sorensen@rice.edu
X-Msg-Ref: server-6.tower-128.messagelabs.com!1171396385!13383447!1
X-StarScan-Version: 5.5.10.7.1; banners=-,-,-
X-Originating-IP: [128.42.17.10]
X-SpamReason: No, hits=0.0 required=7.0 tests=
Received: (qmail 3872 invoked from network); 13 Feb 2007 19:53:05 -0000
Received: from caam.rice.edu (HELO caam.rice.edu) (128.42.17.10)
by server-6.tower-128.messagelabs.com with SMTP; 13 Feb 2007 19:53:05 -0000
Received: from localhost (localhost [127.0.0.1])
by caam.rice.edu (Postfix) with ESMTP id 64341153A7
for <David.Bateman@motorola.com>; Tue, 13 Feb 2007 13:53:04 -0600 (CST)
Received: from caam.rice.edu ([127.0.0.1])
by localhost (caam.rice.edu [127.0.0.1]) (amavisd-new, port 10024) with LMTP
id 23777-01-16 for <David.Bateman@motorola.com>;
Tue, 13 Feb 2007 13:52:59 -0600 (CST)
Received: from [128.42.21.177] (sorensenl400.caam.rice.edu [128.42.21.177])
by caam.rice.edu (Postfix) with ESMTP id 494E81539F
for <David.Bateman@motorola.com>; Tue, 13 Feb 2007 13:52:59 -0600 (CST)
Message-ID: <45D2171B.8030109@rice.edu>
Date: Tue, 13 Feb 2007 13:52:59 -0600
From: Dan Sorensen<sorensen@rice.edu>
User-Agent: Thunderbird 1.5.0.9 (Windows/20061207)
MIME-Version: 1.0
To: David Bateman<David.Bateman@motorola.com>
Subject: Re: ARPACK License Question
References: <457EE5B3.70402@ieee.org> <20070105114426.GI4860@neu.nirvana> <45B8CB2F.9030904@motorola.com>
In-Reply-To: <45B8CB2F.9030904@motorola.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
X-Virus-Scanned: by amavis-2.2.1 at caam.rice.edu
Return-Path: sorensen@rice.edu
X-OriginalArrivalTime: 13 Feb 2007 19:53:14.0831 (UTC) FILETIME=[994B7DF0:01C74FA8]
Dear Mr. Bateman
I apologize for not responding to this previously.
The clarification we discussed is the following
The clause in the license statement that states
>>Written notification is provided to the developers of intent to use this
>> software. Also, we ask that use of ARPACK is properly cited in any
>> resulting publications or software documentation.
has the following intension in your case.
We are asking for acknowledgment in FEDORA that ARPACK is
the software that underlies what corresponds to the "eigs" command.
There is no intention to pass on a requirement of notification of use
from users of FEDORA.
This is the understanding we have with MATLAB for example.
If the above note or a slight modification of it is not acceptable
for the purposes of using ARPACK in FEDORA, I will have to refer
you to the tech transfer department of Rice University as I explained
during our phone conversation.
Once again my apologies for the delay and I thank you for your
interest in ARPACK.
Best Regards
Dan Sorensen
David Bateman wrote:
> Dear Professor Sorensen,
>
> Perhaps you have not yet seen the e-mail below, and so I draw it to your
> attention. Can you please examine the request to modify the license of
> ARPACK in this mail belong to allow its inclusion in FEDORA and other
> similar open source linux distributions?
>
> As the author of the eigs function for Octave (www.octave.org) that uses
> ARPACK for its functionality, I'd hate to see my work not included in
> Octave due to this question not being resolved.
>
> Best Regards
> David
>
>

@ -0,0 +1,2 @@
fffaa970198b285676f4156cebc8626e arpack96.tar.gz
14830d758f195f272b8594a493501fa2 patch.tar.gz
Loading…
Cancel
Save