You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
206 lines
7.2 KiB
206 lines
7.2 KiB
%bcond_with bootstrap
|
|
|
|
Name: apiguardian
|
|
Version: 1.1.2
|
|
Release: 13%{?dist}
|
|
Summary: API Guardian Java annotation
|
|
License: Apache-2.0
|
|
URL: https://github.com/apiguardian-team/apiguardian
|
|
BuildArch: noarch
|
|
ExclusiveArch: %{java_arches} noarch
|
|
|
|
Source0: https://github.com/apiguardian-team/apiguardian/archive/r%{version}.tar.gz
|
|
|
|
Source100: https://repo1.maven.org/maven2/org/apiguardian/apiguardian-api/%{version}/apiguardian-api-%{version}.pom
|
|
|
|
%if %{with bootstrap}
|
|
BuildRequires: javapackages-bootstrap
|
|
%else
|
|
BuildRequires: maven-local
|
|
%endif
|
|
|
|
%description
|
|
API Guardian indicates the status of an API element and therefore its
|
|
level of stability as well. It is used to annotate public types,
|
|
methods, constructors, and fields within a framework or application in
|
|
order to publish their API status and level of stability and to
|
|
indicate how they are intended to be used by consumers of the API.
|
|
|
|
%package javadoc
|
|
Summary: Javadoc for %{name}
|
|
|
|
%description javadoc
|
|
API documentation for %{name}.
|
|
|
|
%prep
|
|
%setup -q -n apiguardian-r%{version}
|
|
find -name \*.jar -delete
|
|
cp -p %{SOURCE100} pom.xml
|
|
|
|
mv src/module/java/* src/main/java
|
|
|
|
# Inject OSGi manifest required by Eclipse
|
|
%pom_xpath_inject pom:project "
|
|
<build>
|
|
<pluginManagement>
|
|
<plugins>
|
|
<plugin>
|
|
<artifactId>maven-jar-plugin</artifactId>
|
|
<configuration>
|
|
<archive>
|
|
<manifestEntries>
|
|
<Implementation-Title>apiguardian-api</Implementation-Title>
|
|
<Implementation-Vendor>apiguardian.org</Implementation-Vendor>
|
|
<Implementation-Version>%{version}</Implementation-Version>
|
|
<Specification-Title>apiguardian-api</Specification-Title>
|
|
<Specification-Vendor>apiguardian.org</Specification-Vendor>
|
|
<Specification-Version>%{version}</Specification-Version>
|
|
<!-- OSGi metadata required by Eclipse -->
|
|
<Bundle-ManifestVersion>2</Bundle-ManifestVersion>
|
|
<Bundle-SymbolicName>org.apiguardian</Bundle-SymbolicName>
|
|
<Bundle-Version>%{version}</Bundle-Version>
|
|
<Export-Package>org.apiguardian.api;version=\"%{version}\"</Export-Package>
|
|
</manifestEntries>
|
|
</archive>
|
|
</configuration>
|
|
</plugin>
|
|
<plugin>
|
|
<groupId>org.apache.maven.plugins</groupId>
|
|
<artifactId>maven-compiler-plugin</artifactId>
|
|
<executions>
|
|
<execution>
|
|
<id>default-compile</id>
|
|
<goals>
|
|
<goal>compile</goal>
|
|
</goals>
|
|
<configuration>
|
|
<release>8</release>
|
|
<excludes>
|
|
<exclude>**/module-info.java</exclude>
|
|
</excludes>
|
|
</configuration>
|
|
</execution>
|
|
<execution>
|
|
<id>module-info</id>
|
|
<goals>
|
|
<goal>compile</goal>
|
|
</goals>
|
|
<configuration>
|
|
<release>9</release>
|
|
<includes>
|
|
<include>**/module-info.java</include>
|
|
</includes>
|
|
</configuration>
|
|
</execution>
|
|
</executions>
|
|
</plugin>
|
|
</plugins>
|
|
</pluginManagement>
|
|
</build>"
|
|
|
|
%build
|
|
%mvn_build
|
|
|
|
%install
|
|
%mvn_install
|
|
|
|
%files -f .mfiles
|
|
%license LICENSE
|
|
|
|
%files javadoc -f .mfiles-javadoc
|
|
%license LICENSE
|
|
|
|
%changelog
|
|
* Tue Oct 29 2024 Troy Dawson <tdawson@redhat.com> - 1.1.2-13
|
|
- Bump release for October 2024 mass rebuild:
|
|
Resolves: RHEL-64018
|
|
|
|
* Thu Aug 01 2024 Troy Dawson <tdawson@redhat.com> - 1.1.2-12
|
|
- Bump release for Aug 2024 java mass rebuild
|
|
|
|
* Mon Jun 24 2024 Troy Dawson <tdawson@redhat.com> - 1.1.2-11
|
|
- Bump release for June 2024 mass rebuild
|
|
|
|
* Mon Jan 22 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.2-10
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
|
|
|
* Fri Jan 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.2-9
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
|
|
|
* Fri Sep 01 2023 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.1.2-8
|
|
- Convert License tag to SPDX format
|
|
|
|
* Wed Jul 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.2-7
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
|
|
|
* Wed Feb 15 2023 Marian Koncek <mkoncek@redhat.com> - 1.1.2-6
|
|
- Build with module-info
|
|
|
|
* Wed Jan 18 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.2-5
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
|
|
|
* Wed Jul 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.2-4
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
|
|
|
* Sat Feb 05 2022 Jiri Vanek <jvanek@redhat.com> - 1.1.2-3
|
|
- Rebuilt for java-17-openjdk as system jdk
|
|
|
|
* Wed Jan 19 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.2-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
|
|
|
* Tue Nov 02 2021 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.1.2-1
|
|
- Update to upstream version 1.1.2
|
|
- Set explicit Java compiler source/target levels to 1.7
|
|
|
|
* Wed Jul 21 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.1-3
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
|
|
|
* Mon May 17 2021 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.1.1-2
|
|
- Bootstrap build
|
|
- Non-bootstrap build
|
|
|
|
* Mon Feb 01 2021 Fabio Valentini <decathorpe@gmail.com> - 1.1.1-1
|
|
- Update to version 1.1.1.
|
|
|
|
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-6
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
|
|
|
* Thu Jan 14 2021 Marian Koncek <mkoncek@redhat.com> - 1.1.1-1
|
|
- Update to upstream version 1.1.1
|
|
|
|
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-5
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
|
|
|
* Fri Jul 10 2020 Jiri Vanek <jvanek@redhat.com> - 1.1.0-4
|
|
- Rebuilt for JDK-11, see https://fedoraproject.org/wiki/Changes/Java11
|
|
|
|
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-3
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
|
|
|
* Tue Nov 05 2019 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.1.0-2
|
|
- Mass rebuild for javapackages-tools 201902
|
|
|
|
* Wed Jul 24 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
|
|
|
* Wed Jul 17 2019 Marian Koncek <mkoncek@redhat.com> - 1.1.0-1
|
|
- Update to upstream version 1.1.0
|
|
|
|
* Thu Jun 27 2019 Fabio Valentini <decathorpe@gmail.com> - 1.1.0-1
|
|
- Update to version 1.1.0.
|
|
|
|
* Fri May 24 2019 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.0.0-5
|
|
- Mass rebuild for javapackages-tools 201901
|
|
|
|
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.0-4
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
|
|
|
* Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.0-3
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
|
|
|
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.0-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
|
|
|
* Thu Sep 14 2017 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.0.0-1
|
|
- Initial packaging
|