You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
51 lines
1.6 KiB
51 lines
1.6 KiB
From c0d934651f0fb01687035c8750f0591ea8b5d0ee Mon Sep 17 00:00:00 2001
|
|
From: Jakub Filak <jfilak@redhat.com>
|
|
Date: Mon, 23 May 2016 14:28:40 +0200
|
|
Subject: [PATCH] build: update pkg modules for systemd
|
|
|
|
systemd-journal was dropped in systemd-230
|
|
|
|
Signed-off-by: Jakub Filak <jfilak@redhat.com>
|
|
---
|
|
src/CMakeLists.txt | 14 +++++++-------
|
|
1 file changed, 7 insertions(+), 7 deletions(-)
|
|
|
|
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
|
|
index 1d31602..36c9ce5 100644
|
|
--- a/src/CMakeLists.txt
|
|
+++ b/src/CMakeLists.txt
|
|
@@ -4,14 +4,14 @@ include_directories(${JAVA_INCLUDE_PATH} ${JAVA_INCLUDE_PATH2})
|
|
include_directories(${PC_LIBREPORT_INCLUDE_DIRS})
|
|
include_directories(${PC_ABRT_INCLUDE_DIRS})
|
|
|
|
-pkg_check_modules(PC_JOURNALD libsystemd-journal)
|
|
+pkg_check_modules(PC_SYSTEMD libsystemd)
|
|
|
|
-if (PC_JOURNALD_FOUND)
|
|
- include_directories(${PC_JOURNALD_INCLUDE_DIRS})
|
|
+if (PC_SYSTEMD_FOUND)
|
|
+ include_directories(${PC_SYSTEMD_INCLUDE_DIRS})
|
|
add_definitions(-DHAVE_SYSTEMD=1)
|
|
else()
|
|
add_definitions(-DHAVE_SYSTEMD=0)
|
|
-endif (PC_JOURNALD_FOUND)
|
|
+endif (PC_SYSTEMD_FOUND)
|
|
|
|
set(AbrtChecker_SRCS configuration.c abrt-checker.c
|
|
jthrowable_circular_buf.c jthread_map.c)
|
|
@@ -27,8 +27,8 @@ set_target_properties(
|
|
target_link_libraries(AbrtChecker ${PC_LIBREPORT_LIBRARIES})
|
|
target_link_libraries(AbrtChecker ${PC_ABRT_LIBRARIES})
|
|
|
|
-if (PC_JOURNALD_FOUND)
|
|
- target_link_libraries(AbrtChecker ${PC_JOURNALD_LIBRARIES})
|
|
-endif (PC_JOURNALD_FOUND)
|
|
+if (PC_SYSTEMD_FOUND)
|
|
+ target_link_libraries(AbrtChecker ${PC_SYSTEMD_LIBRARIES})
|
|
+endif (PC_SYSTEMD_FOUND)
|
|
|
|
install(TARGETS AbrtChecker DESTINATION ${JNIAGENTLIB_INSTALL_DIR})
|
|
--
|
|
2.21.0
|
|
|