- Remove format security patch - not needed anymore - Edit patches to be version specific - Renamed patch4 to be consistent with others - Minor spec file housekeepingepel9
parent
ce9ae0a47b
commit
622648544d
@ -1 +1,2 @@
|
||||
/superlu_4.3.tar.gz
|
||||
/superlu_5.1.1.tar.gz
|
||||
|
@ -1 +1 @@
|
||||
b72c6309f25e9660133007b82621ba7c superlu_4.3.tar.gz
|
||||
260a3cd90b2100122abff38587a8290a superlu_5.1.1.tar.gz
|
||||
|
@ -0,0 +1,12 @@
|
||||
--- SuperLU_5.1.1/MAKE_INC/make.linux.orig 2016-03-26 08:43:03.038994570 -0400
|
||||
+++ SuperLU_5.1.1/MAKE_INC/make.linux 2016-03-26 08:44:09.141092611 -0400
|
||||
@@ -46,7 +46,8 @@
|
||||
RANLIB = ranlib
|
||||
|
||||
CC = gcc
|
||||
-CFLAGS = -O3 -g
|
||||
+FPIC = -fPIC
|
||||
+CFLAGS = -O3 $(FPIC)
|
||||
NOOPTS =
|
||||
FORTRAN = gfortran #g77
|
||||
FFLAGS = -O2 -g -fopenmp
|
@ -0,0 +1,39 @@
|
||||
--- SuperLU_5.1.1/SRC/Makefile.orig 2016-03-26 08:47:18.885503561 -0400
|
||||
+++ SuperLU_5.1.1/SRC/Makefile 2016-03-26 08:52:10.512497969 -0400
|
||||
@@ -98,7 +98,7 @@
|
||||
ilu_zcolumn_dfs.o ilu_zpanel_dfs.o ilu_zcopy_to_ucol.o \
|
||||
ilu_zpivotL.o zdiagonal.o zlacon2.o dzsum1.o izmax1.o
|
||||
|
||||
-all: single double complex complex16
|
||||
+all: sharedlib
|
||||
|
||||
single: $(SLUSRC) $(ALLAUX) $(SCAUX)
|
||||
$(ARCH) $(ARCHFLAGS) $(SUPERLULIB) $(SLUSRC) $(ALLAUX) $(SCAUX)
|
||||
@@ -116,17 +116,23 @@
|
||||
$(ARCH) $(ARCHFLAGS) $(SUPERLULIB) $(ZLUSRC) $(ALLAUX) $(DZLAUX)
|
||||
$(RANLIB) $(SUPERLULIB)
|
||||
|
||||
+sharedlib: $(ALLAUX) $(LAAUX) $(SLASRC) $(DLASRC) $(CLASRC) $(ZLASRC) $(SCLAUX) $(DZLAUX) $(SLUSRC) $(DLUSRC) $(CLUSRC) $(ZLUSRC)
|
||||
+ $(CC) $(CFLAGS) $(LIBS) -shared -Wl,-soname,libsuperlu.so.5.1 -o libsuperlu.so.5.1 \
|
||||
+ $(ALLAUX) $(LAAUX) $(SLASRC) $(DLASRC) $(CLASRC) $(ZLASRC) $(SCLAUX) \
|
||||
+ $(DZLAUX) $(SLUSRC) $(DLUSRC) $(CLUSRC) $(ZLUSRC)
|
||||
+ ln -sf libsuperlu.so.5.1 libsuperlu.so
|
||||
+
|
||||
|
||||
##################################
|
||||
# Do not optimize these routines #
|
||||
##################################
|
||||
-smach.o: smach.c ; $(CC) -c $(NOOPTS) $(CDEFS) $<
|
||||
-dmach.o: dmach.c ; $(CC) -c $(NOOPTS) $(CDEFS) $<
|
||||
-superlu_timer.o: superlu_timer.c ; $(CC) -c $(NOOPTS) $<
|
||||
+slamch.o: slamch.c ; $(CC) $(FPIC) $(LIBS) -c $(NOOPTS) $(CDEFS) $<
|
||||
+dlamch.o: dlamch.c ; $(CC) $(FPIC) $(LIBS) -c $(NOOPTS) $(CDEFS) $<
|
||||
+superlu_timer.o: superlu_timer.c ; $(CC) $(FPIC) $(LIBS) -c $(NOOPTS) $<
|
||||
##################################
|
||||
|
||||
.c.o:
|
||||
- $(CC) $(CFLAGS) $(CDEFS) $(BLASDEF) -c $< $(VERBOSE)
|
||||
+ $(CC) $(CFLAGS) $(CDEFS) $(BLASDEF) $(LIBS) -c $< $(VERBOSE)
|
||||
|
||||
.f.o:
|
||||
$(FORTRAN) $(FFLAGS) -c $<
|
@ -0,0 +1,50 @@
|
||||
--- SuperLU_5.1.1/TESTING/Makefile.orig 2016-03-26 08:56:10.347188385 -0400
|
||||
+++ SuperLU_5.1.1/TESTING/Makefile 2016-03-26 08:58:39.763126530 -0400
|
||||
@@ -52,9 +52,9 @@
|
||||
|
||||
single: ./stest stest.out
|
||||
|
||||
-./stest: $(SLINTST) $(ALINTST) $(SUPERLULIB) $(TMGLIB)
|
||||
+./stest: $(SLINTST) $(ALINTST) $(TMGLIB)
|
||||
$(LOADER) $(LOADOPTS) $(SLINTST) $(ALINTST) \
|
||||
- $(TMGLIB) $(SUPERLULIB) $(BLASLIB) -lm -o $@
|
||||
+ $(TMGLIB) -Wl,-rpath,../SRC $(SUPERLULIB) $(BLASLIB) -lm -o $@
|
||||
|
||||
stest.out: stest stest.csh
|
||||
@echo Testing SINGLE PRECISION linear equation routines
|
||||
@@ -62,9 +62,9 @@
|
||||
|
||||
double: ./dtest dtest.out
|
||||
|
||||
-./dtest: $(DLINTST) $(ALINTST) $(SUPERLULIB) $(TMGLIB)
|
||||
+./dtest: $(DLINTST) $(ALINTST) $(TMGLIB)
|
||||
$(LOADER) $(LOADOPTS) $(DLINTST) $(ALINTST) \
|
||||
- $(TMGLIB) $(SUPERLULIB) $(BLASLIB) -lm -o $@
|
||||
+ $(TMGLIB) -Wl,-rpath,../SRC $(SUPERLULIB) $(BLASLIB) -lm -o $@
|
||||
|
||||
dtest.out: dtest dtest.csh
|
||||
@echo Testing DOUBLE PRECISION linear equation routines
|
||||
@@ -72,9 +72,9 @@
|
||||
|
||||
complex: ./ctest ctest.out
|
||||
|
||||
-./ctest: $(CLINTST) $(ALINTST) $(SUPERLULIB) $(TMGLIB)
|
||||
+./ctest: $(CLINTST) $(ALINTST) $(TMGLIB)
|
||||
$(LOADER) $(LOADOPTS) $(CLINTST) $(ALINTST) \
|
||||
- $(TMGLIB) $(SUPERLULIB) $(BLASLIB) -lm -o $@
|
||||
+ $(TMGLIB) -Wl,-rpath,../SRC $(SUPERLULIB) $(BLASLIB) -lm -o $@
|
||||
|
||||
ctest.out: ctest ctest.csh
|
||||
@echo Testing SINGLE COMPLEX linear equation routines
|
||||
@@ -82,9 +82,9 @@
|
||||
|
||||
complex16: ./ztest ztest.out
|
||||
|
||||
-./ztest: $(ZLINTST) $(ALINTST) $(SUPERLULIB) $(TMGLIB)
|
||||
+./ztest: $(ZLINTST) $(ALINTST) $(TMGLIB)
|
||||
$(LOADER) $(LOADOPTS) $(ZLINTST) $(ALINTST) \
|
||||
- $(TMGLIB) $(SUPERLULIB) $(BLASLIB) -lm -o $@
|
||||
+ $(TMGLIB) -Wl,-rpath,../SRC $(SUPERLULIB) $(BLASLIB) -lm -o $@
|
||||
|
||||
ztest.out: ztest ztest.csh
|
||||
@echo Testing DOUBLE COMPLEX linear equation routines
|
@ -0,0 +1,25 @@
|
||||
Description: Provide stubs for the two functions whose implementation is nonfree
|
||||
Author: Sébastien Villemot <sebastien@debian.org>
|
||||
Forwarded: not-needed
|
||||
Last-Update: 2013-11-27
|
||||
---
|
||||
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
|
||||
--- /dev/null
|
||||
+++ b/SRC/mc64ad.c
|
||||
@@ -0,0 +1,16 @@
|
||||
+#include <stdio.h>
|
||||
+#include <stdlib.h>
|
||||
+
|
||||
+void mc64id_(int *a)
|
||||
+{
|
||||
+ fprintf(stderr, "SuperLU: MC64 functionality not available (it uses non-free code). Aborting.\n");
|
||||
+ abort();
|
||||
+}
|
||||
+
|
||||
+void mc64ad_(int *a, int *b, int *c, int d[], int e[], double f[],
|
||||
+ int *g, int h[], int *i, int j[], int *k, double l[],
|
||||
+ int m[], int n[])
|
||||
+{
|
||||
+ fprintf(stderr, "SuperLU: MC64 functionality not available (it uses non-free code). Aborting.\n");
|
||||
+ abort();
|
||||
+}
|
Loading…
Reference in new issue