You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
PyQt-builder/SPECS/PyQt-builder.spec

54 lines
1.5 KiB

%global pypi_name PyQt-builder
%global srcname PyQt-builder
Name: %{srcname}
Version: 1.12.2
Release: 1%{?dist}
Summary: The PEP 517 compliant PyQt build system
License: GPLv2 or GPLv3
URL: https://www.riverbankcomputing.com/software/pyqt/
Source0: %{pypi_source}
BuildArch: noarch
BuildRequires: python3-devel
BuildRequires: python3dist(setuptools)
%description
PyQt-builder is the PEP 517 compliant build system for PyQt and projects that
extend PyQt. It extends the sip build system and uses Qt's qmake to perform the
actual compilation and installation of extension modules.Projects that use
PyQt- builder provide an appropriate pyproject.toml file and an optional
project.py.
%prep
%autosetup -n %{pypi_name}-%{version}
# Remove bundled egg-info
rm -rf %{pypi_name}.egg-info
%build
%py3_build
%install
%py3_install
# These dll files are from openssl and microsoft visiual studio
# While we can redistribute them, we don't have source and it's
# unlikely anyone will want to bundle a windows executable from linux.
rm -rf %{buildroot}/%{python3_sitelib}/pyqtbuild/bundle/dlls
%files
%license LICENSE-GPL2
%license LICENSE-GPL3
%{_bindir}/pyqt-bundle
%{_bindir}/pyqt-qt-wheel
%{python3_sitelib}/pyqtbuild
%{python3_sitelib}/PyQt_builder-%{version}-py%{python3_version}.egg-info
%changelog
* Thu Oct 05 2023 Arkady L. Shane <tigro@msvsphere-os.ru> - 1.12.2-1
- Rebuilt for MSVSphere 9.2
* Mon May 09 2022 Jan Grulich <jgrulich@redhat.com> - 1.12.2-1
- Initial package
Resolves: bz#2081238